Domain with externel mailserver

#1
Hello,

I have a little problem with one domain configured in ISPConfig.
Original this domain used the local mailserver und all worked well.
Then I changed to use an external mailserver ( "Options"->"Mailserver"->"external mailserver").
The problem now is, that ISPConfig doesn't remove the domain from /etc/postfix/virtual_domains.
So Postfix still thinks that all emails for this domain must delivered local.

How can I fix this without deleting the hole domain?

My ISPConfig version is the latest 2.2.24.

Many thanks & best regards,
martin
 
#4
Schon wieder ich... :eek:
Habe aber auch hierzu eine Frage.
Um zu gewährleisten das alle Domains die unter ISPConfig auf dem Server laufen auch untereinander Mail verschicken können müssen da alle Domains und Co-Domains auf Extern oder Lokal stehen?
Sorry wenn die Frage blöd ist aber ich habs nur soweit "begriffen", das wenn die Einstellung "Externer Mailserver" Aktiv ist auch nur dann versucht wird die Mail Extern zuzustellen sprich an den Server welcher über das DNS ermittelt wurde,richtig?
Folgendes Problem gibts derzeitig. Eine Domain die noch auf unserem alten Root liegt inkl. Mail, etc. aber schon auf dem neuen unter ISPConfig eingerichtet ist empfängt keine Mails welche von einer Domain kommen die es auf dem neuen Server mit ISPConfig schon gibt...
 

Till

Administrator
#5
Du musst alle Domains und co-domains auf externen Mailserver stellen, bei denen die Postfaächer nicht auf dem ispconfig server selbst liegen.
 
#6
Das war es. Danke Till.
Noch zwei Fragen hätte ich bzgl. der Mail geschichte.
1. Was hat der MX Eintrag für eine bedeutung wenn man den lokalen DNS Server gar nicht nutzt. Bin bei Hetzner und nutze die 3 NS Server von dort.
2. Derzeitig habe ich ein Problem mit einem Mailserver der ständig meine E-Mails ablehnt mit folgender begründung:

host mx1.domain.com[xx.xxx.xxx.xxx] said: 550-ptr
of yyy.yyy.yyy.yyy does not match the hostname () 550 for contact see
http://www.domain.com/ (in reply to RCPT TO command)
Das Problem ist schon das yyy.yyy.yyy.yyy zwar meiner IP entspricht aber meine Haupt IP des Servers ist und nicht die des Subnetzes unter welcher auch die Webseite(n) laufen.
 

Till

Administrator
#7
1) Du solltest dann überhaupt keine DNS Records auf dem lokalen Rechner einrichten.
2) Du musst von Hetzner den PTR Record für die IP auf den Hostnamen des Servers setzen lassen. mailservers versenden immer alle Mails unter ihrem eigenen Hostnamen, wie viele und Welche sonstigen Domains Du da drauf hast, spielt keine Rolle.
 

Till

Administrator
#9
Nein, sie dürfen garnicht erst gesetzt worden sein. Wenn Du sie doch gesetzt hattest, musst Du die DNS Zonen im DNS-Manager löschen und ein paar Minuten später den Papierkorb im DNS-Manager leeren.
 
#10
Danke für den Tipp. Habe alles so gemacht. Hoffentlich klappt weiterhin alles :)

Nun könnte man ja Bind komplett abschalten, oder spricht da was dagegen?

Edit: Habe übrigens gerade mal versucht im Zonenfile der Domain folgendes anzugeben:

xxx.xx.xx.xx.in-addr.arpa. 1285 IN PTR mail.domain.de.
Da meldet der NS aber es sei was falsch. Hast du eine erklärung hierfür?
 
Zuletzt bearbeitet:

Till

Administrator
#11
Ich vermute der PTR muss im Nameserver Deines Providers gesetzt werden, wie ich oben geschrieben habe. Nicht auf Deinem ISPConfig Server, da Dein Server nicht die IP's verwaltet, oder beziehst Du die Subnetzte selbst von der IANA und routest sie?
 
#12
Hallo Till,

diesen Eintrag

xxx.xx.xx.xx.in-addr.arpa. 1285 IN PTR mail.domain.de.
habe ich im Domain Robot bei Hetzner (sprich im Hetzner NS eingetragen) nicht bei mir auf dem Server.

oder beziehst Du die Subnetzte selbst von der IANA und routest sie
Wenn ich deine Frage richtig verstanden habe, ist die Antwort ja. Die Adressen sind auf mich registriert (RIPE).
 

Werbung

Top