Domains können nicht aufgerufen werden

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Succ, 4. Apr. 2011.

  1. Succ

    Succ New Member

    Hallo,
    ich habe Debian 6 und ISPconfig nach der Anleitung http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3 auf einem OVH-Server neu installiert. Die Installation war problemlos, keine Fehler aufgetreten, schien alles zu funktionieren.
    In ISPconfig habe ich dann einige Domains angelegt, einen User hinzugefügt, ebenfalls wieder ohne sichtbare Fehler. Nur kann ich die angelegten Domains nicht erreichen. Ein Ping auf die Domain ergibt "Domain nicht gefunden", die DNS-einträge sind aber auf die richtigen Nameserver eingestellt (xxx.kimsufi.com und ns.kimsufi.com). Ein Zonencheck mit http://www.afnic.fr/outils/zonecheck/form_en bringt den Fehler "Server doesn't listen/answer on port 53 for UDP protocol".
    Wie kann ich das beheben und gibt es sonst noch einiges, das ich beachten muss?

    Danke und viele Grüße
    Succ
     
  2. Till

    Till Administrator

    Dann ist es ein DNS Problem und nicht ein problem der Einrichtung der Domains in ISPConfig.
    Welchen DNS Server verwendest Du denn? Poste bitte mnal einen Screenhsot der DNS Zone und der DNS Records, die Du angelegt hast.
     
  3. Succ

    Succ New Member

    Hallo Till,
    danke für die rasche Antwort.

    Verwendete Nameserver
    DNS1 ks34694.kimsufi.com 213.251.174.84
    DNS2 ns.kimsufi.com 213.186.33.199

    Screenshots sind angefügt

    Es kann leicht sein, dass die Nameserverkonfiguration am Server nicht stimmt, ich kenne mich aber mit Linux nicht genug aus, um hier eventuelle Fehler beheben zu können. Anleitungen aus dem Web haben mir auch nicht richtig weitergeholfen.

    Gruß Succ
     

    Anhänge:

  4. Till

    Till Administrator

    sieht swoeit ok aus. teste die domain bitte mal mit:

    dig @localhost x10-svr.com
     
  5. Succ

    Succ New Member

    ; <<>> DiG 9.7.2-P3 <<>> @localhost x10-svr.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10114
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;x10-svr.com. IN A
    ;; ANSWER SECTION:
    x10-svr.com. 86400 IN A 213.251.174.84
    ;; AUTHORITY SECTION:
    x10-svr.com. 86400 IN NS ns.kimsufi.com.
    x10-svr.com. 86400 IN NS ks34694.kimsufi.com.
    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Apr 4 15:21:59 2011
    ;; MSG SIZE rcvd: 92
     
  6. Till

    Till Administrator

    Ok. Poste bitte mal die Ausgabe von:

    netstat -tap

    sowie die Ausgabe von:

    ls -la /etc/bind
     
  7. Succ

    Succ New Member

    netstat -tap
    root@ks34694:/# netstat -tap
    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:10024 *:* LISTEN 1354/amavisd (maste
    tcp 0 0 localhost.localdo:10025 *:* LISTEN 1258/master
    tcp 0 0 *:mysql *:* LISTEN 1053/mysqld
    tcp 0 0 localhost.locald:domain *:* LISTEN 2310/named
    tcp 0 0 *:ftp *:* LISTEN 2291/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 9172/sshd
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 2310/named
    tcp 0 0 *:smtp *:* LISTEN 1258/master
    tcp 0 0 localhost.localdo:59203 localhost.localdoma:ftp TIME_WAIT -
    tcp 0 0 localhost.localdo:55954 localhost.localdoma:www TIME_WAIT -
    tcp 0 0 localhost.localdo:57553 localhost.locald:domain TIME_WAIT -
    tcp 0 52 ks34694.kimsufi.com:ssh 188.21.209.122:58094 VERBUNDEN 12737/0
    tcp6 0 0 [::]pop3 [::]:* LISTEN 2220/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 2192/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 2379/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 2379/apache2
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 2379/apache2
    tcp6 0 0 ip6-localhost:domain [::]:* LISTEN 2310/named
    tcp6 0 0 [::]:ftp [::]:* LISTEN 2291/pure-ftpd (SER
    tcp6 0 0 [::]:ssh [::]:* LISTEN 9172/sshd
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 2310/named
    tcp6 0 0 [::]:https [::]:* LISTEN 2379/apache2
    tcp6 0 0 [::]:imaps [::]:* LISTEN 2209/couriertcpd
    tcp6 0 0 [::]pop3s [::]:* LISTEN 2237/couriertcpd

    ls -la /etc/bind
    root@ks34694:/# ls -la /etc/bind
    insgesamt 76
    drwxr-sr-x 3 root bind 4096 17. Mär 21:06 .
    drwxr-xr-x 101 root root 4096 18. Mär 08:16 ..
    -rw-r--r-- 1 root root 665 2. Dez 01:45 bind.keys
    -rw-r--r-- 1 root root 237 2. Dez 01:45 db.0
    -rw-r--r-- 1 root root 271 2. Dez 01:45 db.127
    -rw-r--r-- 1 root root 237 2. Dez 01:45 db.255
    -rw-r--r-- 1 root root 353 2. Dez 01:45 db.empty
    -rw-r--r-- 1 root root 270 2. Dez 01:45 db.local
    -rw-r--r-- 1 root root 2994 2. Dez 01:45 db.root
    -rw-r--r-- 1 root bind 463 2. Dez 01:45 named.conf
    -rw-r--r-- 1 root bind 490 2. Dez 01:45 named.conf.default-zones
    -rw-r--r-- 1 root bind 376 17. Mär 21:11 named.conf.local
    -rw-r--r-- 1 root bind 632 30. Dez 17:22 named.conf.options
    -rw-r--r-- 1 root bind 668 17. Mär 18:19 pri.flirtarea.at
    -rw-r--r-- 1 root bind 650 17. Mär 21:11 pri.pihoco.at
    -rw-r--r-- 1 root bind 662 17. Mär 21:04 pri.x10-svr.com
    -rw-r----- 1 bind bind 77 30. Dez 16:43 rndc.key
    drwxr-s--- 2 root bind 4096 15. Mär 18:17 slave
    -rw-r--r-- 1 root root 1317 2. Dez 01:45 zones.rfc1918
     
  8. Till

    Till Administrator

    Der BIND auf Deinem Server scheint so konfiguriert zu sein, dass er nur aif localhost läuft. Daher kann er auch keine externen Anfragen benatworten.

    Poste bitte mal den Inhalt der Dateien:

    named.conf
    named.conf.options
    pri.x10-svr.com
     
  9. Succ

    Succ New Member

    Hallo Till,
    hier der Inhalt der Dateien:

    named.conf
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    include "/etc/bind/named.conf.options";
    include "/etc/bind/named.conf.local";
    include "/etc/bind/named.conf.default-zones";


    named.conf.options
    options {
    directory "/var/cache/bind";
    // If there is a firewall between you and nameservers you want
    // to talk to, you may need to fix the firewall to allow multiple
    // ports to talk. See http://www.kb.cert.org/vuls/id/800113
    // If your ISP provided one or more IP addresses for stable
    // nameservers, you probably want to use them as forwarders.
    // Uncomment the following block, and insert the addresses replacing
    // the all-0's placeholder.
    // forwarders {
    // 0.0.0.0;
    // };
    auth-nxdomain no; # conform to RFC1035
    listen-on-v6 { ::1; };
    listen-on { 127.0.0.1; };
    allow-recursion { 127.0.0.1; }


    pri.x10-svr.com
    $TTL 86400
    @ IN SOA ks34694.kimsufi.com. info.x10-svr.com. (
    2011031701 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;
    mail A 213.251.174.84
    www A 213.251.174.84
    x10-svr.com. A 213.251.174.84
    x10-svr.com. MX 10 mail.x10-svr.com.
    x10-svr.com. NS ks34694.kimsufi.com.
    x10-svr.com. NS ns.kimsufi.com.
     
  10. Till

    Till Administrator

    ändere bitte mal die Zeilen in der named.conf.options von:

    listen-on-v6 { ::1; };
    listen-on { 127.0.0.1; };

    in:

    listen-on-v6 { any; };
    listen-on { any; };

    und starte bind neu.
     
  11. Succ

    Succ New Member

    Hallo Till,
    herzlichen Dank für deine Hilfe und deine Geduld.
    Funktioniert !!!!

    Viele Grüße
    Succ
     

Diese Seite empfehlen