Domainverwaltung und Munitsop Veyton

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von torstenv, 17. Aug. 2014.

  1. torstenv

    torstenv New Member

    Hallo Community,
    ich benutze die Multishop-Webshop-Software xtc Veyton.
    Wir sind nun auf einen neuen Server umgezogen und dieser hat ISPConfig als Oberfläche.
    Allerdings schaffe ich es nicht, die verschiedenen Domains richtig in ISPC einzubinden. Gibt es hier einen Profi, der mir da helfen kann, ich bin schon am Verweifeln :-(

    VG,

    Torsten
     
  2. robotto7831a

    robotto7831a Member

    Wenn Du jetzt noch eine Fehlermeldung lieferst oder das Problem beschreibst, dann kann dir vielleicht auch jemand helfen.
     
  3. torstenv

    torstenv New Member

    hi, das ganze ist etwas kompliziert...
    Also, zuerst einnmal, wie es mal war...
    Eine Domain im Multishopsystem ist z.B. www.scheffner-baselbedarf.de
    Ich hatte auf dem alten Server Confixx.
    Ich hbe in der DNS-Verwaltung einfach die IP des "Hauptshops" megahobby - Der grosse Bastelfachmarkt im Internet mit einem A_Record eingetragen und in confixx nix.
    Das hat so wunderbar funktioniert.

    Nun habe ich die neue IP von megahobby.de (funktioniert) in die DNS der www.scheffner-bastelbedarfde eingetragen und eine Alias-Domain (megahobby als Hauptdomain) bei ISPC eingetragen...
    Aber beim Aufrufen der Domain lande ich auf einer Standard-Index-Seite...


    Ein anderer Fall ist, das ein Domaininhaber siene Domain selber hostet.
    Diesem habe ich "früher" auch die IP von megahobby.de gegeben und auch die bitte um die einrichtung eines A-Records.
    Das funktionierte auch immer.
    Aber bim Aufruf von z.B. kreativplus-onlineshop.de erscheint auch wieder nur die StandartIndex-Seite...

    So, ich hoffe, das ist eingermassen verständlich und Ihr könnt mir bitte helfen !

    lg,

    Torsten
     
  4. nowayback

    nowayback Well-Known Member

    Hi,

    du legst in ISPConfig eine Website an mit einer Domain von deinem Multishopsystem. Alle weiteren Domains die auch auf den selben Shop zeigen sollen, legst du als Aliasdomain an.

    Alle Domains brauchen einen A-Record, der auf die IP des Servers zeigt. Wenn E-Mails auch über den Server laufen sollen, dann benötigst du natürlich auch noch die MX-Records. Diese Einträge setzt du dort, wo du die Domain erworben hast. Alternativ dazu kannst du dort, wo du die Domain erworben hast, auch deine eigenen DNS Server, falls vorhanden, angeben (z.B. die IP vom ISPConfig Server) und dann dort alles anlegen (oder durch ISPConfig anlegen lassen).

    Damit sollte dann auch schon alles funktionieren.

    Beachte bitte, zwischen dem Anlegen und Testen mindestens 1 Minute zu warten, damit die Änderungen übernommen werden. Außerdem kann es eine Weile dauern bis DNS Einträge sich "rumgesprochen" haben. Hier hilft nur Geduld.

    Grüße
    nwb
     
  5. torstenv

    torstenv New Member

    Hallo,

    vielen Dank für die Antwort.
    Habe ich auch genau so gemacht, aber bei den Aliasdomins kommt immer nur die Standart-Index-Seite..
    Ich habe keine Ahnung mehr, woran das liegen soll :-(
     
  6. wotan2005

    wotan2005 Member

    Wenn die Domains echte sind, dann fällt mir erst mal folgendes auf:
    Das sieht schon mal gut aus.
    Das sieht zu mindestens was die Nameserver anbelangt schon mal alles richtig aus.
     
    Zuletzt bearbeitet: 18. Aug. 2014
  7. torstenv

    torstenv New Member

    Hi,

    das ist gut, oder ?!?!?!

    Ist es wichtig, das die Hauptdomain im Verzeichnis[FONT=&quot]/web/shop/veyton_4013/ liegt, also nicht direkt in der 1. Ebene ?
    Muss da eventuell auch eine Weiterleitung in den Alias-Domains eingegeben werden ?
    Ausserdem kommt eine Meldung in der Domainkonfiguration bei megahobby: [/FONT]
    ERROR

    Domain muss eindeutig sein
    Es existiert bereits eine Subdomain mit diesen Einstellungen.[FONT=&quot]

    Aber ich habe keine Subdomins, nur Alias, und da ist megahobby.de ja das Ziel..
    VG,

    Torsten



    [/FONT]
     
  8. Till

    Till Administrator

    Ja.

    Dann musst Du auch für die Aliasdomaisn Weiterleitungen einrichten.

    Du versuchts gerade eine webseitem, subdomain oder aliasdomain anzulegen die es bereits im system gibt, dass kann nicht gehen denn sonst wüsste apache ja nicht welceh Inhalte er ausliferns soll wenn es z.b. 2 webseiten "domain.tld" gibt.
     
  9. torstenv

    torstenv New Member

    Hallo, es gibt die domain megahobby.de
    Diese ist unter Webseiten eingetragen.

    Dann habe ich Aliasdomains angelegt (z.B. scheffner-bastelbedarf.de) und als Hauptwebseite megahobby.de ausgewählt.Es sind also eigentlich keine 2 Seiten megahobby.de angelegt... oder Zält die Hauptseite beim Alias auch ?

    Dann habe ich als Weiterleitung /web/shop/veyton_4013/ eingetragen.
    Nun landet die Seite auf megahobby.de, aber eigentlich sollte da eine Seite mit dem Layout von scheffner-bastelbedarf.de aufgehen... :-(

    lg,

    Torsten
     

Diese Seite empfehlen