Dovecot-Cluster

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von darkness_08, 3. Sep. 2016.

  1. darkness_08

    darkness_08 Member

    Hallo,

    ich habe auf einer Mirror-Installation versucht eine Dovecot-Clusterinstallation durchzuführen.
    Leider bekomme ich es nicht hin, das die Mails auch synchronisiert werden.
    Code:
    doveadm sync -A -f tcp:node2
    läuft ohne Fehler durch.

    Code:
    doveadm replicator status '*'
    zeigt mir zwar alle Nutzer. Aber unter full sync steht >1 Stunde.
    Auf dem 2. Server werden auch keine Mail synchronisiert
    Vorgegangen bin ich nach diesen Anleitungen:
    https://blog.schaal-24.de/uncategorized/mails-mit-dovecot-ueber-tcp-syncen/
    http://wiki.dovecot.org/Replication

    Code:
    doveadm replicator status
    liefert:

    Wo/Was könnte ich denn noch anpassen?
     
  2. florian030

    florian030 Member

    Wo ist jetzt das Problem? Die Ausgabe von doveadm replicator status ist völlig ok. Du kannst auf der jeweiligen Platte in /var/vmail/domain/user/Maildir/new nachsehen, ob eine neue Mail auf beiden Server ankommt. Dazu solltest Du aber keine IMAP-Verbindung offen haben.
     
  3. darkness_08

    darkness_08 Member

    Ah, ich habe immer unter /var/vmail/domain/user/Maildir/cur geschaut.
    Jetzt scheint es aber zu klappen.

    Danke
     
  4. florian030

    florian030 Member

    cur ist genau so synchron wie der Rest. Wenn Du auf Server die Mail abgerufen hast, liegt sie dort nur nicht mehr in new.
     

Diese Seite empfehlen