dovecot + pam FEHLER

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Sigix, 23. Aug. 2013.

  1. Sigix

    Sigix Member

    Hallo,

    ich habe irgendwo einen Fehler und finde die Lösung nicht!

    (Debian wheezy)

    Anmelden am Posteingangsserver funktioniert

    Hier mein auth.log

    Aug 23 12:13:30 DBLSR01 auth: pam_unix(dovecot:auth): check pass; user unknown
    Aug 23 12:13:30 DBLSR01 auth: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=mannersdorf@example.com rhost=193.170.233.xxx
    Aug 23 12:14:00 DBLSR01 auth: pam_unix(dovecot:auth): check pass; user unknown
    Aug 23 12:14:00 DBLSR01 auth: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=mischendorf@example.com rhost=193.170.233.xxx

    meine dovecot.conf

    protocols = imap imaps pop3 pop3s
    disable_plaintext_auth = no
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    login_process_per_connection = yes
    mail_location = maildir:/home/vmail/%d/%n/
    login_processes_count = 3
    login_max_processes_count = 128
    login_max_connections = 256

    ssl_cert_file = /etc/dovecot/dovecot.pem
    ssl_key_file = /etc/dovecot/private/dovecot.pem

    namespace private {
    # hidden = yes
    separator = .
    prefix = INBOX.
    inbox = yes
    }

    mail_privileged_group = mail
    mail_debug = no

    protocol lda {
    rejection_subject = Email konnte nicht zugestellt werden
    rejection_reason = Ihre Email an <%t> konnte nicht zugestellt werden:%nDie Mailbox ist leider voll. Bitte informieren Sie den Empfaenger.
    log_path = /home/vmail/dovecot-deliver.log
    auth_socket_path = /var/run/dovecot/auth-master
    postmaster_address = office@sx-it.com
    mail_plugins = quota sieve
    # global_script_path = /home/vmail/globalsieverc
    # sieve_global_path = /home/vmail/globalsieverc
    }

    protocol pop3 {
    #mail_executable = /usr/lib/dovecot/mypop3
    pop3_uidl_format = %08Xu%08Xv
    mail_plugins = quota
    }

    protocol imap {
    mail_plugins = quota imap_quota
    }


    auth default {
    mechanisms = plain login
    #user = root

    passdb sql {
    args = /etc/dovecot/dovecot-sql.conf
    }

    userdb static {
    args = uid=5000 gid=5000 home=/home/vmail/%d/%n allow_all_users=yes
    }
    socket listen {
    master {
    path = /var/run/dovecot/auth-master
    mode = 0600
    user = vmail
    }

    client {
    path = /var/spool/postfix/private/auth
    mode = 0660
    user = postfix
    group = postfix
    }
    }
    }

    plugin {
    quota = maildir:User quota
    quota_rule = *:storage=100MB
    sieve_global_path = /home/vmail/globalsieverc
    }

    Kann mir wer helfen???
     
  2. magenbrot

    magenbrot Member

    wie sieht deine /etc/dovecot/dovecot-sql.conf aus. Funktioniert der user_ und password_query so wie er dort drinsteht wenn du es manuell testest (mysql-shell)?
     
  3. Sigix

    Sigix Member

    Hier der Auszug:

    driver = mysql
    connect = host=127.0.0.1 dbname=mailserver user=mail_admin password=*********
    default_pass_scheme = CRYPT
    password_query = SELECT email as user, password FROM view_users WHERE email='%u';

    Ja funktioniert!
     
  4. Sigix

    Sigix Member

    Was kann ich noch testen oder machen????
     
  5. Sigix

    Sigix Member

    Ich habe jetzt anstatt pam auf SASL umgestellt ,...jetzt funktioniert alles!
    Danke
     

Diese Seite empfehlen