dovecot/postfix (user unknown)

Dieses Thema im Forum "Allgemein" wurde erstellt von thomasde, 29. Dez. 2012.

  1. thomasde

    thomasde New Member

    Hi,
    ich hab mit ispconfig 3 Domain und mail eingerichtet eine Catchallin der mail.log hab ich das gefunden! weil der empfang von mails nicht geht

    Code:
    Dec 29 10:40:36 server1 postfix/pipe[11763]: 88D833D6D38: to=<info@xxx.com>, orig_to=<test@xxx.com>, relay=dovecot, delay=0.02, delays=0.01/0/0/0.01, dsn=5.1.1, status=bounced (user unknown) Dec 29 10:40:36 server1 postfix/cleanup[11756]: 8D5543D7442: message-id=<20121229094036.8D5543D7442@server1.xxx.com> Dec 29 10:40:36 server1 postfix/qmgr[10417]: 8D5543D7442: from=<>, size=5427, nrcpt=1 (queue active) Dec 29 10:40:36 server1 postfix/bounce[11765]: 88D833D6D38: sender non-delivery notification: 8D5543D7442 Dec 29 10:40:36 server1 postfix/qmgr[10417]: 88D833D6D38: removed
    kann mir einer sagen wo das Problem liegt? hab schon eine menge gefunden aber nichts
    hat was gebracht....

    wenn ihr noch was braucht bitte sagen

    hoffe es kann mir einer helfen

    hab ich ein haufen mails im root liegen


    Code:
     Out: 220 server1.xxx.com ESMTP Postfix (Debian/GNU)
     In:  EHLO localhost
     Out: 250-server1.xxx.com
     Out: 250-PIPELINING
     Out: 250-SIZE 18446744073708503040
     Out: 250-VRFY
     Out: 250-ETRN
     Out: 250-STARTTLS
     Out: 250-AUTH PLAIN LOGIN
     Out: 250-AUTH=PLAIN LOGIN
     Out: 250-ENHANCEDSTATUSCODES
     Out: 250-8BITMIME
     Out: 250 DSN
     In:  MAIL FROM:<root@server1.xxx.com> BODY=7BIT
     Out: 452 4.3.1 Insufficient system storage
     In:  RCPT TO:<root@server1.xxx.com> ORCPT=rfc822;root
     Out: 503 5.5.1 Error: need MAIL command
     In:  DATA
     Out: 503 5.5.1 Error: need RCPT command
     In:  RSET
     Out: 250 2.0.0 Ok
     In:  QUIT
     Out: 221 2.0.0 Bye
    Prüfung....

    ~df
    Code:
    Dateisystem          1KâBlöcke   Benutzt Verfügbar Ben% Eingehängt auf
    /dev/sda1             79177624   2014020  73141588   3% /
    tmpfs                  1030540         0   1030540   0% /lib/init/rw
    udev                   1025696       120   1025576   1% /dev
    tmpfs                  1030540         0   1030540   0% /dev/shm
    ~df -h
    Code:
    Dateisystem           Size  Used Avail Use% Eingehängt auf
    /dev/sda1              76G  2,0G   70G   3% /
    tmpfs                1007M     0 1007M   0% /lib/init/rw
    udev                 1002M  120K 1002M   1% /dev
    tmpfs                1007M     0 1007M   0% /dev/shm
    ~free -m
    Code:
                 total       used       free     shared    buffers     cached
    Mem:          2012       1202        810          0        101        561
    -/+ buffers/cache:        539       1473
    Swap:         3361          0       3361
    ~postconf -n
    Code:
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    append_dot_mydomain = no
    biff = no
    body_checks = regexp:/etc/postfix/body_checks
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    content_filter = amavis:[127.0.0.1]:10024
    header_checks = regexp:/etc/postfix/header_checks
    html_directory = /usr/share/doc/postfix/html
    inet_interfaces = all
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 51200000
    message_size_limit = 51200000
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    mydestination = server1.1a-cams.com, localhost, localhost.localdomain
    myhostname = server1.1a-cams.com
    mynetworks = 127.0.0.0/8 [::1]/128
    myorigin = /etc/mailname
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    owner_request_special = no
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    readme_directory = /usr/share/doc/postfix
    receive_override_options = no_address_mappings
    recipient_delimiter = +
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    relayhost =
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_client_message_rate_limit = 100
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sasl_path = private/auth
    smtpd_sasl_type = dovecot
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_tls_security_level = may
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_use_tls = yes
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
    virtual_gid_maps = static:5000
    virtual_mailbox_base = /var/vmail
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_transport = dovecot
    virtual_uid_maps = static:5000
    ist doch genug platz ich verstehe das nicht!


    meine main.cf
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = server1.1a-cams.com
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = server1.1a-cams.com, localhost, localhost.localdomain
    relayhost = 
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 51200000
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains = 
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 51200000
     
    Zuletzt bearbeitet: 29. Dez. 2012
  2. thomasde

    thomasde New Member

    Kann mir keiner helfen?:confused:
     
  3. Till

    Till Administrator

    Was steht in /etc/mailname ?
     
  4. thomasde

    thomasde New Member

    hallo

    Danke für die Antwort

    das steht nur der servername

    server1.xxxx.com

    mehr nicht
     
  5. Till

    Till Administrator

    Das ist ok, wenn dort die domain der nicht funktionerenden emailadresse gestanden hätte, dann wäre das die Ursache gewesen.

    Geht der Empfang denn für eine normale mailbox, ein catchall ist immer eine schlechte Lösung um allgemeine Postfix Probleme zu diagnostizieren.
     
  6. thomasde

    thomasde New Member

    Ja der Senden geht ohne Probleme

    kann nur nichts Empfangen kommt gleich zurück

    Code:
    This is the mail system at host server1.xxx.com.
    
    I'm sorry to have to  inform you that your message could not
    be delivered to one or more  recipients. It's attached below.
    
    For further assistance, please send mail  to postmaster.
    
    If you do so, please include this problem report. You  can
    delete your own text from the attached returned  message.
    
                       The mail system
    
    <[EMAIL="werbmaster@1a-cams.com"]werbmaster@xxx.com[/EMAIL]> (expanded  from <[EMAIL="webmaster@1a-cams.com"]webmaster@xxx.com[/EMAIL]>):  user unknown
    
     
  7. Till

    Till Administrator

    Ok, ist die mailbox wirklich aktiv? Also ist die Checkbox bei "aktiviere empfang" in den mailbox einstellungen ist gesetzt und bei der email domain ist die checkbox bei "Aktiv" auch gesetzt?

    Erhältst Du irgendwelche Fehler im mail.log wenn Du postfix neu startest?

    Nach welche Anleitung hast Du den Server installiert und war der Server vorher leer oder war ein anderes controlpanel installiert oder bereits ein mailserver konfiguriert?

    Wenn das obige ok ist, dann gehe wie folgt vor:

    Logge Dich in webmail mit genau dieser adresse ein und sende eine email an dich selbst, also die emailadresse mit der Du in webmail eingeloggt bist. Dann warte eine Minute, wenn die emil nicht angekommen ist poste alle Zeilen aus dem mail.log (/var/log/mail.log die bei der einloggen und versende Aktion neu hinzugekommen sind.
     
  8. thomasde

    thomasde New Member

    Ja, Ist bei allen Aktiv
    einen Fehler bei ein Neustart erhalte ich nicht...
    nur das ist mir aufgefallen
    Code:
    Dec 29 11:25:42 server1 amavis[1823]: Net::Server: Group Not Defined.  Defaulting to EGID '114 114' 
    Dec 29 11:25:42 server1 amavis[1823]: Net::Server: User Not Defined. Defaulting to EUID '109'
    das ist die Fehlermeldung beim Empfang
    (user unknown)!?
    Code:
    Dec 29 18:31:31 server1 postfix/pipe[2577]: 3E5713D74AC: to=<webmaster@xxx.com>, relay=dovecot, delay=0.2, delays=0.01/0.01/0/0.18, dsn=5.1.1, status=bounced (user unknown)
     Dec 29 18:31:31 server1 postfix/cleanup[2567]: 6E6873D74AD: message-id=<20121229173131.6E6873D74AD@server1.xxx.com> 
    Dec 29 18:31:31 server1 postfix/qmgr[2303]: 6E6873D74AD: from=<>, size=5389, nrcpt=1 (queue active) 
    Dec 29 18:31:31 server1 postfix/bounce[2579]: 3E5713D74AC: sender non-delivery notification: 6E6873D74AD 
    Dec 29 18:31:31 server1 postfix/qmgr[2303]: 3E5713D74AC: removed
    Nach dieser Anleitung
    HowtoForge Linux Tutorials » Der Perfekte Server - Debian Squeeze (Debian 6.0) mit BIND & Dovecot [ISPConfig 3]
    Werde ich mal machen
     
  9. thomasde

    thomasde New Member

    So hab ich jetzt gemacht

    Code:
    Dec 29 19:28:20 server1 postfix/smtpd[4564]: connect from localhost[127.0.0.1] Dec 29 19:28:20 server1 postfix/smtpd[4564]: 3A28C3D7564: client=localhost[127.0.0.1]
    Dec 29 19:28:20 server1 postfix/cleanup[4558]: 3A28C3D7564: message-id=<4ebb846f538d0eea64f46b27efc90fc0.squirrel@server1.xxxx.com> 
    Dec 29 19:28:20 server1 postfix/qmgr[2303]: 3A28C3D7564: from=<mail1acams@server1.xx.com>, size=1203, nrcpt=1 (queue active) Dec 29 19:28:20 server1 postfix/smtpd[4564]: disconnect from localhost[127.0.0.1] 
    Dec 29 19:28:20 server1 amavis[2036]: (02036-03) Passed CLEAN, LOCAL [127.0.0.1] [94.135.141.166] <mail1acams@server1.xxx.com> -> <info@xxx.com>, Message-ID: <4ebb846f538d0eea64f46b27efc90fc0.squirrel@server1.xxx.com>, mail_id: 6CJmBggr7NGm, Hits: -1, size: 750, queued_as: 3A28C3D7564, 472 ms 
    Dec 29 19:28:20 server1 postfix/smtp[4559]: 9FF9F3D755E: to=<info@xxx.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.61, delays=0.13/0/0/0.47, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=02036-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3A28C3D7564) 
    Dec 29 19:28:20 server1 postfix/qmgr[2303]: 9FF9F3D755E: removed Dec 29 19:28:20 server1 postfix/pipe[4565]: 3A28C3D7564: to=<werbmaster@xxx.com>, orig_to=<info@xxx.com>, relay=dovecot, delay=0.03, delays=0.01/0.01/0/0.01, dsn=5.1.1, status=bounced (user unknown) 
    Dec 29 19:28:20 server1 postfix/cleanup[4558]: 406283D7568: message-id=<20121229182820.406283D7568@server1.xxx.com> 
    Dec 29 19:28:20 server1 postfix/bounce[4567]: 3A28C3D7564: sender non-delivery notification: 406283D7568 
    Dec 29 19:28:20 server1 postfix/qmgr[2303]: 406283D7568: from=<>, size=3127, nrcpt=1 (queue active) 
    Dec 29 19:28:20 server1 postfix/qmgr[2303]: 3A28C3D7564: removed 
    Dec 29 19:28:20 server1 postfix/local[4569]: 406283D7568: to=<mail1acams@server1.1a-cams.com>, relay=local, delay=0.01, delays=0/0/0/0, dsn=5.1.1, status=bounced (unknown user: "mailusername") 
    Dec 29 19:28:20 server1 postfix/qmgr[2303]: 406283D7568: removed
    
    

    wo ich mich bei webmail eingelogt habe kann diese Fehlermeldung
    Code:
    [B][COLOR=#cc0000]ERROR: Bad or malformed request.[/COLOR][/B][COLOR=#cc0000]
    Query: FETCH 0 (FLAGS BODYSTRUCTURE)
    Server responded: No mailbox selected.[/COLOR]
     
    Zuletzt bearbeitet: 29. Dez. 2012
  10. Till

    Till Administrator

    Sind in ispconfig im monitor noch jobs in der jobqueue gelistet?
     
  11. thomasde

    thomasde New Member

    Hallo

    Danke für deine antwort hab den Server neu aufgesetzt mit ispcp Omega
    und es geht jetzt alles

    Danke für deine Zeit u. Hilfe.....

    LG
    Thomas
     

Diese Seite empfehlen