E-Mail Empfang: Alles landet in einer Datei

#1
Guten Morgen.

Habe nach dem Tutorial einen eben solchen Server erfolgreich installiert. Der Login über IMAP/IMAPS sowie SMTP/SMTPS funktioniert einwandfrei, E-Mails versenden geht auch wunderbar. Der Anleitung wurde exakt gefolgt, bis auf den Part mit DNS und FTP da ich beides auf dieser Maschine nicht brauche.

Empfangen gab es anfangs Probleme mit einer Fehlermeldung
Code:
(temporary failure. Command output: /usr/bin/maildrop: Home directory owned by wrong user. )
welche ich damit gelöst habe dem Ordner /var/vmail mit
Code:
chown vmail:vmail /var/vmail
die Rechte darauf zu geben. Zumindest hielt ich das zu dem Zeitpunkt für eine gute Idee... :confused:

Der Server nimmt jetzt zwar E-Mails an die ich von extern schicke und laut Logfile werden diese auch zugestellt
Code:
Dec 2 05:02:35 mailsrv postfix/pipe[2573]: A0B0440ABE: to=, relay=maildrop, delay=0.06, delays=0/0.01/0/0.05, dsn=2.0.0, status=sent (delivered via maildrop service)
nur sie tauchen nicht im Postfach des Users auf.
Habe mir dann das /var/vmail Verzeichnis angesehen und musste feststellen, dass es dort eine Datei namens Maildir gibt in der bereits fleißig E-Mails auch schon von anderen Konten gelandet sind.
(Domain MX Eintrag wurde geändert, es waren wohl noch E-Mails in der Warteschleife auf anderen Servern die zugestellt wurden nachdem ich die Accounts angelegt hatte)

Schaue ich mir hingegen die erzeugten Unterordner an, sehe ich keine Maildir Datei sondern, wie ich es erwartet habe, jede E-Mail als einzelne Datei in /cur/ wenn bekannt und in /new/ wenn neu.

Code:
root@mailsrv:/var/vmail/weinzettel.eu/test# ll
insgesamt 28
drwx------ 2 vmail vmail 4096  2. Dez 05:00 courierimapkeywords
-rwxr--r-- 1 vmail vmail   47  2. Dez 04:58 courierimapsubscribed
-rw-r--r-- 1 vmail vmail  271  2. Dez 05:38 courierimapuiddb
drwx------ 2 vmail vmail 4096  2. Dez 05:38 cur
drwx------ 2 vmail vmail 4096  2. Dez 04:58 new
-rwxr--r-- 1 vmail vmail   23  2. Dez 04:58 subscriptions
drwx------ 2 vmail vmail 4096  2. Dez 05:44 tmp
root@mailsrv:/var/vmail/weinzettel.eu/test# ll cur/
insgesamt 60
-rw-r--r-- 1 vmail vmail  2184  2. Dez 05:25 1354423128.M920004P3552V000000000000FE02I000000000018004F_0.mailsrv.usrv.eu,S=2184:2,S
-rw-r--r-- 1 vmail vmail  1567  1. Dez 21:50 1354423128.M999868P3552V000000000000FE02I000000000018004A_1.mailsrv.usrv.eu,S=1567:2,RS
-rw-r--r-- 1 vmail vmail 52111  1. Dez 11:32 1354423129.M107521P3552V000000000000FE02I0000000000180058_2.mailsrv.usrv.eu,S=52111:2,S
root@mailsrv:/var/vmail/weinzettel.eu/test# ll new/
insgesamt 0
In der ISPConfig3 Konfiguration sind folgende Dinge für E-Mail eingestellt (unverändert von mir)
Code:
Modul: postfix_mysql
Maildir Pfad: /var/vmail/[domain]/[localpart]
Homedir Pfad: /var/vmail
POP/IMAP Dämon: courier
Mailfiter Syntax: Maildrop
Mailuser UID 5000
Mailuser GID 5000
Mailuser Name vmail
Mailuser Gruppe vmail
Relayhost Benutzer <leer>
Relayhost Passwort <leer>
Mailboxgrößen-Limit 0 MB
Nachrichtengrößen-Limit 0 MB
(Wenn ihr dig/lookups macht, bitte nicht an den Domainnamen stören, der Domainumzug sowie die DNS Zonefiles sind noch nicht beim Hoster eingespielt bzw. die KK Anträge laufen noch.)


Eines muss ich noch dazu sagen, ich hatte vorher nicht gewusst das man das Maildir nicht während der Installation setzen kann, und hatte so die LVM Partition für den Mailstorage auf /opt gemountet.
Der "Umzug" nach /var/vmail lief so ab:

Code:
cd /var
mv vmail/* /opt
Danach in der fstab den mountpoint von /opt auf /var/vmail gesetzt.
Glaube es zwar nicht, aber möglich das dadurch was kaputtgegangen ist.
Habe jetzt auch den Port25 dicht gemacht um nicht noch mehr E-Mails in der Maildir aufzunehmen


Ich hab bereits Google befragt und ganz ähnliche Themen gefunden, aber nichts was ich hier anwenden könnte.
Kann mir hier jemand weiterhelfen? Ich möchte ungern das alles neu installieren müssen...
 
#2
Ok Update...
Habe jetzt mal Maildrop direkt getestet und damit funktioniert es.
Code:
root@mailsrv:/etc/postfix# maildrop -V 10 -d test@weinzettel.eu < dummytext
maildrop: authlib: groupid=5000
maildrop: authlib: userid=5000
maildrop: authlib: logname=test@weinzettel.eu, home=/var/vmail, mail=/var/vmail/weinzettel.eu/test
maildrop: Changing to /var/vmail
Message start at 0 bytes, envelope sender=test@weinzettel.eu
maildrop: Attempting .mailfilter
WARN: quota string '0' not parseable
maildrop: Delivery complete.
Die Mail war in meiner Inbox wo sie sein sollte.
Also gehe ich mal davon aus, das an dieser master.cf irgendetwas nicht stimmt:

Code:
smtp      inet  n       -       -       -       -       smtpd
smtps     inet  n       -       -       -       -       smtpd
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       -       -       -       smtp
relay     unix  -       -       -       -       -       smtp
        -o smtp_fallback_relay=
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
retry     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache

maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}

amavis unix - - - - 2 smtp
        -o smtp_data_done_timeout=1200
        -o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks=127.0.0.0/8
        -o strict_rfc821_envelopes=yes
        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
        -o smtpd_bind_address=127.0.0.1
Unnötige Kommentarzeilen habe ich entfernt.
Die Datei wurde genau so wie sie ist von ISPConfig erstellt.
Alles was ich gemacht habe ist smtps zu aktivieren

Edit:
Code:
System: Debian 6.0.6 x64
Courier: 0.65.0-3
Postfix: 2.7.1-1+squeeze1

#maildrop -v
Maildrop: maildrop 2.5.0 Copyright 1998-2005 Double Precision, Inc.
 
Zuletzt bearbeitet:

Till

Administrator
#3
Beim umkopieren der maildir folder hast du das .mailfilter script nicht mit verschoben, denn bei dem von dir genannten befehl gehen alle versteckten dateien verloren. Lade ispconfig neu runter, entpacke es und rufe das update.php script im install folder auf. Wähle die option das die dienste neu konfiguriert werden dollen.
 

Werbung

Top