E-Mail kommen nicht an

s-8

New Member
#1
Hallo,
ich habe auf meinem Server (Suse + Postfix) das Problem, dass keine E-Mails an die Postfächer ankommen und es wirkt auf mich, als wenn die Mails angenommen aber dann auf dem System gelöscht werden.

Die einzigen Hinweismeldungen enhtalten die beiden folgenden Log-Dateien:

mail.info:
Code:
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: connect from mail.gmx.net[213.165.64.20]
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: AC8741FC0390: client=mail.gmx.net[213.165.64.20]
May 18 16:30:02 openSUSE-102-64-LAMP postfix/cleanup[9998]: AC8741FC0390: message-id=<4830370E.6080400@gmx.de>
May 18 16:30:02 openSUSE-102-64-LAMP postfix/qmgr[9574]: AC8741FC0390: from=<MeinName@gmx.de>, size=844, nrcpt=1 (queue active)
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: disconnect from mail.gmx.net[213.165.64.20]
May 18 16:30:03 openSUSE-102-64-LAMP postfix/pickup[9573]: 47D4D1FC0396: uid=10005 from=<web11>
May 18 16:30:03 openSUSE-102-64-LAMP postfix/cleanup[9998]: 47D4D1FC0396: message-id=<20080518143003.47D4D1FC0396@www.MeineDomain.de>
May 18 16:30:03 openSUSE-102-64-LAMP postfix/local[10002]: AC8741FC0390: to=<web11@www.MeineDomain.de>, orig_to=<info@MeineDomain.de>, relay=local, delay=0.64, delays=0.2/0.03/0/0.41, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
May 18 16:30:03 openSUSE-102-64-LAMP postfix/qmgr[9574]: AC8741FC0390: removed
May 18 16:30:03 openSUSE-102-64-LAMP postfix/qmgr[9574]: 47D4D1FC0396: from=<web11@www.MeineDomain.de>, size=376, nrcpt=1 (queue active)
May 18 16:30:03 openSUSE-102-64-LAMP postfix/local[10002]: 47D4D1FC0396: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.66, delays=0.64/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
May 18 16:30:03 openSUSE-102-64-LAMP postfix/qmgr[9574]: 47D4D1FC0396: removed

mail:
Code:
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: connect from mail.gmx.net[213.165.64.20]
May 18 16:30:02 openSUSE-102-64-LAMP postfix/anvil[9990]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
May 18 16:30:02 openSUSE-102-64-LAMP postfix/anvil[9990]: warning: inet_protocols: configuring for IPv4 support only
May 18 16:30:02 openSUSE-102-64-LAMP postfix/trivial-rewrite[9994]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
May 18 16:30:02 openSUSE-102-64-LAMP postfix/trivial-rewrite[9994]: warning: inet_protocols: configuring for IPv4 support only
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_destination" instead
May 18 16:30:02 openSUSE-102-64-LAMP postfix/cleanup[9998]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
May 18 16:30:02 openSUSE-102-64-LAMP postfix/cleanup[9998]: warning: inet_protocols: configuring for IPv4 support only
May 18 16:30:02 openSUSE-102-64-LAMP postfix/cleanup[9998]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: AC8741FC0390: client=mail.gmx.net[213.165.64.20]
May 18 16:30:02 openSUSE-102-64-LAMP postfix/cleanup[9998]: AC8741FC0390: message-id=<4830370E.6080400@gmx.de>
May 18 16:30:02 openSUSE-102-64-LAMP postfix/qmgr[9574]: AC8741FC0390: from=<MeinName@gmx.de>, size=844, nrcpt=1 (queue active)
May 18 16:30:02 openSUSE-102-64-LAMP postfix/smtpd[9982]: disconnect from mail.gmx.net[213.165.64.20]
May 18 16:30:02 openSUSE-102-64-LAMP postfix/local[10002]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
May 18 16:30:02 openSUSE-102-64-LAMP postfix/local[10002]: warning: inet_protocols: configuring for IPv4 support only
May 18 16:30:02 openSUSE-102-64-LAMP postfix/sendmail[10010]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
May 18 16:30:02 openSUSE-102-64-LAMP postfix/sendmail[10010]: warning: inet_protocols: configuring for IPv4 support only
May 18 14:30:02 openSUSE-102-64-LAMP postfix/postdrop[10014]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
May 18 14:30:02 openSUSE-102-64-LAMP postfix/postdrop[10014]: warning: inet_protocols: configuring for IPv4 support only
May 18 16:30:03 openSUSE-102-64-LAMP postfix/pickup[9573]: 47D4D1FC0396: uid=10005 from=<web11>
May 18 16:30:03 openSUSE-102-64-LAMP postfix/cleanup[9998]: 47D4D1FC0396: message-id=<20080518143003.47D4D1FC0396@www.MeineDomain.de>
May 18 16:30:03 openSUSE-102-64-LAMP postfix/local[10002]: AC8741FC0390: to=<web11@www.MeineDomain.de>, orig_to=<info@MeineDomain.de>, relay=local, delay=0.64, delays=0.2/0.03/0/0.41, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
May 18 16:30:03 openSUSE-102-64-LAMP postfix/qmgr[9574]: AC8741FC0390: removed
May 18 16:30:03 openSUSE-102-64-LAMP postfix/qmgr[9574]: 47D4D1FC0396: from=<web11@www.MeineDomain.de>, size=376, nrcpt=1 (queue active)
May 18 16:30:03 openSUSE-102-64-LAMP postfix/local[10002]: 47D4D1FC0396: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.66, delays=0.64/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
May 18 16:30:03 openSUSE-102-64-LAMP postfix/qmgr[9574]: 47D4D1FC0396: removed
Kann mir jemand weiterhelfen? Ich meine aus den LogFiles lesen (bzw. eher raten) zu können, dass die Mails zugestellt werden.
 

s-8

New Member
#3
Danke für den Tipp, habe es geprüft. Dieses ist bereits aktiviert.

Eine Sachen sollte ich noch erwähnen, ich kann mich auch nicht einloggen und Mails checken. Das Problem habe ich aber noch nicht näher geprüft da ich den Mailempfang erst einmal hinbekommen wollte.

Was ich gerade aber noch entdeckt habe...
...ich habe auf dem Server 3 Webpakete, also 3 User und in dem Verzeichnis des Users habe ich die Mails entdeckt:
/srv/www/web11/user/web11/Maildir/new

Die kommen also an (wird mir aber leider so nicht angezeigt), also fehlt irgendwie die Verknüpfung in welchem BEreich die Mails sich befinden etc!?

Jetzt bin ich völlig verwirrt.....
 

Anhänge

Zuletzt bearbeitet:

Till

Administrator
#4
Woher weißt Du denn, dass die mails nicht abgekommen sind, wenn Du Dich nicht einloggen kannst? Laut Mail Log sind sie korrekt angekommen und an den lokalen User ausgeliefert worden.
 

s-8

New Member
#5
Weil ich die Verzeichnisse abegklappert habe in denen ich meine Mails vermutet habe, dadurch habe ich nun auch letztendlich den Ort gefunden wo die Mails mittlerweile angekommen sind uns liegen.
 

Till

Administrator
#6
Wenn die Emails im Maildir innerhalb des Home Verzeichnisses des Users liegen, dann ist alles in Ordnung. Installiere einfach Courier wie im Perfect Server Guide für OpenSuSE beschrieben und alles sollte funktionieren.
 

Werbung

Top