E-Mail Routing einzelner Postfächer zu einem anderen Mailserver

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ramsys, 27. Mai 2014.

  1. ramsys

    ramsys Member

    Folgendes Setup:

    In einer ISPConfig Multiserver-Umgebung gibt es einen reinen Mailserver (mail1.server.de) mit den Postfächern test1@domain.de und test2@domain.de sowie einem Catchall auf test2@domain.de. Die MX-Records von domain.de zeigen auf mail1.server.de. Funktioniert alles wie erwartet.

    Außerdem gibt es einen weiteren Mailserver (mail2.server.de), der jedoch nicht über ISPConfig verwaltet wird. Funktioniert ebenfalls Stand-Alone wie erwartet. Die E-Mail-Adresse test3@domain.de soll nun auf diesen zweiten Mailserver weitergeleitet werden.

    In ISPConfig ist der Relay-Empfänger eingetragen. Server: mail1.server.de, Relay-Empfänger: test3@domain.de. Außerdem das E-Mail-Routing. Server: mail1.server.de, Domain: test3@domain.de, Typ: SMTP, Kein MX-Lookup aktiviert, Ziel: mail2.server.de. Der A-Record von mail2.server.de zeigt auf die korrekte IP.

    In den beiden Tabellen mail_transport und mail_relay_recipent vom Mailerver mail1.server.de sind ebenfalls die korrekten Werte eingetragen.

    Wenn ich nun von test1@domain.de eine E-Mail an test3@domain.de sende, landet sie im Catchall-Postfach test2@domain.de vom Mailserver mail1.server.de. Ohne Catchall gibt es die Fehlermeldung: "SMTP Fehler (550): Der Empfänger "test3@domain.de" konnte nicht gesetzt werden (5.1.1 <test3@domain.de>: Recipient address rejected: User unknown in virtual mailbox table)." Ein Routing auf den zweiten Mailserver mail2.server.de findet also nicht statt.

    Was habe ich übersehen?
     
  2. mare

    mare Member

    Du mußt test3 noch als lokales Postfach einrichten.
    Der Transport kommt nach dem Usercheck.
     
  3. ramsys

    ramsys Member

    Hallo mare,

    danke für Dein Feedback :)

    Das Postfach test3@domain.de war sowohl auf dem zweiten Mailserver (mail2.server.de) als auch in ISPConfig auf mail1.server.de angelegt. Allerdings hatte ich zu Testzwecken in ISPConfig für dieses Postfach die Dienste SMTP, IMAP und POP3 deaktiviert und die Größe des Postfachs auf 0 MB gesetzt.

    Lösung: SMTP muss aktiviert sein!
     
  4. ramsys

    ramsys Member

    Noch eine ergänzende Frage dazu:

    Das einzelne Postfach test3@domain.de wird in ISPConfig per Routing auf den Mailserver mail2.server.de (nicht ISPConfig) weitergeleitet. Welche Einstellungen in ISPConfig auf dem Mailserver mail1.server.de für das lokale Postfach test3@domain.de greifen trotzdem?

    Getestet:

    a) Alle Einstellungen die direkt für das Postfach test3@domain.de gemacht werden greifen nicht. Einschließlich CC-Empfänger, Spamfilter, Autoresponder und Filter.

    b) Der direkt bei der E-Mail-Domain domain.de eingestellte Spamfilter wirkt auch auf das weitergeleitete Postfach test3@domain.de.

    c) Die in ISPConfig für das weitergeleitete Postfach test3@domain.de angelegten Fetchmail-Konten funktionieren ebenfalls.

    Frage:

    1) Können die genannten Punkte so bestätigt werden?

    2) Wie sieht es mit den White-/Blacklist aus? Greifen diese auch für das weitergeleitete Postfach test3@domain.de?

    3) Gibt es eine Möglichkeit, in ISPConfig (also auf Mailserver mail1.server.de) direkt für das lokale Postfach test3@domain.de den Spamfilter zu konfigurieren? Um so auf Mailserver mail2.server.de möglichst keinen Spam-/Virencheck/Scanner mehr aktivieren zu müssen.
     
  5. Till

    Till Administrator

    a) Das ist richtig, denn diese Einstellungen sind ja alle nur für das lokale Postfch und dort kommt ja keine Email mehr an.
    b) Das ista cuh richtig, den der Spamfilter wirdkt sowohl auf weitergeleitete als auch auf lokale Emails.
    c) das ist auch richtig, denn sie haben nichts mit dem Postfach selbst zu tun. Getmail fügt die emails normal per smtp in die mailqueue ein, daher werden sie auch weitergeleitet.

    2) Die sollten auch bei Weiterleitungen greifen.
    3) Ja, spamfilter user für die Adresse anlegen.
     
  6. ramsys

    ramsys Member

    Richtig, so wird es ja auch im Handbuch ausgeführt:

    Für ein weitergeleitetes Postfach muss aber auch ein lokales Postfach eingerichtet werden und der Spamfilter-User wird automatisch angelegt, wenn in diesem Konto ein entsprechender Spamfilter ausgewählt wurde. Aber wie auch von Dir bestätigt, greifen dieses Einstellungen nicht.

    Ist es denn ein Unterschied, ob dieser Spamfilter-User für das weitergeleitete Postfach automatisch vom System oder manuell von mir angelegt wird?
     
  7. ramsys

    ramsys Member

    Irgendwie verstehe ich das nicht:

    Der im lokalen Konto eingerichtete Spamfilter greift für ein weitergeleitetes Postfach nicht. Obwohl dafür vom System automatisch ein Spamfilter-User angelegt wird.

    Wenn ich diesen Spamfilter-User für dieses Konto nun manuell einrichte, soll der dort ausgewählte Spamfilter aber greifen? Obwohl diese umgekehrte Funktionsweise in der Datenbank den gleichen Datensatz anlegt. Gerade getestet: Greift (logischerweise) ebenfalls nicht.

    Kann mir jemand die Blockade nehmen oder die korrekte Vorgehensweise erklären?
     
  8. Till

    Till Administrator

    Jeder spamfilter user greift für weitergeleitete emails, egal wie Du ihn anlegst. hab es gerdae nochmal hier getestet, bei mir funktioniert es im debian perfect server.
     
  9. ramsys

    ramsys Member

    Dann stimmt die erste Aussage unter a) aber nicht mehr. Denn: Unabhängig vom Spamfilter-User (da er ja sowieso automatisch angelegt wird) greift der im lokalen Konto eingestellte Spamfilter immer auch für weitergeleitete Postfächer.

    Aber genau das passiert hier nicht. Die Konfiguration für das lokale Postfach (einschließlich Spamfilter) greift nicht bei bzw. vor der Weiterleitung.

    Als Server für den Spamfilter-User ist natürlich der Server vom lokalen Postfach ausgewählt, da der Mailserver zu dem weitergeleitet wird wie erwähnt nicht über ISPConfig verwaltet wird.

    Dito.
     

Diese Seite empfehlen