E-Mail Sammeldienst - SSL - Web.de = Fehler

Dieses Thema im Forum "Allgemein" wurde erstellt von kleinermann, 10. Juni 2016.

  1. kleinermann

    kleinermann New Member

    Moinsen,

    nutze ISPConfig schon einige Zeit und möchte meine Web.de Mails mit bzw. über ISPConfig abholen.
    Als Type habe ich imapssl angeben und als Server; imap.web.de. Sonst habe ich nur noch meine Login Daten eingetragen und gespeichert.

    Jedoch werden meine Mails von web.de nicht abgeholt und in den Logs finde ich folgende Einträge;

    Code:
     dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=80.137.174.250, lip=176.9.34.23, TLS handshaking: SSL_accept() failed: error:1408A10B:SSL routines:SSL3_GET_CLIENT_HELLO:wrong version number, session=<b2cF0O40dABQia76>
    Vermute mal es liegt an meinem SSL bzw. meine Version von SSL, nur mir fehlen die Erfahrungen mit SSL und wollte mal um Rat fragen, wie ich das Problem am besten angehe !

    Gruß
    kleinermann
     
  2. florian030

    florian030 Member

    Dein Log kommt von Dovecot, die Emails werden aber mit getmail abgeholt.
     
  3. kleinermann

    kleinermann New Member

    Mist, stimmt ja aber es macht es nun etwas schwerer. In den Log's (mail.* Auth.log usw) sind keine Fehlermeldungen oder andere Meldungen von getmail zu finden, die auf das Problem hindeuten. Was mich jetzt erst recht vor ne Mauer stehen lässt.
     
  4. florian030

    florian030 Member

    Schau mal nach /var/log/getmail.log oder suche in /var/log/messages nach getmail. Meistens ist das aber ein Problem mit falschen Login-Daten. Oder Du holst noch an anderer Stelle die Mails ab oder leitest sie weiter. Dann getmail auch nichts abholen.
     
  5. kleinermann

    kleinermann New Member

    Grüß dich,

    getmail.log existiert nicht und der message sind nur einträge vom FTP. Also nachwievor keine Anhaltspunkte in den Log's
    führe ich einfach getmail auf der Konsole aus erhalte ich folgende Meldung;

    Code:
    root@city /var/log # getmail
    Error: Default config/data dir "/root/.getmail/" does not exist - create or specify alternate directory with --getmaildir option
    
    ß
    könnte es entscheidend sein
     
  6. florian030

    florian030 Member

    Getmail läuft nicht als root, sondern als user getmail. Wie Du getmail komplett aufrufst, siehst Du als User getmail mit crontab -l
     
  7. kleinermann

    kleinermann New Member

    Auch in der Crontab ist nichts mit getmail zu finden;

    Code:
    * * * * * /usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    30 00 * * * /usr/local/ispconfig/server/cron_daily.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    
    Eine Konfigurationsdatei wird von ispconfig in /etc/getmail angelegt. Vermute das er nicht ausgeführt wird ?!
     
  8. florian030

    florian030 Member

    Wenn, dann ist das crontab -u getmail -l
    Die Configs liegen aber alle in /etc/getmail - ich würde mal nachsehen, ob da nicht ein Teppfuhler drin ist.
     
  9. kleinermann

    kleinermann New Member

    Besten Dank,

    habe mit einem su getmail und dann /usr/local/bin/run-getmail.sh per Hand angestoßen und es funktioniert.

    Jetzt wäre ja die Frage, warum macht er dies nicht automatisch ?
     

Diese Seite empfehlen