Einbinden von (Zend) Extensions für Apache2 (DEBIAN)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ZauberFee, 8. Mai 2008.

  1. ZauberFee

    ZauberFee New Member

    Hallo,

    ich habe da noch ein Problem, dessen Fehler ich einfach nicht finden kann,
    Grundinstallation nach Anleitung von "Perfekt Setup Debian". Vorab ein
    Auszug aus der "php.ini" (aus /etc/php5/apache2):

    Egal wie ich es drehe, mit Verzeichnisangabe oder ohne, sei es für das
    "extension_dir" oder direkt unter der Angabe "extension=", das Modul
    "ioncube_loader...." scheint einfach nicht geladen zu werden.

    Wie heisst der Befehl, mit dessen Hilfe man anzeigen lassen kann im Shell,
    welche *.so extensions geladen wurden, und welche nicht? Das ganze soll
    wenn unter ISPConfig dann zur Verfügung stehen.

    so long,
    ZauberFee.
     
  2. Till

    Till Administrator

    Das PHP auf der Shell und das im apache haben unterscheidliche php.ini dateien, daher kannst Due s Dir auf der Shell garnicht anzeigen lassen.

    Erstelle eine info.php Datei mit Folgendem Inhalt

    <?php
    phpinfo();
    ?>

    in einer beliebiegn Website auf dem Server und rufe sie auf.

    Ich würde Dir außerdem raten, die Datei ioncube_loader_lin_5.2.so direkt in das Verzeichnis /usr/lib/php5/extensions zu legen und nicht in ein Unterverzeichnis.
     
  3. ZauberFee

    ZauberFee New Member

    Ok, ich habe dieses zum Abruf eingetragen unter http://clansurf.de/info.php

    Habe Einträge zurück gesetzt bezüglich extensions in der "php.ini". Habe eine
    Datei namens "ioncube.ini" in der "/etc/php5/apache2/conf.d" mit dem nach-
    folgenden Inhalt (dort sind auch alle anderen extension-module von der
    originalen Installation als Dateien hinterlegt worden): :rolleyes:

    Code:
    zend_extension=ioncube_loader_lin_5.2.so
    
    Den Apache2 neu gestartet, und die URL aufgerufen, die diese Erweiterung benötigt: http://clansurf.de/iface/admin.php

    Dort schreibt er jedoch mir immer noch, das diese Erweiterung anscheinend
    fehlt. Die *.so für ioncube habe ich in das selbe Verzeichnis kopiert, in dem
    auch die anderen *.so Extension-Dateien sich befinden. Ich weiss nicht weiter... :(

    so long,
    ZauberFee.
     
  4. Till

    Till Administrator

    Das sieht soweit alles ok aus. Bist Du sicher, dass Du die richtige Version des Loaders installiert hast (32Bit / 64Bit) ? Poste doch mal die Ausgabe von:

    uname -a
     
  5. Till

    Till Administrator

    Ansonsten mach bitte mal das Folgende:

    It's not working - why?
    -----------------------

    If encoded files fail to run with run-time loading, you can test this by
    using the helper PHP script 'ioncube-loader-helper.php' that's included in
    this package.

    1. Copy the 'ioncube-loader-helper.php' and 'ioncube-encoded-file.php' PHP scripts
    to a directory where you expect encoded files to be working.

    2. Access the 'ioncube-loader-helper.php' script from a web server or with a
    PHP cli or cgi executable.

    3. Choose the 'Run-time loading installation instructions' option.

    4. The script will try to locate and install the required Loader, and will
    produce output as it runs.

    5. Once complete the script will either report that run-time loading is working,
    will provide instructions for how to correct any issue with the server
    configuration, or will report that Loaders must be installed in the php.ini
    file.
     
  6. ZauberFee

    ZauberFee New Member

    Nein, da bin ich mir nicht sicher, da ich auf Anfrage diese Version (Files)
    vom Anbieter des gekauften WEB-Interfaces welches diese benötigt, er-
    halten habe.

    Ich werde da aber nochmals nachhaken und den Status hier dann an-
    schließend bekanntgeben. :cool:

    so long,
    ZauberFee.
     
  7. ZauberFee

    ZauberFee New Member

    ...du hast recht - 6 Gummipunkte von mir...:D, dem war also nicht so.

    Es war selbstverständlich die 32-Bit Variante, ich war dazu aber noch
    gezwungen die *.so Dateien direkt mit dem aktuell genutzten Pfad an-
    geben zu müssen, erst danach funktionierte es. :rolleyes:

    Auch der Pfad-Eintrag für die "Extensions" wurde wohl hier nicht genutzt,
    K.A. warum. :eek: Aber nun ist die gewünschte Funktionalität verfügbar.

    so long,
    ZauberFee.
     

Diese Seite empfehlen