Eine .htaccess Frage bezüglich vBulletin + vBSEO

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von timersen2004, 28. Nov. 2008.

  1. timersen2004

    timersen2004 New Member

    Hi!
    vBulletin läuft ohne Probleme, wahrscheinlich auch vBSEO aber dazu hätte ich eine .htaccess Frage. Ich muß ja durch Apache Direktiven im ACP diese erst freigeben in der .htaccess die bei liegt und auf den Server mu? steht:

    Code:
    # Comment the following line (add '#' at the beginning)
    # to disable mod_rewrite functions.
    # Please note: you still need to disable the hack in
    # the vBSEO control panel to stop url rewrites.
    RewriteEngine On
    
    # Some servers require the Rewritebase directive to be
    # enabled (remove '#' at the beginning to activate)
    # Please note: when enabled, you must include the path
    # to your root vB folder (i.e. RewriteBase /forums/)
    #RewriteBase /
    
    #RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
    #RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]
    
    RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
    
    RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron)
    RewriteRule ^((archive/)?(.*\.php(/.*)?)?)$ vbseo.php [L,QSA]
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
    RewriteRule ^(.+)$ vbseo.php [L,QSA]
    Was mu? ich nun ins Feld Apache Direktiven eintragen damit alles lauft? Habe vieles probiert, nichts geht. Verwende Apache2 mit Mandrake....

    Danke

    Gruß,
    Timo
     
    Zuletzt bearbeitet: 28. Nov. 2008
  2. Till

    Till Administrator

    Die einfachste Variante is, wenn Di die gesamte .htaccess Datei löscht und deren kompletten Inhalt in das apache Direktiven Feld kopierst.
     
  3. timersen2004

    timersen2004 New Member

    Geht leider nicht. Kommt "Bad Request" oder auch "Not found". Hmmm...

    Geht leider nicht. Kommt "Bad Request" oder auch "Not found". Hmmm...
     

    Anhänge:

  4. Till

    Till Administrator

    Dann schau bitte mal ins error Log der Webseite und poste den exakten Fehler.
     
  5. rihocu2

    rihocu2 New Member

    Habe das gleiche Problem!!! schon loesung gefunden??
     
  6. planet_fox

    planet_fox Super-Moderator

    Habt ihr das Apache das modul Aktiviert ?

    sollte unter /etc/apache2/mod_enabled/rewrite.load liegen
     
  7. rihocu2

    rihocu2 New Member

    bei mri aktiviert!
    Koente mir jemand bitte veraten was ich ins apache derektiven feld schreiben muss, damit alle dateien im verzeichnis aufgelistet werden (z.b. hier zu sehen)

    danke

    edit: nebenfrage: wie logge ich mich in phpmyadmin ein? also welche daten muss ich eingeben, irgendwie klappts mit keinen....
     
    Zuletzt bearbeitet: 28. Feb. 2009
  8. Till

    Till Administrator

    Options +Indexes


    Mit den mysql Zugangsdaten.
     
  9. rihocu2

    rihocu2 New Member

    Thx. Ich muss ja nicht nur Options +Indexes reinkopieren, was war das doch mal was ich davor und danach eingeben muss? Finde leider nichts dazu. Habt ihr dazu eine Dokumention oder einen Link zum Thema?

     
  10. Till

    Till Administrator

    Du Findest diese Infos alle in der Apache Documentation. Zm das Options +Indexes solltest Du noch eine directory Direktive drum herum setzen.
     
  11. rihocu2

    rihocu2 New Member

    Hab ich läuft aber leider irgendwie nicht :( Wahrscheinlich was falsch gemacht. Leider jetzt keine Zeit die komplette Apache Documentation zu studieren, könnte jemand mal ein Example davon zeigen? Also wie es korrekt mit Options +Indexes auszusehen hat.
     
  12. rihocu2

    rihocu2 New Member

    vBSEO braucht Zend Optimier und/oder IONCube, ich wette mit dir das du das nicht isntaliiert hast ;) Wenn das hast sollte es laufen.
     
  13. planet_fox

    planet_fox Super-Moderator

Diese Seite empfehlen