Email mit alternativen Login funktioniert nicht korrekt

#1
Hallo

Wenn ich einen abweichenden Loginnamen unter system Config/email einstelle und auch verwende gib es folgende Probleme.

- beim versenden über Squirrelmail wird nicht mehr der Domainname der sendenden Domain rangehangen sondern der Servername (hostname) mit dem alternativen login als Benutzername
- das Antworten auf diese email geht natürlich nicht
- beim Senden auf die email kommt ein MailerDaemon zurück (unknown user)

- beim Login auf das Postfach (pop) über z.B. Outlook funktioniert zwar die Anmeldung, aber emails verschwinden im Nirwana ohne Fehlermeldung.

Im log ist nichts auffälliges zu sehen



cu Huflatisch
 

Till

Administrator
#2
- beim versenden über Squirrelmail wird nicht mehr der Domainname der sendenden Domain rangehangen sondern der Servername (hostname) mit dem alternativen login als Benutzername
- das Antworten auf diese email geht natürlich nicht
- beim Senden auf die email kommt ein MailerDaemon zurück (unknown user)
Du musst in squirrelmail in den Optionen des Mailkontos eine korrekte Absenderadresse angeben.

- beim Login auf das Postfach (pop) über z.B. Outlook funktioniert zwar die Anmeldung, aber emails verschwinden im Nirwana ohne Fehlermeldung.
Schau nochmal ins log, es muss dort was drin stehen wohin die mails gehen und warum dies der Fall ist.
 
#3
Hallo

Danke für die Antwort

Ja, es ist unbedingt erforderlich das die emailadresse eingetragen ist. Bei squirrelmail und auch bei. z.B. Outlook.
Dem Postfix mit imapd auf meinem alten Server war das egal. Die Zuordnung zur domain erfolgte mit der Anmeldung
Gerade bei Outlook verschwinden die emails wenn nix eingetragen ist ohne Fehlermeldung. Mal sehen ob die wieder auftauchen.

Der Empfang (z.B. von gmx) funktioniert trotzdem nicht. Es gibt ein Mailer Daemon "unknown user"
Code:
Jan 15 09:07:10 hal9000 postfix/smtpd[16877]: connect from mout.gmx.net[212.227.15.18]
Jan 15 09:07:10 hal9000 postfix/smtpd[16877]: C4851F01155: client=mout.gmx.net[212.227.15.18]
Jan 15 09:07:10 hal9000 postfix/cleanup[16884]: C4851F01155: message-id=<20130115080710.261130@gmx.net>
Jan 15 09:07:10 hal9000 postfix/qmgr[19347]: C4851F01155: from=<name@gmx.de>, size=1076, nrcpt=1 (queue active)
Jan 15 09:07:10 hal9000 postfix/smtpd[16877]: disconnect from mout.gmx.net[212.227.15.18]
Jan 15 09:07:11 hal9000 postfix/smtpd[16888]: connect from localhost[127.0.0.1]
Jan 15 09:07:11 hal9000 postfix/smtpd[16888]: 712E4F01228: client=localhost[127.0.0.1]
Jan 15 09:07:11 hal9000 postfix/cleanup[16884]: 712E4F01228: message-id=<20130115080710.261130@gmx.net>
Jan 15 09:07:11 hal9000 postfix/qmgr[19347]: 712E4F01228: from=<name@gmx.de>, size=1555, nrcpt=1 (queue active)
Jan 15 09:07:11 hal9000 postfix/smtpd[16888]: disconnect from localhost[127.0.0.1]
Jan 15 09:07:11 hal9000 amavis[1306]: (01306-15) Passed CLEAN, [212.227.15.18] [185.199.113.38] <name@gmx.de> -> <test@isp-domain.de>, Message-ID: <20130115080710.261130@gmx.net>, mail_id: JlofLJKfv17d, Hits: 0.01, size: 1076, queued_as: 712E4F01228, 615 ms
Jan 15 09:07:11 hal9000 postfix/smtp[16885]: C4851F01155: to=<test@isp-domain.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.77, delays=0.13/0.02/0.01/0.62, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 712E4F01228)
Jan 15 09:07:11 hal9000 postfix/qmgr[19347]: C4851F01155: removed
Jan 15 09:07:11 hal9000 dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
Jan 15 09:07:11 hal9000 postfix/pipe[16889]: 712E4F01228: to=<test@isp-domain.de>, relay=dovecot, delay=0.22, delays=0.07/0.01/0/0.13, dsn=5.1.1, status=bounced (user unknown)
Jan 15 09:07:11 hal9000 postfix/cleanup[16884]: A6801F01244: message-id=<20130115080711.A6801F01244@hal9000.server4you.de>
Jan 15 09:07:11 hal9000 postfix/qmgr[19347]: A6801F01244: from=<>, size=3442, nrcpt=1 (queue active)
Jan 15 09:07:11 hal9000 postfix/bounce[16894]: 712E4F01228: sender non-delivery notification: A6801F01244
Jan 15 09:07:11 hal9000 postfix/qmgr[19347]: 712E4F01228: removed
Jan 15 09:07:12 hal9000 postfix/smtp[16895]: A6801F01244: to=<name@gmx.de>, relay=mx01.gmx.net[213.165.67.97]:25, delay=0.59, delays=0.06/0.02/0.12/0.39, dsn=2.0.0, status=sent (250 Requested mail action okay, completed: id=0MF9r5-1TkLES3Rj1-00GJqi)
Jan 15 09:07:12 hal9000 postfix/qmgr[19347]: A6801F01244: removed
hier mal wenn ich mit koma-mail an gmx send, kein Eintrag bei email.
Die email sollte trotzdem nicht verschwinden. Wie kann ich einstellen das er das Standart Konto nimmt. Die Anmeldung klappt ja.
Code:
Jan 15 10:26:56 hall9000 postfix/smtpd[18245]: connect from telekom.ns.de[185.199.113.38]
Jan 15 10:26:56 hall9000 postfix/smtpd[18245]: BE0AFF011FA: client=telekom.ns.de[185.199.113.38], sasl_method=LOGIN, sasl_username=web1p1
Jan 15 10:26:56 hall9000 postfix/cleanup[18252]: BE0AFF011FA: message-id=<>
Jan 15 10:26:57 hall9000 postfix/qmgr[19347]: BE0AFF011FA: from=<>, size=1172, nrcpt=1 (queue active)
Jan 15 10:26:57 hall9000 postfix/smtpd[18245]: disconnect from telekom.ns.de[185.199.113.38]
Jan 15 10:26:57 hall9000 postfix/smtpd[18256]: connect from localhost[127.0.0.1]
Jan 15 10:26:57 hall9000 postfix/smtpd[18256]: 55433F01995: client=localhost[127.0.0.1]
Jan 15 10:26:57 hall9000 postfix/cleanup[18252]: 55433F01995: message-id=<20130115092657.55433F01995@hall9000.server4you.de>
Jan 15 10:26:57 hall9000 postfix/qmgr[19347]: 55433F01995: from=<>, size=1724, nrcpt=1 (queue active)
Jan 15 10:26:57 hall9000 postfix/smtpd[18256]: disconnect from localhost[127.0.0.1]
Jan 15 10:26:57 hall9000 amavis[1305]: (01305-18) Passed CLEAN, [185.199.113.38] [185.199.113.38] <> -> <name@gmx.de>, mail_id: nboQ92DBWRj4, Hits: 2.21, size: 1172, queued_as: 55433F01995, 412 ms
Jan 15 10:26:57 hall9000 postfix/smtp[18253]: BE0AFF011FA: to=<name@gmx.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.78, delays=0.34/0.01/0.01/0.42, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 55433F01995)
Jan 15 10:26:57 hall9000 postfix/qmgr[19347]: BE0AFF011FA: removed
Jan 15 10:26:57 hall9000 postfix/smtp[18257]: 55433F01995: to=<name@gmx.de>, relay=mx00.gmx.net[213.165.67.114]:25, delay=0.47, delays=0.12/0.02/0.11/0.22, dsn=2.0.0, status=sent (250 Requested mail action okay, completed: id=0LvVch-1SvtgY1lg3-010dbF)
Jan 15 10:26:57 hall9000 postfix/qmgr[19347]: 55433F01995: removed
Wenn Benutzername = email ist klappt ja die ganze Sache !!! Kann ich aber nicht verwenden weil ich alte confixx Konten rumnehmen möchte. Die aber nicht funktionieren werden wenn der Kunde die emailadresse nicht hinterlegt hat!!! Ein Teufelskreis !!!

PS: Bin mir aber nicht mehr ganz sicher das die email nicht hinterlegt werden muss - prüfe ich noch.

cu
Huflatisch
 
Zuletzt bearbeitet:

Till

Administrator
#4
Die Emailadresse die als Absender genutzt werden soll muss immer im Mailclient hinterlegt werden. Wenn Du eine Emailadresse als Login nimmst, dann nehmen die meisten Mailclients diese automatisch und tragen sie als absender ein. Das ganze hat also nur was mit den clients zu tun und nicht dem mailserver, der mailserver ändert die Absenderadresse nicht in den Mailheadern.

Zu der email bounce message: Stell sicher dass isp-domain.de nicht als hostname des Servers oder emaildomain in der main.cf oder /etc/mailname verwendet wird. Es darf dort keine Domain drin stehen die für Email postfächer verwendet wird sondern es muss eine subdomain sein wie im perfect server Tutorial beschrieben.
 
#5
Hallo

Code:
myhostname = hal9000.server4you.de
myorigin = /etc/mailname
mydestination = hal9000.server4you.de, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
inet_interfaces = all
default_destination_concurrency_limit = 2
der steht auch in der mailname ---> ist also korrekt

cu
Huflatisch
 

Till

Administrator
#6
Ok. Und was genau steht in der non delivery notofication die Dir gmx geschickt hat? Dort muss drin stehen warum sie die Email nicht angenommen haben, z.B. wegen fehlender oder unvollständiger Emailadresse wenn der Mailclient sie nicht gesetzt hat.
 
#7
Hallo

Wie gesagt "unknown user"

Kopfzeilen:
Code:
Return-Path:  
Received: from hal9000.server4you.de ([12.78.125.48]) by mx-ha.gmx.net  (mxgmx104) with ESMTP (Nemesis) id 0MgZ7z-1TYHV10YaN-00Nyqi for  
<name@gmx.de>; Tue, 15 Jan 2013 09:07:12 +0100 
Received: by hal9000.server4you.de (Postfix)
     id A6801F01244; Tue, 15 Jan 2013 09:07:11 +0100 (CET) Date: Tue, 15 Jan 2013 09:07:11 +0100 (CET) 
From: MAILER-DAEMON (Mail Delivery System) 
Subject: Undelivered Mail Returned to Sender 
To: name@gmx.de 
Auto-Submitted: auto-replied 
MIME-Version: 1.0 
Content-Type: multipart/report; report-type=delivery-status;     boundary="712E4F01228.1358237231/hal9000.server4you.de" 
Message-Id: <20130115080711.A6801F01244@hal9000.server4you.de> 
Content-Transfer-Encoding: 7bit Envelope-
To: <name@gmx.de> 
X-GMX-Antispam: 0 (Mail was not recognized as spam); Detail=V3; 
X-GMX-Antivirus: 0 (no virus found)
hier Text
Code:
This is the mail system at host hal9000.server4you.de.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<test@domain.de>: user unknown
cu
huflatisch
 
Zuletzt bearbeitet:

Till

Administrator
#8
Die Nachricht ist eindeutig, es gibt halt die dort genannte Emailadresse nicht auf dem Server an den die Mail zugestellt wurde.
 
#9
Hallo


Doch.... Schreibfehler nahzu ausgeschlossen.

Wenn ich das Login auf test@domain.de ändere nimmt das Posfach emails ja auch an. Nur nicht wenn ich als login web1p1 vergebe !!!

cu
Huflatisch

PS: Beim stöbern im Forum meine ich mal was gelesen zu haben das dovecot die sql Auth nicht richtig umsetzt. Finde das nicht wieder. Kann das damit zusammen hängen
 

Till

Administrator
#10
PS: Beim stöbern im Forum meine ich mal was gelesen zu haben das dovecot die sql Auth nicht richtig umsetzt. Finde das nicht wieder. Kann das damit zusammen hängen
An sich nicht, denn wenn das Problem vorliegen würde dann könntest Du Dich nicht per pop3 oder imap am Konto anmelden. Du kannst aber mal Deine dovecot-sql.conf Datei posten, Passwort vorher ändern bzw. löschen.
 

Till

Administrator
#11
PS: Beim stöbern im Forum meine ich mal was gelesen zu haben das dovecot die sql Auth nicht richtig umsetzt. Finde das nicht wieder. Kann das damit zusammen hängen
An sich nicht, denn wenn das Problem vorliegen würde dann könntest Du Dich nicht per pop3 oder imap am Konto anmelden. Du kannst aber mal Deine dovecot-sql.conf Datei posten, Passwort vorher ändern bzw. löschen.
 
#13
Hallo

genau das war das Problem

nach einfügen von " OR email = '%u' " in den query der dovecot-sql.conf
ist alles bestens.

Code:
user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, CONCAT('*:storage=', quota, 'B') AS quota_rule, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE login = '%u' [FONT=Arial Black][U][COLOR=black][B]OR email = '%u'[/B][/COLOR][/U][/FONT] AND disable%Ls = 'n'
Ich vermute mal das die wenigstens alternative email Logins nutzen (ist auserdem auch ziemlich versteckt) und es deshalb nicht auffällt das das nicht korrekt funktioniert.

cu
Huflatisch

PS:
Der Server ist es erst paar Tage online und schon kommt hier permanet Hintergrundrauschen an
Code:
Jan 15 13:59:00 hal9000 dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<web@server4you.de>, method=PLAIN, rip=95.50.61.10, lip=45.115.145.10
Jan 15 13:59:12 hal9000 dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<service@server4you.de>, method=PLAIN, rip=95.50.61.10, lip=45.115.145.10
Jan 15 13:59:23 hal9000 dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<danny@server4you.de>, method=PLAIN, rip=95.50.61.10, lip=45.115.145.10
Jan 15 13:59:38 hal9000 dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<guest@server4you.de>, method=PLAIN, rip=95.50.61.10, lip=45.115.145.10

...usw.
 
Zuletzt bearbeitet:

Till

Administrator
#14
Ich vermute mal das die wenigstens alternative email Logins nutzen (ist auserdem auch ziemlich versteckt) und es deshalb nicht auffällt das das nicht korrekt funktioniert.
In 3.0.5 RC1 geht es mit dovecot, da habe ich es vor ein paar Wochen getestet. Kann aber sein dass es in der 3.0.4.6 nicht mit dovecot geht, denn mit Courier habe ich einen Server bei einem Kunden der das nutzt.

Der Server ist es erst paar Tage online und schon kommt hier permanet Hintergrundrauschen an
Das ist normal.
 

Werbung