EMail Versand nur intern möglich, ohne Auth ?!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mk3, 1. Dez. 2008.

  1. mk3

    mk3 New Member

    Hallo,

    ich habe das Problem, dass mein Ausgangsserver (ISPConfig ist dort installiert) keine Authentifizierung macht und auch nur interne Mails schickt.

    Beispiel:

    Meine Domains sind example.com und beispiel.de; Externer Bsp.-Empfänger ist extern@mailanbieter.de

    mustermail@example.com kann an mustermail@beispiel.de schicken.
    mustermail@beispiel.de kann an mustermail@example.com schicken.


    mustermail@example.com kann nicht an extern@mailanbieter.de schicken wenn er über eigenen example.com-SMTP schickt. (Relay not allowed).
    extern@mailanbieter.de kann an mustermail@example.com schicken.

    //EDIT:
    Habe gerade herausgefunden das es über Webmail geht (benutze das Roundcube AddOn).
    Wie kann ich das denn per Software-Lösung verschicken?
    //edit ende


    Kann ISPConfig nicht selber schicken? Was muss ich machen um das zu aktivieren? Ausserdem muss ich mich beim schicken nicht authentifizieren.
    Laut Config und bei der Installation ist Postfix am Werk.

    Vielen Dank.
     
    Zuletzt bearbeitet: 1. Dez. 2008
  2. Till

    Till Administrator

    Mit ISPConfig hat das nichts zu tun, Du musst nur einfach SMTP Authentifizierung in Deinem Email Client aktivieren.
     
  3. mk3

    mk3 New Member

    Wenn ich das mache, nutze zum testen Thunderbird Portable, geht bei mir immer wieder das Passwort-Fenster auf. Logge mich mit web[ID]_name beim server abruf und senden an. Empfangen geht, senden nicht.
     
  4. Till

    Till Administrator

    Dann hast Du sasl auf Deinem Server nicht richtig konfiguriert. Sieh Dir mal bitte die perfect setup Anleitung für die von Dir verwendete Linux Distribution an und konfiguriere Dein mail system entsprechend.
     
  5. mk3

    mk3 New Member

    Meine Einstellungen (Webmin) sind im Anhang.
     

    Anhänge:

    • sasl.jpg
      sasl.jpg
      Dateigröße:
      53,3 KB
      Aufrufe:
      33
  6. Till

    Till Administrator

    Webmin sollte auf einem ISPConfig System nicht instralliert sein, da sich die Funktionen von Webmin und ISPConfig überschneiden. Wie bereits oben beschrieben, rekonfiguriere Dein System bitte exakt wie im perfect setup beschrieben.
     
  7. mk3

    mk3 New Member

    Hab mir nochmal ein paar Einstellungen angesehen...

    Müsste smtp (sasl) nicht eigentlich schn beim telnet auf den port nach einem user fragen? bzw. wie kann ich das von hand mal simulieren? ich vermute, dass mein client einen internen fehler hat, weil über Webmail alles perfekt funktioniert. Dazu müsste er ja entweder die internen Sockets zum senden nehmen oder Sendmail...

    Also, wie kann ich den Client mal von hand "simulieren"?


     
    Zuletzt bearbeitet: 2. Dez. 2008
  8. Till

    Till Administrator

    Webmail braucht sich nicht authentifizieren, da es auf localhost läuft.

    Mach doch bitte einfach das, was ich Dir geschrieben habe ;)
     
  9. mk3

    mk3 New Member

    Hab ich ja schon :rolleyes:

    Könnte vllt. durch ein Update etwas umgestellt worden sein (arbeite mit Ubuntu 8.10)? Wenn er fragt ob er Config Datein überschreiben soll, sage ich ihm das er die alte nutzen soll. Habe früher nie meinen eigenen SMTP genutzt :cool:
    Grund dafür ist, dass ich Tobit David nutze und natürlich auch Mailrelay (= kein eigener Ausgangsserver).

    Ist das eigentlich normal das mein Server auf Port 25 manchmal die Connection animmt aber nichts sagt (also für kurze Zeit mich auf eine Ignor setzt)?
     
  10. Till

    Till Administrator

    Wann? Jetzt gerade? Wenn Du die Linux Distribution aktualisierst dann werden auch Config dateien aktualisiert oder sie haben eine andere Syntax. Du musst danach nochmal das perfect setup für die neue Version durchgehen, nicht umsonst schreiben wir es für jede Version neu! Insebesondere die SASL Syntax hat sich geändert.
     
  11. mk3

    mk3 New Member

    Die Perfektes Server Setup Anleitungen sind perfekt, habe danach auch unter 8.04 alles ans laufen gebracht, nur finde ich keine 8.10er?!
     
  12. Till

    Till Administrator

  13. mk3

    mk3 New Member

    hab nochmal alles so gemacht, kann mich immernoch nicht authentifizieren :(

    hab mal versucht mit dem addon opennewsletter mit dem smtp etwas zu verschicken (auch localhost). Es kommt der Fehler, dass er nicht verbinden konnte (vermutlich das gleiche Problem).
     
  14. mk3

    mk3 New Member

    ich war blind :D

    jetzt ging die mail aus meinem testaccount raus :)
     
  15. mk3

    mk3 New Member

    Vielen Dank für den tollen Support - ISPConfig finde ich mittlerweile schon besser als die bekannteren Produkte. Das bessere setzt sich eben nicht immer durch :)
     
  16. Till

    Till Administrator

    Als unbekannt würde ich ISPConfig nicht gerade bezeichnen, da es zumindest nach Downloads die weltweit am weitesten verbreitete OpenSource Lösung ist. Unbekannt ist es nur in Deutschland, denn in Deutschland gab es viele Jahre Confixx als Gratis Zugabe zum Server, da hat dann niemand OpenSource Software eingesetzt.
     

Diese Seite empfehlen