eMail Zustellung klappt nicht!

#1
Hallo, nach dem nun der Webserver läuft, klemmts noch beim Mail-Server!

Ich hab erstmal zum Test für alles eine Domain über dyndns.com genommen, mit dem Webserver klappt ja auch alles, und in Sachen Mailserver dürfte es durch den Dienst auch keine Probleme geben!

Ich hab unter "eMail-Konten > Domain" die Domain "domain.dyndns.org" angelegt.
Dann unter "eMail-Konten > Email Mailbox" ein Postfach zur Domain angelegt. Zusätzlich hab ich dann noch ein Catchall auf das Postfach gelegt.

Dann hab ich über Gmail eine Mail an das Postfach geschickt und in die Mailwarteschlange geschaut. Dort stand dann drin:

-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
7EEE46CC1E5 585 Thu May 6 14:45:45 wwwrun@h1155611.stratoserver.net
(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
inbox@domain.dyndns.org

923076CC1E7 1932 Thu May 6 14:51:13 adresse@gmail.com
(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
test@domain.dyndns.org

-- 3 Kbytes in 2 Requests.
Was könnte da noch das Problem sein?

Gleich noch was am Rande. Bei der Installation (Perfekter Server openSUSE 11.1) von Maildrop, kam irgendeine Meldung das er irgendwelche Probleme mit courier-imap hat...Könnte das auch ein Problem sein? Wozu ist Maildrop gut?

Achja bei dem Webmail-Client SquirrelMail wie meld ich mich an. Benutzerdaten gingen nicht!?

Ich danke.
 
Zuletzt bearbeitet:
#2
Noch paar Logo:

maillog:
May 6 16:50:02 h1755662 postfix/smtpd[11841]: connect from localhost[::1]
May 6 16:50:02 h1755662 postfix/smtpd[11841]: lost connection after CONNECT from localhost[::1]
May 6 16:50:02 h1755662 postfix/smtpd[11841]: disconnect from localhost[::1]
mail error:

May 5 08:41:35 h1755662 postfix/qmgr[32107]: fatal: open database /etc/postfix/relay.db: No such file or directory
May 5 08:42:36 h1755662 postfix/qmgr[32119]: fatal: open database /etc/postfix/relay.db: No such file or directory
May 5 08:43:37 h1755662 postfix/qmgr[32172]: fatal: open database /etc/postfix/relay.db: No such file or directory
Wenn ich amavis starten will kommt das: (in der config wurde aber nirgend der hostname so benannt wie in der meldung)
/etc/init.d/amavis start
Starting virus-scanner (amavisd-new): The value of variable $myhostname is "h1255661", but should have been
a fully qualified domain name; perhaps uname(3) did not provide such.
You must explicitly assign a FQDN of this host to variable $myhostname
in amavisd.conf, or fix what uname(3) provides as a host's network name!
 
Zuletzt bearbeitet:
#3
dann wurde doch das howto nicht richtig durchgegangen da ist doch darin das am anfang einrichtiger fdqn vergeben werden soll.

Macht man das vor der install der anderen packete vernüftig dann haben die auch den richtigen namen drin.

Generell ist doch eine install wo es hier und da Fehlermeldungen schon bei der
vorbereitung mit dem howto gegeben hat sinnfrei. Wie lange und stabil soll das System den laufen?
 
#4
Hi ich konnte erst ab Seite 4 anfangen! Ich hab ein Server bei Starto das ist openSUSE 11.1 schon vorinstalliert. Also bin ich nie an den Punkt mit der fdqn gekommen. Sollte ja schon alles eigentlich vorinstalliert sein.

Aber ich habe vorher von 11.1 auf 11.2 geupdatet, vielleicht ist das was schief gegangen?

Wie kannich die FDQN in Ordnung bringen. Der Server soll lange und stabil laufen...

Danke
 
#5
also kann ich nur für debian sprechen /etc/hostname und /etc/mailname.

Für dann fall das du die chance hast bei Strato Debian als OS auszuwählen nihm das. Damit solltes du mit isp config am wenigsten Probleme Bekommen.
 

Till

Administrator
#7
Das ist keine Lösung für mich. Wenn ich überhaupt mit Linux klar komme, dann mit openSuse.
Sagen alle Opensuse Benutzer bis sie zum ersten mal debian verwenden und sich danach fragen warum sie sich so lange mit den Macken von opensuse gequält haben, wo es doch so viel einfacher geht ;)

Der Server soll lange und stabil laufen...
Das ist gerade der Punkt, der gegen opensuse spricht. Lange und stabil ist damit sehr schwierig, da opensuse bei updates auch gerne mal Konfigurationsdateien überschreibt bzw. das system nach dem Update nicht mehr rund läuft.

Das Problem, yast macht es falsch. Oder besser gesagt, yast macht es in einer Art und Weise, die inkompatibel zu amavisd ist, da yast wie für desktops in privaten netzwerken üblich die Domain weglässt, was aber bei Internetservern fatal ist.

In Schritt 9 dieses Tutorials steht, welche Datei Du ändern musst:

http://www.howtoforge.com/perfect-server-opensuse-11.2-x86_64-ispconfig-3-p4

aber Yast wird das immer mal wieder zurück ändern bei Updates, wundere Dich also nicht wenn nach einem Update mit yast das mailsystem stehen belicbt, bis Du es manuell wieder repariert hast.

OpenSuSE ist eine nette Linux Distribution, aber nur für Desktops und nicht Hosting Server.
 

Werbung