[erledigt] Wert von "upload_max_filesize" für eine Webseite ändern

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von sanchez, 13. Okt. 2014.

  1. sanchez

    sanchez Member

    Hi,
    ich muss für eine Webseite die maximale Dateigröße beim Hochladen ändern. Diese läuft mit php-fpm und so habe ich auch entsprechende Werte in der benutzerdefinierten php.ini Datei über das Panel vorgenommen, welche auch übernommen wurden:
    Code:
    php_admin_value[upload_max_filesize] = 10M
    Allerdings zeigt mir phpinfo() an, dass der Wert beim Standardwert von 2M liegt. Die Eingabe ist an sich ja richtig und steht ja so auch in der Datei, nur PHP selbst möchte es nicht übernehmen. Woran könnte es liegen?
     
  2. wotan2005

    wotan2005 Member

    apache2ctrl restart gemacht?
     
  3. sanchez

    sanchez Member

    Ja, habe neben Apache auch php-fpm manuell neugestartet. Aber erfolglos.
     
  4. wotan2005

    wotan2005 Member

    steht den der Wert in der richtigen vhost-Datei der Domain drin?
     
  5. sanchez

    sanchez Member

    Nein, in den vHost Dateien steht davon nichts. Ich habe die Parameter lediglich in das Textfeld für PHP-Einstellungen eingetragen. Müssen die etwa auch bei den Apache Direktiven rein? Obwohl ich php-fpm und nicht mod_php nutze?
     
  6. Till

    Till Administrator

    Der Eintrag ist falsch, richtig wäre:

    upload_max_filesize = 10M

    im php.ini Feld in ispconfig.
     
  7. sanchez

    sanchez Member

    Genau so steht er auch drin. Die Ausgabe war die von der benutzerdefinierten php.ini Datei und sollte nur zeigen, dass die Einstellung übernommen und geschrieben wurde.
     
  8. Till

    Till Administrator

    Hast Du irgendwelche custom nginx Direktiven im Einsatz in der Seite?
     
  9. sanchez

    sanchez Member

    Nein, nutze nur Apache und daher nichts für nginx drin.
     
  10. logifech

    logifech Member

    Steht der wert in der dazugehrigen Pool datei von PHP-FPM richtig drinne?? Bei PHP-FPM werden die werte soweit ich weiß dort reingeschrieben und daraus übernommen.
    So steht dies z.B. in meiner /opt/php-5.6.1/etc/pool.d/webXX.conf datei
    Bei euch varriiert der Ordner wo die pool dateien drinne liegen wahrscheinlich.
    Code:
    php_admin_value[disable_functions] = pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,dl,highlight_file,show_source,proc_open,popen
    php_admin_value[post_max_size] = 100M
    php_admin_value[upload_max_filesize] = 100M
    php_admin_value[max_execution_time] = 1200
    php_admin_value[max_input_time] = 1200
    php_admin_flag[magic_quotes_gpc] = Off
    php_admin_flag[file_uploads] = Yes
    php_admin_value[max_file_uploads] = 20
     
    Zuletzt bearbeitet: 13. Okt. 2014
  11. sanchez

    sanchez Member

    Genau so steht der Wert bei mir drin, wie oben bereits erwähnt.

    Individuelle php.ini Einstellungen
    Code:
    ...
    upload_max_filesize = 10M
    post_max_size = 10M
    In der /etc/php5/fpm/pool.d/webXXX.conf
    Code:
    ...
    php_admin_value[upload_max_filesize] = 10M
    php_admin_value[post_max_size] = 10M
    phpinfo()
    Code:
    ...
    upload_max_filesize 2M
    post_max_size 8M
    ...
    Apache und php-fpm wurden bereits auch schon manuell neugestartet. Ohne Erfolg. Alle Einstellungen sind im Panel gemacht worden und ganz sicher auch für die richtige Webseite. Die phpinfo-Datei befindet sich auch im richtigen Verzeichnis, sprich im web-Verzeichnis der Domain.
     
    Zuletzt bearbeitet: 13. Okt. 2014
  12. logifech

    logifech Member

    mhh dann wüsste ich jetzt auch nicht weiter müsste ich mal bei mir nachgucken.
     
  13. nowayback

    nowayback Well-Known Member

    und du nutzt ganz sicher apache2 + php-fpm und nicht apache2 + fastcgi?
     
  14. logifech

    logifech Member

    Ja nutze ich ganz sicher:) PHP-FPM mit PHP5.6.1 als zusatz version.
     
  15. nowayback

    nowayback Well-Known Member

    dann sollten die werte in der entsprechenden webxxx.conf im verzeichnis der zusatzversion (z.b. /opt/php5.6.1/....) stehen
     
  16. logifech

    logifech Member

    Bei mir ist das auch so ich habe da keine Probleme.
     
  17. sanchez

    sanchez Member

    Ja, auch ganz sicher, dass ich es so nutze. Habe jetzt sogar nochmal extra nachgesehen. Anders würden die Einstellungen ja auch nicht in die Konfigurationsdatei geschrieben werden.
    Der Parameter "display_errors" wurde ja exakt so auch eingetragen und funktioniert problemlos. Bloß bei der Sache mit der Dateigröße für den Upload will PHP nicht ganz mitspielen.
     
  18. sanchez

    sanchez Member

    Also, ich wollte gerade temporär den Wert über die globale php.ini einstellen. Dafür /etc/php5/fpm/php.ini geöffnet und upload_max_filesize umgestellt. Anschließend php-fpm neugestartet. Einen kurzen Blick auf die phpinfo riskiert und dabei festgestellt, dass selbst diese Einstellung nicht übernommen wurde.

    Die gleiche Einstellung habe ich dann mal auf /etc/php5/cgi/php.ini angewandt und siehe da: Es funktioniert!
    Damit scheint es, als würde die Einstellung von php-fpm bei den Einstellungen für den PHP-Modus ignoriert, da ich dort explizit php-fpm ausgewählt habe.

    Ist das jetzt ein Bug oder habe ich irgendetwas übersehen?
     
  19. logifech

    logifech Member

    Ich werd dies auch mal bei mir testen, aber in der Regel nutze ich nicht die default php version vom OS sondern zusätlich Kompillierte Software. Werde meine erfahrung dann auch mal hier berichten.
     
  20. sanchez

    sanchez Member

    Danke dir, wäre einfach schön zu wissen woran es jetzt genau liegt.
     

Diese Seite empfehlen