Error 403 Forbidden

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von SAVERSERVER, 22. Dez. 2014.

  1. SAVERSERVER

    SAVERSERVER Member

    einige minuten nach der Neuinstall bekomme ich einen Error 403 Forbidden statt des Webinterfaces.
    Habe zuerst an einen Fehler bei der install gedacht, und mittlerweile mindesten 8x neu installiert. Habe folgende aktuelle Doku genommen http://www.howtoforge.com/perfect-server-debian-wheezy-apache2-bind-dovecot-ispconfig-3. Ach ja, squirrelmail offnet die Startseite ganz normal.
    Die Apache2 errror.log
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: PHP Strict Standards: Non-static method SimplePie_Misc::element_implode() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 14990, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: PHP Strict Standards: Non-static method SimplePie_Misc::element_implode() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 14990, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: PHP Strict Standards: Non-static method SimplePie_Misc::element_implode() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 14990, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: PHP Strict Standards: Non-static method SimplePie_Misc::element_implode() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 14990, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: PHP Strict Standards: Non-static method SimplePie_Misc::element_implode() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 14990, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: PHP Stri, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 21:56:40 2014] [warn] [client 9x.xxx.xxx.xx] mod_fcgid: stderr: s/simplepie.inc.php on line 14990, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 22:02:42 2014] [error] [client 9x.xxx.xxx.xx] client denied by server configuration: /var/www/ispconfig, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 22:02:44 2014] [error] [client 9x.xxx.xxx.xx] client denied by server configuration: /var/www/ispconfig, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 22:02:47 2014] [error] [client 9x.xxx.xxx.xx] client denied by server configuration: /var/www/ispconfig, referer: https://xx2.xxxxxxxxx.com:8080/index.php
    [Mon Dec 22 22:03:06 2014] [error] [client 9x.xxx.xxx.xx] client denied by server configuration: /var/www/ispconfig

    Danke für euere Hilfe
     
  2. Till

    Till Administrator

    Hast Du zusätzlich irgendwelche apache Module, wie z.B. mod_evasive installiert?

    Gibt es den Symlink /var/www/ispconfig der auf /usr/local/ispconfig/interface/web verweist?
     
  3. SAVERSERVER

    SAVERSERVER Member

    Hallo Till,
    danke für deine Hilfe, aber ich habe gestern Nacht irgendwann aufgegeben. Der vServer eignet sich definitv nicht für mein Projekt. Da wurde vermutlich sehr viel nicht installiert.
    So, gerade install bei anderem Anbieter auf einem (richtigen) Server durchgeführt ... und alles läuft wie es soll ;-)
    MUSS ICH GLEICH REVIDIEREN
    Gleiches Problem
    keine zusätzlichen Apache Module
    kein Symlink /var/www/ispconfig
     
    Zuletzt bearbeitet: 23. Dez. 2014
  4. Till

    Till Administrator

    Hmm, das ist ja sehr merkwürdig. Nicht dass Debian was geändert hat, aber letzte WE ging es noch, da hab ich einen Kundenserver damit installiert.
     
  5. SAVERSERVER

    SAVERSERVER Member

    schei....... und das jetzt wo ich ein bisschen in Zeitnot stehe.
    Was hast Du für eine Idee für mich?
     
  6. Till

    Till Administrator

    Leg mal bitte den /var/www/ispconfig an:

    ln -s /usr/local/ispconfig/interface/web /var/www/ispconfig
     
  7. SAVERSERVER

    SAVERSERVER Member

    Ja, jetzt komme ich wieder auf das Admin-Panel
    Teste mal noch weiter, ob das schon alles war.
     
  8. nowayback

    nowayback Well-Known Member

    Also ich kann nur berichten, das ich gerade einen Server nach exakt dem Tutorial erstellt, wie du es verlinkt hast. Ich habe als Quelle das Debian 7.7 Netinstall-Image genommen. Konnte keine Probleme feststellen. Lief alles wie es sollte.
    Sicher das du die sources.list angepasst hast? Sonst lässt sich nämlich libapache2-mod-fastcgi nicht installieren
     
  9. SAVERSERVER

    SAVERSERVER Member

    Ja, das hat Debain vermutlich bereits auch gemerkt und wieder repariert.
    Gestern auch noch einen weiteren aufgesetzt und alles lief Problemlos.
    Da habe ich vermutlich nur zum falschen Zeitpunkt den Server aufgesetzt ;-)
     

Diese Seite empfehlen