error nach multiserver conf

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Viperdriver2000, 19. Apr. 2011.

  1. Hallo,
    ich habe ein "kleines" problem.

    also ich habe zwei server. einen habe ich als master configuriert und den anderen als slave.

    seit der slave hinzugefügt ist bekomme ich im error und debug log folgende meldung:
    ich lese da nur das raus:
    das ist ein "kunde" den ich auf dem master server angelegt habe.
    er nutzt aber keine dienste vom slave server.
    also sollte er nicht.

    kann mir einer vielleicht erklären was der server mir sagen möchte?!

    danke & gruß
    Vip
     
    Zuletzt bearbeitet: 19. Apr. 2011
  2. Till

    Till Administrator

    In einem Multiserver setup muss auf allen Servern die gleiche ISPConfig Version installiert sein. Du scheinst bei Dir auf dem Master eine SVN Version zu haben und auf dem Slave eine stable Version. Daher funktioniert die Replikation nicht, da die Tabellen auf dem Master Server mehr Felder als auf dem Slave haben.
     
  3. Aber in der Übersicht steht bei beiden:
    ISPConfig 3.0.3.3

    Haste ne tipp für mich wie ich das fixen kann?

    EDIT:
    ich sehe gerade ich habe mich in dem how to verlesen :( shit.
    habe auf dem master scheinbar wirklich die svn installiert?
    wie kann ich das testen das ich mir sicher sein kann?
    ist die svn schlechter als die stable ?
    ich dachte immer ist die gleiche version...
     
    Zuletzt bearbeitet: 19. Apr. 2011
  4. Till

    Till Administrator

    SVN Downloads haben keine eigenen Versionsnummern, da sie nur für Entwickler gedacht sind und nicht auf Produktivsystemen installiert werden (z.B. da sie nicht getestet sind).

    Das ist jezzt etwas schwierig, da der master eine SVN Version ist, müsstest Du den slave jetzt auch auf AVN aktualieisiern. Ich würde aber SVN nicht für Produktivzwecke verwenden. da Du aber nicht downgraden kannst, müsstest Du beim einsatz von stable ISPConfig auf beiden Server neu installieren.

    Wenn Du also nicht alles neu installieren willst, wirst Du den slave auch auf SVN aktialisieren müssen und hoffen dass dann alles geht.
     
  5. könnte ich dann beim nächsten update von ispconfig beide systeme auf die stable bringen?

    mit neu inst meinste ispconfig oder den ganzen server weil die Dateien so gestreut sind das ich es nicht so einfach los werde.

    dann noch die frage. ich habe den master ja schon so weit eingerichtet das ich nur noch die domains umschwenken muss.
    kann ich die db dann exportieren und wieder einspielen und es geht dann alles?^^ ich habe die Befürchtung nein :(

    EDIT:
    So ich habe mich entschlossen den master server neu aufzusetzen. ^^
    @till danke für dein schnelles feedback! echt klasse. :)
     
    Zuletzt bearbeitet: 19. Apr. 2011
  6. Till

    Till Administrator

    Geht vielleicht mit 3.0.4. Es kann aber durchaus sein dass sich das Datenbank Layout ändert und ein Update nicht möglich ist. SVN ist halt der Sandkasten für Entwickler, da landen auch mal features die bis zum reölease wieder gestrichen werden.
     
  7. also ich habe den master nun neu inst.

    jetzt muss ich nur noch den slave wieder rein bekommen.

    ne idee?
    habe über phpmyadmin den user geaddet aber im cp wird der server net angezeigt :(
     
  8. Till

    Till Administrator

    Der slave muss neu installiert werden, da nur der installler den slave während des Installationsvorganges zum master hinzufügen kann. Du kannst das sicherlich auch manuell machen, ist aber kompliziert und lässt sich nicht eben mal so in einem post erklären, Du müsstest dafür mal durch den Installer code gehen und alle mysql Befehle für das hinzufügen manuell ausführen.

    Ich würde daher ispconfig auf demslave mittels uninstall.php (ist im install folder des tar.gz, muss auf dem slave ausgeführt werden) einstallieren und danach ispconfig neu installieren.
     
  9. Danke Till!
    Das hat geklappt :)

    jetzt ist er wieder drin.

    dann fange ich mal von vorne an mit einrichten ;)
     

Diese Seite empfehlen