fail2ban problem, der perfekte Server ubuntu 12.04 lts

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von cjs1976, 17. Aug. 2013.

  1. cjs1976

    cjs1976 New Member

    Hallo!

    Ich mache gerade meine ersten Gehversuche mit Linux. Ich wollte jetzt einfach mal einen Server anhand der Anleitung auf dieser Webseite aufsetzen.

    Ich bin bis zu HowtoForge Linux Tutorials » Der Perfekte Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) gekommen. Da soll ich jetzt fail2ban neu starten. Ich bekomme aber immer eine Fehlermeldung:

    ***
    ...
    ConfigParser.InterpolationMissingOptionError: Bad value substitution:
    section [dovecot-pop3imap]
    option: action
    key: port
    rawval: ", protocol="%(protocol)s", chain="%(chain)s"]
    ***

    Die Dateien habe ich schon mehrfach überprüft, ich kann keine Fehler finden. Leider sagt die Meldung nicht genau bei welcher Konfiguartionsdatei und in welcher Zeile der Fehler auftritt.

    Was kann ich tun um den Fehler zu finden?

    Danke,
    Christian.
     
  2. nowayback

    nowayback Well-Known Member

    Hi Christian,

    der Fehler sollte in der /etc/fail2ban/jail.local sein bei dem Abschnitt: [dovecot-pop3imap]

    Bitte prüfe nach, ob wirklich alle Zeichen, auch Anführungszeichen vorhanden sind

    Code:
    [dovecot-pop3imap]
    
    enabled = true
    filter = dovecot-pop3imap
    action = iptables-multiport[name=dovecot-pop3imap, port="pop3,pop3s,imap,imaps", protocol=tcp]
    logpath = /var/log/mail.log
    maxretry = 5
    
    Danach am besten gleich noch in der /etc/fail2ban/filter.d/dovecot-pop3imap.conf die Einträge prüfen:

    Code:
    [Definition]
    failregex = (?: pop3-login|imap-login): .*(?:Authentication failure|Aborted login (auth failed|Aborted login (tried to use disabled|Disconnected (auth failed|Aborted login (d+ authentication attempts).*rip=(?P<host>S*),.*
    ignoreregex =
    
    Dann fail2ban restarten:
    Code:
    /etc/init.d/fail2ban restart
    Grüße
    nwb
     
  3. cjs1976

    cjs1976 New Member

    Hi nowayback!

    Super, danke für die Hilfe! Das Problem ist, dass die Webseite - egal mit welchem Browser ich sie öffne - irgendwie total zerschossen ist, und ich habe nicht gesehen, dass da mehr Zeilen sind.

    Nun habe ich alle Dateien entsprechend erweitert, und jetzt klappt es auch!

    Ich werde morgen versuchen den Rest fertig zu machen...

    Vielen Dank,
    Christian.
     

Diese Seite empfehlen