Fehler 500 beim Upload von Dateien

Dieses Thema im Forum "Server Administration" wurde erstellt von Paul, 16. Nov. 2011.

  1. Paul

    Paul Member

    Hallo.
    Seit kurzem habe ich ein Problem beim Upload von Dateien.
    Wenn in das phpBB-Forum Fotos oder PDF-Dateien hochgeladen werden sollen, erhält man meistens die ISPConfig „Fehlermeldung 500 – Interner Serverfehler! - Beim Aufruf der angegebenen URL ist ein interner Serverfehler aufgetreten.“
    Das Problem tritt sowohl bei dem Forum als auch bei der CRM-Software Vtiger auf. Aber nicht immer. Z.B. kleine jpg-Fotos können hochgeladen werden.
    Leider ist es mir nicht gelungen in den Logs aussagekräftige Fehlermeldungen zu finden. Vor ca. 6 Wochen war es noch kein Problem auch größere Dateien und Fotos hochzuladen.

    Das System: Debian 6 mit ISPConfig 3.

    Meine Vermutung: Nach einem System-Upgrade müssen Werte in der php.ini oder der suhosin.ini angepasst werden. Hat jemand eine Idee?
     
  2. Till

    Till Administrator

    Schau mal ins error.log der Webseite, dort steht was den Fehler verursacht.
     
  3. Paul

    Paul Member

    Mit den Antworten geht das aber Ruckzuck. Fast wie beim Chatten.
    Ich habe mich schnell einmal in VTiger angemeldet und einen Upload versucht. Das Error-Log notiert dazu folgendes:

     
  4. Paul

    Paul Member

    Schönen Dank für den Tipp doch noch mal genauer ins Error-Log zu schauen.
    In der Tat steht ja ganz genau drin, was der Fehler ist.
    Zwischenzeitlich habe ich gegoogelt und die Lösung hier gefunden:
    [fix] mod_fcgid: HTTP request length xyz (so far) exceeds MaxRequestLen (131072) » Philipp Klaus's Computing Blog

    In der /etc/apache2/mods-available/fcgid.conf folgende Zeile einfügen:
    MaxRequestLen 15728640

    Dann klappt's auch wieder mit dem Hochladen von Dateien.
    Schönen Dank noch mal für die schnelle Hilfe!
     
  5. nowayback

    nowayback Well-Known Member

    Moinsen

    mod_fcgid - Apache HTTP Server

    Parameter stand früher bei 1GB. Wurde dann im Laufe der Updates geändert.

    Trag einfach einen Wert der zu deiner restlichen Config (upload_max_filesize, post_max_filesize) in den entsprechenden Block mit ein:

    Das sollten, wenn ich mich nicht verrechnet hab, 64 MB sein


    *** Edit: Schön das du es selbst gefunden hast und ich nun umsonst getippt habe :p ***

    Grüße
    nwb
     

Diese Seite empfehlen