Fehler 500 statt php Fehlermeldung

Dieses Thema im Forum "Server Administration" wurde erstellt von cokotech, 13. Nov. 2010.

  1. cokotech

    cokotech Member

    Hallo Ihr!

    Ich habe seit dem letzten Server und ISPConfig Update (Ubuntu 10.04 oder wars 04.10 naja die letzte LTS halt) ein seltsames Problem.
    Trotz error-reporting=E_ALL und display_errors=on zeigt er mir keine PHP Fehler mehr an sondern einen Fehler 500.
    Die Fehlermeldung kann ich dann im Log nachlesen, was ich recht müshelig finde.
    Auch das setzen der beiden Variablen (zusätzlich) im script bringt keinen Unterschied.

    Hat jemand eine Idee???


    Gruß Sven!
     
  2. Quest

    Quest Member

    Ein Fehler 500 ist da immer etwas eigenes. Der wird auch nicht von PHP erzeugt, sondern von Apache.
    Ein Interner Serverfehler verhindert das Senden der eigentlichen Ausgabe deines Skripts an den Browser (wenn das Skript überhaupt abgearbeitet wird).
    Das wird auch solange so bleiben, bis du den Fehler behoben hast.
    Was für eine Fehlermeldung bekommst du denn im Log?
     
  3. cokotech

    cokotech Member

    Hallo!

    Naja im Log steht dann eine normale PHP Fehlermeldung!
    sowas wie unexpected $end oder das eine ] anstatt ) erwartet wird.
    Also es ist definitiv so, das die Meldung bei einem PHP-Fehler kommt,
    was ich auch reproduzieren kann, wenn ich einfach einen in ein laufendes Script einbaue.
    Der gleiche Fehler 500 kommt im Übrigen auch bei verstoß gegen die suphp Richtlinien!


    Gruß Sven!
     
  4. Till

    Till Administrator

    Schau mal in die php.ini, dort steht an sich drin wie fehler ausgegeben werden sollen.
     
  5. cokotech

    cokotech Member

    Hallo Till,


    öhm naja.... also wie soll denn da so die Option lauten?
    Weil die üblichen Verdächtigen habe ich ja durch!
    Zumal ich da nie was dran geändert habe, aber irgendwann wars so!
    (hatte die php.ini übernommen)


    Gruß Sven!
     
  6. Till

    Till Administrator

    Versuch mal:

    error_reporting = E_ALL & ~E_NOTICE
    display_errors = On
    log_errors = Off
     
  7. Laubie

    Laubie Member

    Mir fällt gerade ein:
    hast du auch mal geschaut, dass du auch die richtige php.ini änderst?

    Grüße
    Laubie
     
  8. cokotech

    cokotech Member

    Hallo Ihr....


    1. Diese Variablen meinte ich mit den üblichen Verdächtigen!! DIe sind so eingestellt wie beschrieben

    2. /etc/php5/apache2/php.ini --- jup ist die richtige.... habe gerade nen sendmail wrapper dazwischen gebastelt



    Gruß Sven!
     

Diese Seite empfehlen