Fehler in Vhosts (3.0.0.6)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Quest, 21. Aug. 2008.

  1. Quest

    Quest Member

    Hallo zusammen
    Ich hab da ein kleines Problem.
    Auf meiner frischen ISPconfig3 Installation auf dem frischen Debian-Server habe ich schon mal einige Benutzerkonten und Domains vorbereitet, die demnächst dorthin umgezogen werden.
    Die erste Domain zeigt auch bereits auf meinen Server.

    Der eingetragene DocRoot, in dem ich auch per FTP lande ist
    /var/clients/client0/web14

    Wenn ich jetzt dort etwas im web-Verzeichnis ändere hat das keine Auswirkungen auf die ausgegebene Seite.
    Also habe ich rumprobiert und die standard-index.html der vorbereiteten Konten editiert. So habe ich herausgefunden, dass Apache das Verzeichnis eines anderen Kunden aufruft:
    /var/clients/client0/web5

    Was ist da schief gegangen? Wie könnte ich das beheben?

    Gruß, Michael

    [EDIT]

    Hab da grad was Interessantes gesehen.
    Nach einem /etc/init.d/apache2 reload bekomm ich das hier auf den Schirm:
    [Thu Aug 21 08:33:11 2008] [warn] VirtualHost 78.46.85.41:80 overlaps with VirtualHost 78.46.85.41:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Thu Aug 21 08:33:11 2008] [warn] VirtualHost 78.46.85.41:80 overlaps with VirtualHost 78.46.85.41:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Thu Aug 21 08:33:11 2008] [warn] VirtualHost 78.46.85.41:80 overlaps with VirtualHost 78.46.85.41:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Thu Aug 21 08:33:11 2008] [warn] VirtualHost 78.46.85.41:80 overlaps with VirtualHost 78.46.85.41:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Thu Aug 21 08:33:11 2008] [warn] VirtualHost 78.46.85.41:80 overlaps with VirtualHost 78.46.85.41:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Thu Aug 21 08:33:11 2008] [warn] VirtualHost 78.46.85.41:80 overlaps with VirtualHost 78.46.85.41:80, the first has precedence, perhaps you need a NameVirtualHost directive

    Ich habe 7 vHosts eingerichtet. den ersten übernimmt er wohl, den Rest überspringt er.

    Und das ist ein Auszug aus einem vHost:
    <VirtualHost 78.46.85.41:80>
    DocumentRoot /var/clients/client0/web14/web
    ServerName paxdei.de
    ServerAdmin webmaster@paxdei.de
    ErrorLog /var/clients/client0/web14/log/error.log

    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html

    ServerAlias www.paxdei.de
    # cgi enabled
    ScriptAlias /cgi-bin/ /var/clients/client0/web14/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5

    </VirtualHost>
     
    Zuletzt bearbeitet: 21. Aug. 2008
  2. Till

    Till Administrator

    Wähle statt der IP bitte ienfach "*" für beide betreffenden Vhosts aus.

    Waren auf dem Server schon Webseiten angelegt, bevor Du ISPConfig installiert hast?
     
  3. Quest

    Quest Member

    Ach, daher kommt der Eintrag...
    Na dann ist alles klar.
    Danke für den Tipp.
     

Diese Seite empfehlen