Fehler nach löschen eines Web

#1
Hi,

ich habe ein Web ganz normal gelöscht über das Admininterface. Seitdem läuft mein Sql-Server nicht mehr.

Code:
[B]Warning[/B]:  mysql_connect() [[URL="http://www.sajojo.de/function.mysql-connect"]function.mysql-connect[/URL]]: Access denied for user 'web47u1'@'p15183370.pureserver.info' (using password: YES) in [B]/home/htdocs/web47/web/admin/inc/config.inc.php[/B] on line [B]4[/B]

[B]Warning[/B]:  mysql_select_db(): supplied argument is not a valid MySQL-Link resource in [B]/home/htdocs/web47/web/admin/inc/config.inc.php[/B] on line [B]5[/B]
Keine Verbindung zur Datenbank
Kann mir jemand sagen was ich machen kann. Auch wenn ich Ihn neustarten will über die Konsole kommt

Code:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Wer kann mir da helfen.

Vielen Dank im Vorraus.
 

Till

Administrator
#2
Logge Dich bitte mal ein und rufe:

/etc/init.d/mysql restart

auf (Befehl kann je nach Linuxdistribution variieren) und poste den exakten Output von der Kommadozeile.
 
#3
es kommt folgende Ausgabe:

Code:
p15183370:/var/lib/mysql# /etc/init.d/mysql restart
Stopping MySQL database server: mysqld failed!
Starting MySQL database server: mysqld already running.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
 
#5
output:

Code:
p15183370:/var/lib/mysql# ps aux | grep mysql
root      1572  0.0  0.1   2664  1336 ?        S    Mar11   0:00 /bin/sh /usr/bin/mysqld_safe
mysql     1609  0.1  3.9 130872 40556 ?        Sl   Mar11 186:27 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root      1610  0.0  0.0   1560   508 ?        S    Mar11   0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root      2295  0.0  0.0   1644   560 pts/0    S+   15:44   0:00 grep mysql
 

Till

Administrator
#6
Ok, da scheint noch eine mysql Datenbank zu laufen, die das Start / Stop Script nicht beenden kann.

Entweder Du startest den kompletten Server mal neu, oder Du versuchst die Prozesse mit kill zu beenden und dann mysql neu zu starten.

kill 1572 1609
 

Till

Administrator
#8
Mit dem Löschen des Kuden wird das direkt nichts zu tun haben, da dies die mysql DB nicht beeinflußt. da wird zur gleichen Zeit noch irgend ein anderes Problem aufgretreten sein.

Poste nochmal die Ausgabe von:

ps aux | grep mysql
 
#9
jetzt bekomm ich folgende Meldung wenn ich den Apache stoppen will und neustarten

Code:
httpd (no pid file) not running
ausgabe:

Code:
p15183370:~# ps aux | grep mysql
root      1571  0.0  0.1   2664  1336 ?        S    16:03   0:00 /bin/sh /usr/bin/mysqld_safe
mysql     1608  0.0  1.5 126260 15524 ?        Sl   16:03   0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root      1609  0.0  0.0   1560   508 ?        S    16:03   0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root      2430  0.0  0.0   1644   552 pts/0    S+   16:18   0:00 grep mysql
 

Till

Administrator
#10
Schau mal bitte in die /etc/passwd Datei, ob die "normal" aussioeht, d.h. ob dort alle User gelistet sind oder ob das Format irgendwie durcheinader aussieht.
 
#11
sieht alles normal aus
habe noch folgendes probiert.

Code:
ps aux | grep httpd
root      2011  0.0  0.8  13936  8392 ?        Ss   16:44   0:00 /root/ispconfig/httpd/bin/ispconfig_httpd -DSSL
110       2018  0.0  0.7  14068  8104 ?        S    16:44   0:00 /root/ispconfig/httpd/bin/ispconfig_httpd -DSSL
110       2143  0.0  0.8  14068  8292 ?        S    16:45   0:00 /root/ispconfig/httpd/bin/ispconfig_httpd -DSSL
root      2533  0.0  0.0   1644   556 pts/0    S+   17:04   0:00 grep httpd
 
Zuletzt bearbeitet:
#14
ich hab gerade mal in die httpd.conf geschaut von apache. die ist leer. kann mir jemand mal den inhalt davon geben.
komisch ist. das wenn ich auf meine Domain gehe mit port 81 dann zeigt er mir den login von ispconfig aber gehe ich auf die anderen domains geht nichts da kommt dann Verbindung fehlgeschlagen
 
Zuletzt bearbeitet:

Till

Administrator
#15
Die httpd.conf ist leer, da die Konfigurationsdatei des Apache apache2.conf heißt.

Bitte verwechsel nicht den Server auf port 81 mit dem Haupt Server, die haben nichts miteinander zu tun und ob der eine funktioniert ist auch völlig unabhängig vom anderen,
 

Till

Administrator
#17
1) Welche Linux Distribution.
2) Was steht im error log des apache, im syslog und messages log, wenn Du den apache startest.
3) Poste mal die Audgabe von: httpd -t
 
#18
1) Welche Linux Distribution.
2) Was steht im error log des apache, im syslog und messages log, wenn Du den apache startest.
3) Poste mal die Audgabe von: httpd -t
1) Suse
2)
syslog
Code:
Jul 13 16:44:06 p15183370 syslogd 1.4.1#18: restart.
messages log
Code:
Jul 13 14:22:22 p15183370 -- MARK --
Jul 13 14:42:22 p15183370 -- MARK --
Jul 13 15:02:23 p15183370 -- MARK --
Jul 13 15:22:23 p15183370 -- MARK --
Jul 13 15:42:23 p15183370 -- MARK --
Jul 13 16:02:23 p15183370 -- MARK --
Jul 13 16:02:45 p15183370 shutdown[2716]: shutting down for system reboot
Jul 13 16:23:47 p15183370 -- MARK --
Jul 13 17:04:06 p15183370 -- MARK --
Jul 13 17:24:06 p15183370 -- MARK --
Jul 13 17:44:06 p15183370 -- MARK --
Jul 13 18:04:07 p15183370 -- MARK --
Jul 13 18:24:07 p15183370 -- MARK --
Jul 13 18:44:07 p15183370 -- MARK --
3) p15183370:/# httpd -t
httpd: bad user name www-data
 

Werbung