Fehler nach Update auf 2.2.27

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ts-onlyfree, 13. Okt. 2008.

  1. ts-onlyfree

    ts-onlyfree New Member

    moinmoin

    habe grade das update gestartet und geendet hat es hiermit.. das sind die letzten zeilen die ich sehen kann.

    so wie es scheint, hat mein sophos auch noch einen virus im clam-av entdeckt, vllt liegts daran...

    Code:
    cat: ../test/.split/split.clam-pespin.exeaa: Operation not permitted
    make[2]: *** [clam-pespin.exe] Error 1
    make[2]: Leaving directory `/root/install_ispconfig/compile_aps/clamav-0.94/test'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/install_ispconfig/compile_aps/clamav-0.94'
    make: *** [all] Error 2
    ERROR: Could not make ClamAV
    
    ********************** Sophos Anti-Virus Alert ***********************
    Virus "Mal/Packer" detected in file
    "/root/install_ispconfig/compile_aps/clamav-0.94/test/.split/split.clam-pespin.exeaa".
    
    Access to the file has been denied.
    !! Sophos AV hat einen bösen Virus gefunden !!
    **********************************************************************
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `ispconfig_tmp': No such file or directory
    cp: cannot stat `dist.info': No such file or directory
    Alle Voraussetzungen erfuellt.
    Here we go...
    chmod: cannot access `./install.php': No such file or directory
    
    ./setup2: line 1090: mysql_config: No such file or directory
    ./setup2: line 1091: httpd: No such file or directory
    ./setup2: line 1092: httpd2: No such file or directory
    ./setup2: line 1093: httpd2: No such file or directory
    ./setup2: line 1103: ip_addresses: No such file or directory
    ./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
    ./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
    Neustart einiger Dienste...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    [Mon Oct 13 13:03:40 2008] [warn] VirtualHost 78.47.110.xxx:443 overlaps with VirtualHost 78.47.110.229:443, the first has precedence, perhaps you need a NameVirtualHost directive
    [Mon Oct 13 13:03:40 2008] [warn] VirtualHost 78.47.110.xxx:443 overlaps with VirtualHost 78.47.110.229:443, the first has precedence, perhaps you need a NameVirtualHost directive
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.46.44.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.46.44.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.46.44.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.230:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.229:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    [Mon Oct 13 13:03:40 2008] [warn] NameVirtualHost 78.47.110.xxx:80 has no VirtualHosts
    httpd not running, trying to start
    ./setup2: line 1143: [: ==: unary operator expected
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ISPConfig system...
    /etc/init.d/ispconfig_server: line 66: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    ISPConfig system stopped!
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    /etc/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/init.d/ispconfig_server: line 48: /root/ispconfig/php/php: No such file or directory
    ISPConfig system is now up and running!
    Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.
    
    ./setup2: line 1189: cd: /root/install_ispconfig/compile_aps/../..: No such file or directory
    root@ts-onlyfree:~/install_ispconfig# 
    
    apache ist tot und meldet folgendes im log
    Code:
    Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d': No such file or directory
    Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d': No such file or directory
    Unable to open logs
    hab leider kein rat... alles gemacht wie es in der mail stand, tar.gz geladen, entpackt, setup gestartet ... wie immer halt... aber nu geht nix mehr :(

    bitte um hilfe =)

    cya
    ts-onlyfree
     
  2. ts-onlyfree

    ts-onlyfree New Member

    so also ispconfig setup lief jetzt durch, hab sophos ausgemacht... apache ist wieder on, aber ispconfig will nicht starten, dafür gibts hier die meldungen

    Code:
    root@ts-onlyfree:~/install_ispconfig# /etc/init.d/ispconfig_server restart
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    ISPConfig system is now up and running!
    
    diese hier "shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory" kommt bei jeder eingabe auf der shell... ich werd gleich wahnsinnig :D

    hat jemand eine idee?
     
  3. Till

    Till Administrator

    Ich hoffe Du hast das Setup script nicht ein 2. mal aufgerufen ohne vorher:

    mkdir /root/ispconfig

    aufzurufen? Wenn nicht dann lief das Script beim 2. Mal im Install statt Update mode durch. Ob die Datenbank das überlebt hat, können wir aber erst feststellen nachdem Du wieder auf das Interface zugreufen kannst. dazu musst Du erstmal die SSL Zertifikate neu erzeugen:

    http://www.howtoforge.com/forums/showpost.php?p=358&postcount=4

    und dann ispconfig neu starten.

    Die Fehler die Du am Ende auf der Shell erhalten hast kommen daher, dass Du Dich in einem nicht existenten Verzeichnis befindes. Mach doch mal ein: cd /root oder so und sie sind weg.
     
  4. hunter999

    hunter999 New Member

    Hallo,

    habe ein ähnliches Problem. Ich hatte beim Updatelauf zwischen durch mal auf die Pause Taste gedrückt weil ich eine Meldung lesen wollte. Danach brach der Update Vorgang ab.
    Anschließend habe ich das install_ispconfig verzeichniss gelöscht. Den Ordner ispconfig mit mkdir /root/ispconfig neu erstellt. Nun lief der Update Prozess normal wieder durch. Am Ende kam folgende Meldung:

    Code:
    Alle Voraussetzungen erfuellt.
    Here we go...
    
    Connected successfully to db db_ispconfig
    Neustart einiger Dienste...
    Stopping Postfix Mail Transport Agent: postfix.
    Starting Postfix Mail Transport Agent: postfix.
    Stopping ftp server: proftpd.
    Starting ftp server: proftpd - setting default address to 127.0.0.1
    .
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!
    Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.
    
    Die Webseiten vom System laufen.
    Nur leider gibt ISPConfig unter https://www.fqdn.de:81 einen "Access Denied" aus.
    Any Ideas?
     
  5. Till

    Till Administrator

    Siehe mein Post in diesem Thread ;)
     
  6. hunter999

    hunter999 New Member

    :eek: uups. Ja klar. Danke für den Tipp.

    Tja, was soll ich sagen?

    Wie immer: DANKE!!!

    Passt alles wieder. :)

    Edit: Ist es richtig das unter Administration ->System Config -> Eigenschaften der Reiter Allgemein leer ist?
     
    Zuletzt bearbeitet: 14. Okt. 2008
  7. Till

    Till Administrator

    Ja, das ist richtig. das ist schon immer so :)
     
  8. hahni

    hahni Active Member

    Huhu Till,

    ich glaube zwar nicht, dass mein Problem so "simpel" ist, aber ich kann seit 2.2.25 auch nicht mehr updaten. Es erscheint die Abfrage nach der Sprache. Aber eben auch der Warning, dass in Zeile 97 von ./setup2 der IMPORT nicht ausgeführt werden konnte.

    Ich bin etwas ratlos und habe keine Ahnung, woran das liegen könnte. Was genau macht denn dieser IMPORT? Stimmt mit den Pfaden auf meinem System etwas nicht? Wenn ja: wie kann ich dies prüfen? Gibt es andernfalls ein Problem mit dem make oder gcc auf meinem System?

    Habe extra noch einmal 2.2.25 kompilieren lassen. Dort läuft alles. Und das, obwohl ich vorher die Verzeichnisse "/root/ispconfig" geleert hatte. Ebenso im "/home/admispconfig". Ich bin echt total ratlos; möchte aber gerne auch die neuen Updates einspielen. Hat denn tatsächlich sonst keiner hier ein ähnliches Problem?

    Viele Grüße

    Hahni
     
  9. hahni

    hahni Active Member

    Auch der unter "http://www.howtoforge.com/forums/showthread.php?t=27501" befindliche Tipp, mit "apt-get install mysql-server mysql-client libmysqlclient15-dev" hat nix geholfen.

    Zwar wurde die "libmysqlclient12-dev"-Version entfernt und gegen "libmysqlclient15-dev" ausgetauscht. Aber die Fehlermeldung ist nach wie vor die gleiche:

    ---
    ./setup2: line 76: export: `/etc/init.d': not a valid identifier
    ---
     
  10. hahni

    hahni Active Member

  11. Till

    Till Administrator

  12. hahni

    hahni Active Member

    Moin Till,

    normalerweise mach ich ja auch nur einen Thread auf! Aber hier bin ich sehr verzweifelt und weiß einfach nicht weiter.

    Außerdem schicke ich immer, wenn ich selbst ein Problem gelöst habe, immer eine Erklärung, warum es nun funktioniert.

    Es sollen auch die anderen Benutzer bei ähnlichen Problemen davon partizipieren und die Sachverhalte leicht über Google finden.

    Viele Grüße

    Hahni
     
  13. ts-onlyfree

    ts-onlyfree New Member

    ololol doch genau das hab ich gemacht :D die db hats überlebt, und wenn net, gäbs alle 4h ein backup :)

    anlegen der certs hat geholfen !!! :D THX !!!
     

Diese Seite empfehlen