Firbidden 403 bei seitenaufruf

Dieses Thema im Forum "Allgemein" wurde erstellt von theseeker, 15. Apr. 2010.

  1. theseeker

    theseeker New Member

    Hallo,

    ich habe mir zu Testzwecken einen Ubuntu Server 8.04 in einer VM installiert und ISPConfig Version: 3.0.2.1.
    Mit DynDNS.org habe ich mir die Domain hardi.homeip.net freigeschaltet. Wenn ich nun mit http://hardi.homeip.net darauf zugreife komme ich auch auf die default Seite vom Apache (It Works).

    Nun habe ich mir einen Kunden test eingerichtet. Dazu eine Seite, im Feld Domain habe ich test.hardi.homeip.net.

    im Verzeichnis /var/www steht nun folgendes:
    Code:
    lrwxrwxrwx 1 root    root      30 2010-04-15 17:59 test.hardi.homeip.net -> /var/www/clients/client4/web4/
    Im Feld ip habe ich die IP des Servers eingegeben (192.168.27.51).
    Wenn ich nun auf die Seite mittels http://hardi.homeip.net/test.hardi.homeip.net gehe kommt diese Fehlermeldung im Browser:
    Code:
    Forbidden
    
    You don't have permission to access /test.hardi.homeip.net on this server.
    
    Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.10 with Suhosin-Patch Server at hardi.homeip.net Port 80
    Ein cat /var/log/apache2/error.log gibt folgendes aus:
    Code:
    [Thu Apr 15 18:05:17 2010] [error] [client 93.199.203.49] client denied by server configuration: /var/www/test.hardi.homeip.net
    [Thu Apr 15 18:05:17 2010] [error] [client 93.199.203.49] File does not exist: /var/www/favicon.ico, referer: http://hardi.homeip.net/test.hardi.homeip.net
    
    In der /etc/apache2/sites-available/test.hardi.homeip.net.vhost steht dieses:
    Code:
    <Directory /var/www/test.hardi.homeip.net>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost 192.168.27.51:80>
        DocumentRoot /var/www/clients/client4/web4/web
    
        ServerName test.hardi.homeip.net
        ServerAdmin webmaster@test.hardi.homeip.net
    
        ErrorLog /var/log/ispconfig/httpd/test.hardi.homeip.net/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    	
        <Directory /var/www/test.hardi.homeip.net/web>
            Options FollowSymLinks
            AllowOverride none
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
        <Directory /var/www/clients/client4/web4/web>
            Options FollowSymLinks
            AllowOverride none
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
    
        # cgi enabled
    	<Directory /var/www/clients/client4/web4/cgi-bin>
          Order allow,deny
          Allow from all
        </Directory>
        ScriptAlias  /cgi-bin/ /var/www/clients/client4/web4/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup web4 client4
        # suphp enabled
        <Directory /var/www/clients/client4/web4/web>
            suPHP_Engine on
            # suPHP_UserGroup web4 client4
            AddHandler x-httpd-suphp .php .php3 .php4 .php5
            suPHP_AddHandler x-httpd-suphp
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web4 client4
        </IfModule>
    
    
    </VirtualHost>
    
    Wenn ich nun aber ganz oben in der vhost-Datei diese reinschreibe geht alles fast wie es soll:
    Code:
    <Directory /var/www/test.hardi.homeip.net>
        AllowOverride None
        Order Deny,Allow
        Allow from all
    </Directory>
    .....
    
    Der Befehl hostname gibt folgendes aus:
    Code:
    hardi.homeip.net
    Der Befehl hostname -f :
    Code:
    hardi.homeip.net
    Ich bin nun nicht unbedingt der Serveradmin, um ehrlich zu sein habe ich keine Ahnung von solchen Sachen. Ich wollte einfach nur ein einfaches System haben wo ich ein paar Webseiten verwalten kann und ich auf einfache art weise auch den entsprechenden FTP zugang einrichten. Bis jetzt habe ich das immer auf einen Öffenlichen Webserver gemacht aber da der Speicherplatz doch recht Begrenzt ist würde ich es ganz gerne Local machen zum Testen. Ausserdem habe ich jetzt Blut geleckt! :D

    MfG TheSeeker
     

Diese Seite empfehlen