firewall

#1
Habe einen neuen Server mit CentOS 7aufgesetzt und nach der beschriebenen Perfect Server konfiguriert.
Beim durchsehen von systemd ist mir aufgefallen, das bastille-firewall gar nicht läuft und wenn man es aktiviert (Regeln sind in ISP-config erstellt) die Netzwerkverbindung gekappt wird.
 
#2
so habe mal spassens halber ein centos 7 in einer vm installiert und ispconfig installiert und configuriert.
der gleiche effekt. iptables läuft nicht, bastille läuft nicht mit der ausgabe iptables -L kommt folgendes
[root@static run]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Jetzt stellt sich die Frage was da verkehrt läuft.

https://access.redhat.com/documenta...ewalld_to_system-config-firewall_and_iptables
 
#3
Ich denke mal es liegt daran das Deine Netzwerkkarte nicht in Basitlle hinterlegt ist.
Schau mal mit ifconfig nach wie die Karten heißen, und sieh in der bastille-firewall.cfg nach ob eben Dein Interface da steht unter PUBLIC_IFACES
Sollte Deine Karte nicht als eth* erscheinen bei Ausgabe von ifconfig, dann hast du das gleiche Problem was ich hatte. Die Kiste wird komplett dichtgemacht und alle Regeln die erstellt wurden, greifen dann auf eth0 bzw eth0:1 usw. da aber kein Interface so lautete ist kiste dicht.
Bei mir heißt die Karte zum Beispiel p10p1 also hab ich bei PUBLIC_IFACES noch p10p1+ hinzugefügt und schon klappts mit der Firewall und die Kiste ist wieder erreichbar.

Vielleicht hilfts auch bei Dir.
 
#4
Werde ich mir mal anschauen, aber ich werde mir auch mal die Möglichkeit anschauen, ein Plugin zu erstellen für Firewalld......benutze CentOS 7 und mag ganz gerne die originalen Feature des BS benutzen.
Ich glaube es hat sich auch was in den Rules zu iptables geändert, damit es mit firewalld-cmd zusammenspielte.
Aber Danke für Deine Antwort als, Soforthilfe ist es genau richtig.
 

Werbung