FTP funktioniert "teilweise" nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von beliar, 22. Juli 2009.

  1. beliar

    beliar New Member

    Hi Leute,

    Nach der Installation eines Servers nach der Anleitung

    http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-3/

    scheint alles eigentlich so zu funktionieren wie es soll (hoffe ich mal).

    Einziges Problem das ich (bewusst) identifizieren kann ist der FTP-Server.

    Dieser scheint zu laufen und Verbindungn sind scheinbar auch möglich allerdings ... naja seht selbst:

    Code:
    Transmit 3.5.5 Session Transkript
    LibNcFTP 3.1.9 (March 19, 2005) compiled for UNIX
    Uname: Darwin|*****.local|8.11.0|Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC|Power Macintosh
    220: --------- Welcome to Pure-FTPd [privsep] [TLS] ----------
         You are user number 1 of 50 allowed.
         Local time is now 14:46. Server port: 21.
         This is a private system - No anonymous login
         IPv6 connections are also welcome on this server.
         You will be disconnected after 15 minutes of inactivity.
    Connected to **.***.***.***.
    Cmd: USER ********
    331: User ******** OK. Password required
    Cmd: PASS xxxxxxxx
    230: User ******** has group access to:  client1  sshusers
         OK. Current restricted directory is /
    Logged in to **.***.***.*** as ********.
    Cmd: SYST
    215: UNIX Type: L8
    Cmd: PWD
    257: "/" is your current location
    Cmd: PASV
    227: Entering Passive Mode (**,***,***,***,***,**)
    Cmd: LIST -a
    150: Accepted data connection
    226: Sorry, we were unable to read [.]
         Options: -a -l 
         0 matches total
    
    Was soll "226: Sorry, we were unable to read [.]" bedeuten und wieso scheine ich der einzige der nach einer frischen installation dieses Problem hat?

    Zur Info:

    System Debian 5 (net-install - Standardsystem)
    ISPConfig installiert via SVN (apt-get install subversion" usw.) laut Anleitung
    Clients: im moment 1
    Seiten: 2 Domains (NameBasedHost)
    FTP-Benutzer: 1
    alle erstellt mit ISPConfig

    Weiters:
    Ich habe derzeit keine Domains die auf den Server zeigen. Zu Testzwecken trage ich die Domains in die hosts-Datei meines PCs ein.
    Ach muss ich "warnen" das meine Linux-"erfahrung" praktisch 0 ist.

    Ich hoffe mir kann geholfen werden :)
     
  2. Till

    Till Administrator

    Probier mal bitte active mode in Deinem FTP Client.

    Außerdem ein kleiner Tipp, installiere niemals eine SVN Version auf einem Produktivsystem. SVN Versionen sind ausschließlich zum testen und für entwickler gedacht.
     
  3. beliar

    beliar New Member

    Hi Till,

    thx für die info, funktioniert allerdings nicht.

    ein anderer gedanke:
    kann es sein das es durch die svn version (danke auch für den "tipp") nicht funktioniert? oder dürfte es doch eher ein ftp-problem als ein ispconfig problem sein?
     
  4. Till

    Till Administrator

    Poste mal die Ausgabe von:

    netstat -tap | grep ftp
     
  5. beliar

    beliar New Member

    bitte sehr:
    hosting:~# netstat -tap | grep ftp
    tcp 0 0 *:ftp *:* LISTEN 2524/pure-ftpd (SER
    tcp6 0 0 [::]:ftp [::]:* LISTEN 2524/pure-ftpd (SER
     
  6. Till

    Till Administrator

    Stell mal in ispconfig unter system > server config auf dem web tab die securityEinstellung von high auf mdium und ändere dann was am we, z.B. quota und speichere. Warte eine Minute und probier es mit dem FTP nochmal.
     
  7. beliar

    beliar New Member

    keine änderung weder im activ noch im passive mode

    Nachtrag:

    aus "langeweile" hab ich einen 2. benutzer für die selbe seite angelegt (client1/web1). ich musste feststellen das auch er die selben probleme hat wie mein 1. benutzer.

    ich habe dem 2. user das Verzeichnis geändert von "/var/www/clients/client1/web1" auf "/var/www/" und plötzlich wird mir etwas angezeigt.

    dann wechselte ich in den ordner "clients/client1/web1" (manuell im ftp client) und hatte das selbe problem wie vorher.

    --> es stimmt etwas mit dem ordner nicht

    hier die zugriffsrechte

    Code:
    hosting:/var/www/clients/client1# ls -l
    insgesamt 8
    lrwxrwxrwx 1 root root   30 21. Jul 14:06 domain1.at -> /var/www/clients/client1/web1/
    lrwxrwxrwx 1 root root   30 22. Jul 12:14 domain2.com -> /var/www/clients/client1/web5/
    drwx--x--x 6 root root 4096 22. Jul 11:51 web1
    drwx--x--x 6 root root 4096 22. Jul 12:14 web5
    hosting:/var/www/clients/client1# cd web1
    hosting:/var/www/clients/client1/web1# ls -l
    insgesamt 16
    drwx--x--x 2 web1 client1 4096 21. Jul 14:06 cgi-bin
    lrwxrwxrwx 1 web1 client1   31 21. Jul 14:06 log -> /var/log/ispconfig/httpd/domain1.at
    drwx--x--x 2 web1 client1 4096 21. Jul 14:06 ssl
    drwx--x--x 2 web1 client1 4096 21. Jul 14:06 tmp
    drwx--x--- 4 web1 client1 4096 21. Jul 14:06 web
    hosting:/var/www/clients/client1/web1# 
    
    irgendwie scheine ich zugriff auf ordner zu haben die "root" gehören aber nicht auf ordner die "client1" gehören.

    Nachtrag 2:
    mein letzter satz stimmt noch ganz ...
    Code:
    drwxr-xr-x 4 root root 4096 22. Jul 12:14 client1
    da habe ich leserechte
    Code:
    drwx--x--x 6 root root 4096 22. Jul 11:51 web1
    Hier allerdings nicht mehr ....
    die ordner werden von ispconfig erstellt --> dort müsste das problem liegen
     
    Zuletzt bearbeitet: 23. Juli 2009
  8. beliar

    beliar New Member

    "Nachtrag 3:"

    das scheint zu funktionieren wenn man eine neue site (domain) anlegt, allerdings werden die Zugriffsrechte der alten bestehenden domains nicht geändert.

    ich habe sie im shell manuel geändert --> habe jetzt ftp zugriff
     
  9. Samir

    Samir New Member

    Hier gibts noch einen Thread zum gleichen Problem: http://www.howtoforge.de/forum/showthread.php?p=12251

    das gleiche Problem hatten wir auch...

    Wir haben einen etwas anderen Lösungsweg gewählt:
    Das Home-Verzeichnis des FTP-Users setzen wir auf /var/www/clientx/weby/web (der User soll die anderen Verzeichnisse nicht nutzen). Dazu haben wir das Skript [...]/ispconfig/interface/web/sites/ftp_user_edit.php geändert.

    Jeweils die zwei Zeilen

    $dir = $web["document_root"];

    in

    $dir = $web["document_root"]."/web";

    Dadurch wird in der MySQL-Tabelle das Home-Verzeichnis in web geändert.

    Ich bin mir nur nicht sicher, ob diese Änderung ausreicht und die Datenkonsistenz erhalten bleibt. Kann da jemand was zu sagen?
     
  10. Till

    Till Administrator

    Die korrekte Änderung ist, den security Level zu ändern. Wenn Ihr eine betaversion verwendet, dann kann da ahlt bei neuen Features auch mal ein Problem sein. In der Final wird der neue Security Level dann ja auch funktionieren.
     

Diese Seite empfehlen