FTP läuft nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von joeby, 8. Feb. 2010.

  1. joeby

    joeby New Member

    Hallo,

    ich habe eben einen Virtuellen Server von Strato mit Debien Lenny gemäß

    Der Perfekte Server – Debian Lenny (Debian 5.0) [ISPConfig 3] ab Punkt 5

    installiert. Fast alles läuft, nur Pure-ftpd läuft nicht

    Code:
    /etc/init.d/pure-ftpd-mysql restart:
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -O clf:/var/log/pure-ftpd/transfer.log -b -B
    Aber:
    ISPConfig zeigt FTP als nicht laufend an

    Das FTP-Programm zeigt:
    Code:
    Can't exec "/usr/sbin/pure-ftpd": Datei oder Verzeichnis nicht gefunden at /usr/sbin/pure-ftpd-wrapper line 174.
    /var/log/pure-ftpd ist leer (Trotz verbose 1)


    pure-ftpd-common
    pure-ftpd-mysql
    Sind laut dpkg installiert

    user web1 ist angelegt

    Ich habe jetzt lange hier rumgesucht und gesehen, dass es mit pure-ftpd nicht ganz problemlos ist. Aber meinen Fall habe ich noch nicht gefunden. Herzlichen Dank im Voraus für Tipps!

    joeby
     
  2. Till

    Till Administrator

  3. joeby

    joeby New Member

    Hallo Till,

    danke für Deine schnelle Hilfe.

    Entsprechend dem Link und ergänzend dazu habe ich

    die alte Version entfernt
    Code:
    apt-get remove pure-ftpd-mysql
    /etc/apt/sources.list ergänzt
    Code:
    deb-src http://ftp.de.debian.org/debian/ lenny main contrib non-free
    deb-src http://security.debian.org/ lenny/updates main contrib non-free
    und apt aktualisiert
    Code:
    apt-get	update
    apt-get	upgrade
    dann
    Code:
    cd /tmp 
    apt-get source pure-ftpd 
    apt-get build-dep pure-ftpd 
    cd pureftpd-xxx/debian 
    
    dannach nano rules
    Code:
    optflags 	optflags=–with-everything –with-largefile –with-pam –with-privsep –with-tls –without-capabilities 
    Schließlich
    Code:
    cd ..
    dpkg-buildpackage -uc -b
    cd ..
    dpkg -i pure-ftpd-mysql_1.0.xxx_i386.deb 
    /etc/init.d/pure-ftpd-mysql restart 
    Nur Leider funktioniert es nicht:

    Code:
    dpkg -i pure-ftpd-mysql_1.0.21-11.4_i386.deb
    Wähle vormals abgewähltes Paket pure-ftpd-mysql.
    (Lese Datenbank ... 38669 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacke pure-ftpd-mysql (aus pure-ftpd-mysql_1.0.21-11.4_i386.deb) ...
    Richte pure-ftpd-mysql ein (1.0.21-11.4) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -d -A -O clf:/var/log/pure-ftpd/transfer.log -b -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: Fehler beim Bearbeiten von pure-ftpd-mysql (--install):
     Unterprozess post-installation script gab den Fehlerwert 252 zurück
    Fehler traten auf beim Bearbeiten von:
     pure-ftpd-mysql
    
    ISPConfig meldet: FTP-Server läuft nicht

    Deshalb meine dumme Frage: Watt nu?:confused:

    Grüßle Jörg
     
  4. Till

    Till Administrator

    Ruf bitte mal folgendes auf der Shell als root user auf:

    Code:
    /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -d -A -O clf:/var/log/pure-ftpd/transfer.log -b -B
    
    und poste die Ausgabe, die Du erhältsts.
     
  5. joeby

    joeby New Member

    Hallo Till,

    das habe ich gemacht. Es kam überhaupt keine Antwort und in /var/log/pure-ftpd findet sich auch garnichts.

    LG joeby
     
  6. Till

    Till Administrator

    Poste mal die Ausgabe von:

    netstat -tap | grep ftp
     
  7. joeby

    joeby New Member

    netstat -tap | grep ftp
    tcp6 0 0 [::]:ftp [::]:* LISTEN 9868/xinetd

    LG Jörg
     
  8. Till

    Till Administrator

    Da läuft zur zeit ein anderer ftp server, daher kann pure-ftpd auch nicht starten. entferne den anderen ftp server aus der xinetd konfiguration, starte xinetd neu und dann versuch nochmal, pure-ftpd zu installieren.
     
  9. joeby

    joeby New Member

    Habe jetzt in /etc/xinetd.d mit touch die Datei ftp angelegt.

    Dort eingefügt:

    Code:
    service ftp
    { (
    disable         = yes disable = yes
    socket_type     = stream socket_type = stream
    protocol        = tcp protocol = tcp
    wait            = no wait = no
    user            = root user = root
    instances       = UNLIMITED instances = UNLIMITED
    server          = /usr/sbin/in.proftpd server = / usr / sbin / in.proftpd
    server_args     = -c /etc/proftpd.conf server_args =-c / etc / proftpd.conf
    } )
    Diese Sequenz habe ich zum Abschalten der FTP-Funktion von xinet im Netz gefunden, denn in der Datei /etc/xinetd.conf war nur der Eintrag
    Code:
    includedir /etc/xinetd.d
    In diesem Verzeichnis fand sich keine Datei, die ftp betrifft.


    Dann
    Code:
    /etc/init.d/xinetd restart 
    Jetzt gibt netstat keinen ftp mehr aus, xinet kommt dort nicht vor:
    Code:
    netstat -tap | grep ftp
    Keine Ausgabe

    Dann
    Code:
    /etc/init.d/pure-ftpd-mysql restart 
    Probleme weiterhin wie oben:
    Code:
    /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -d -A -O clf:/var/log/pure-ftpd/transfer.log -b -B
    Keine Ausgabe

    Unter ISPConfig: FTP läuft nicht.

    Ich ... ratlos ... :confused:

    LG Jörg
     
  10. Till

    Till Administrator

    Es läuft ja genau deswegen nicht, weil Du da was in xinetd eingetragen hast. FTP über xinetd ist inkompatibel mit ispconfig. Das steht auch ganz klar in den Installationsaleitungen dass Du es nicht in xinetd oder inetd eintragen sollst. Also enteferne alles in inetd und xinetd was mit ftp zu tun hat und satrte pure-ftpd als stanadlone Daemon.
     
  11. Free99

    Free99 New Member

    Andere Frage... musste leider auch das Paket manuell installieren.
    Jetz möchte aber aptitude bei jedem upgrade den pureftpd updaten... und zerschiesst mir nat. das Paket wieder... wie kann ich das verhindern, dass er das jedesmal macht und ich es neuinstallieren muss?
     
  12. Till

    Till Administrator

    versuch mal:

    echo "paketname hold"|dpkg --set-selections

    wobei Du paketname durch den Namen des Debian Paketes ersetzen musst.
     
  13. Klatschianer

    Klatschianer New Member

    Ich habe das selbe Problem bei Strato. Bin ebenfalls nach Anleitung vorgegangen. Ich hänge mal die unveränderte xinetd an.
    Was genau muss entfernt werden?

    Ich finde da jetzt nix, was auf FTP hinweist.

    Danke für die Hilfe.
     
    Zuletzt bearbeitet: 16. Feb. 2010
  14. Till

    Till Administrator

    @Klatschianer: Dann hast Du eben nicht das gleiche Problem. Mach bitte einen neuen Thread auf und poste eine exakte Beschreibung Deines Problems.
     
  15. Klatschianer

    Klatschianer New Member

    Okay, sorry
     
  16. Free99

    Free99 New Member

    sehr schön... vielen dank Till, jetz klappts ;)
     

Diese Seite empfehlen