FTP-Zugang zeigt auf falschen Ordner

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Blackwolf, 7. Juni 2008.

  1. Blackwolf

    Blackwolf New Member

    Salve,...

    Ich habe mir bei Strato einen Server zugelegt und die Installation von ISPconfig auf Debian 4.0 funktionierte auch einwandfrei.

    Ich habe zwei Beispiel-Webs angelegt und auch zwei Beispiel-Kunden.

    Laut Howto liegen die Webs in /var/www/

    Dort liegt auch wirklich ein Symlink mit der Domain, der auf den Ordner "web2" im gleichen Verzeichnis verweist, in dem sich ein Ordner namens "web" befindet.

    Soweit so gut.

    Als ich nun den FTP-Upload mache, öffnet sich auch ein Ordner namens "web" im "/" (wobei ich natürlich vom DocRoot ausgehe) und ich schiebe meine Website hoch.

    Bei der Kontrolle im Browser kommt aber die Standard-ISP-Site für die Domain.

    Also Fehlersuche!

    Folgendes habe ich herausgefunden:

    Der FTP connected auf den Ordner:
    /var/www/web2/user/web2_001/web/

    Der Symlink, den ISP-Config für den Browser in /var/www/ anlegt, verweist auf:
    /var/www/web2/web/

    Das bedeutet, das die Website in einem anderen Ordner hochgeladen wird, als der Apache sie abbildet, was natürlich blöd ist.

    Wie kann ich ISP-Config nun so (und vor allem wo) konfigurieren, das FTP und Apache immer auf den gleichen Ordner zeigen?

    Für 'ne schnelle Hilfe wäre ich dankbar ...

    [Edit]

    Mittlerweile habe ich herausgefunden, das ISP-Config die Datei:
    /etc/apache2/vhosts/Vhosts_ispconfig.conf

    ... anlegt, in der das DocumentRoot definiert ist (DocumentRoot /var/www/web2/web). Nachdem ich das DocumentRoot händisch auf: DocumentRoot /var/www/web2/user/web2_001/web korrigiert habe, klappt's - logischerweise - auch mit der Anzeige der Site.

    Da ISP-Config die Datei anlegt, müsste ich also jedesmal "händisch" das Verzeichnis anpassen. Es muß also irgendwo eine Datei geben, auf die ISP-Config bei der Anlage, bzw. der Modifikation der Vhosts_ispconfig.conf zugreift und in der ich den Pfad anpassen kann. Frage ist nur ... wo?

    Kann es sein, das die Aliase in /etc/apache2/vhosts/Vhosts_ispconfig.conf ...
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3

    ... irgendwie einen Fehler haben?

    [/Edit]


    Greetz
    Blackw:cool:lf
     
    Zuletzt bearbeitet: 7. Juni 2008
  2. Till

    Till Administrator

    Du hast vergessen die Administrator Checkbox bei dem User zu aktivieren, mit dem Du die Webseite hochgeladen hast.
     
  3. Blackwolf

    Blackwolf New Member

    *hüpf ...

    Danke Till,... hat funktioniert ...

    Aber wer soll denn auch darauf kommen ... :rolleyes:

    Greetz ...
    Blackw:cool:lf
     
  4. prego

    prego New Member

    Hi,

    habe genau das selbe Problem? Heißt das jeder User muss Admin sein, damit es "richtig" funktioniert? Ich verstehs nicht ganz, vielleicht kanns mir einer erklären.

    DocRoot zeigt auf /var/www/webx/web, aber wenn ich per FTP connecte lande ich in /var/www/webx/user/web_<user>/web/. Muß ich also jeden User zu nem Admin machen (was ja nicht geht, da ja nur ein User Admin sein darf), damit er seinen WebSpace auch benutzen kann?

    Wie erreiche ich per Browser /var/www/webx/user/web_<user>/web/?
    Was darf der User mehr wenn er Admin ist?

    //edit:
    Ich glaube ich habs verstanden. Der Admin ist für (zB) www.example.de zuständig. Alle anderen User haben ja ein Userverzeichnis in Form von www.example.de/~web1_test/ - richtig?
     
    Zuletzt bearbeitet: 18. Juni 2008
  5. Till

    Till Administrator

    Ja, genau so ist es :)
     

Diese Seite empfehlen