ftppolicy

#1
gemeint ist natürlich "ftplicity" ;-)

das c´t Script ist schon echt ne feine Sache, das Backup scheint auch mit "ftplicity backup" zu funktionieren. Bei der Angabe der Optionen: "ftplicity list" oder "ftpplicity verify" bekomme ich aber folgende Fehlermeldung:

"Command line error: option --verify not recognized
Enter 'duplicity --help' for help screen."

Ich nehme mal an das das c´t Script den Parameter an duplicity schickt und dann duplicity die Fehlermeldung zurückschickt. Liegt es vielleicht an einer neuen geänderten Version von duplicity?

Ich verwende den Ubuntu-Server 8.04. Installiert ist duplicity 0.4.10-1
 
Zuletzt bearbeitet:
#2
jo, gleiches Problem habe ich auch seit dem Upate von debian sarge auf lenny.

EDIT: so hab ne Lösung gefunden, zumindest bei den beiden Servern unter lenny die das Problem aufweisen.

Die Datei ftplicity editieren (liegt bei mir unter /usr/local/bin) und dort zu Beginn in der funktion ftply das "$@" direkt nach duplicity setzen und in der letzten Zeile dann dauch den \ entfernen. Sieht dann so aus:

function ftply { # die eigentliche Wrapper-Funktion
FTP_PASSWORD="$ZIEL_PW" \
PASSPHRASE="$GPG_PW" \
TMPDIR="$TEMP_DIR" \
$DUPLICITY "$@" --encrypt-key $GPG_KEY \
--sign-key $GPG_KEY --verbosity $VERBOSITY
}
dann weiter unten bei folgenden Parametern das -- davor entfernen: verify, list-current-files, cleanup und remove-older-than

Dann sollte es passen... zumindest ging's bei mir. Nur -- entfernen hat nichts gebracht, da er sich dann über die Parameter beschwert hat, daß er nur zwei wolle aber drei bekommen hat...

hth
 
Zuletzt bearbeitet:

Ben

New Member
#3
Was ich vergass, auch zu ändern ist bei --full das -- davor weg,
sowie das ganze full "$QUELLE" "$ZIEL" vor das --exlude... zu setzen.
 

Werbung

Top