GD - Problem ?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von w3bservice, 7. Nov. 2011.

  1. w3bservice

    w3bservice Member

    Hallo,
    Nach 3,5 Jahren meines alten Servers mit CentOS 5 und ISP-Config 2,habe ich meinen neuen Server unter ScientificLinux 6.1 und ISP-Config 3 aufgesetzt.
    Soweit so gut, Nach dem Umzug der Domains ist mir aufgefallen das bestimmte
    Captchas nicht funktionieren andere ja.
    Unter http://test03.jk-trockenbau.de/test2.php kann man die php-gd ausgabe sehen.
    Ich denke mal das GD funktioniert .
    Interessant ist das ein Captcha mit einem gdf-Font funktioniert aber nicht mit einen ttf-Font. Bewerbung2
    Ich wäre für jede Hilfe Dankbar
     
  2. nowayback

    nowayback Well-Known Member

    Moinsen,

    unter Debian gibts nen Paket Namens "ttf-freefont". Schriften die nicht installiert sind können halt nicht dargestellt werden. Vielleicht hilft dir das weiter.

    Grüße
    nwb
     
  3. w3bservice

    w3bservice Member

    freetype ist installiert da sonst des testscript nicht funktionieren würde.
    Habe aber gerade auf einem Testrechner zuHause (Rechner meiner Frau)
    ein Joomla mit den Erweiterungen installiert die rumzicken.
    Nachdem ich ein PHP-Upgrade von 5.3.3 auf 5.3.8 gemacht habe funktionierten die Captchas.Also werde ich jetzt die Pakete auf meinem Server installieren und mal schauen. Ich sage dann Bescheid.

    Danke für die Meldung.

    Gruss Jörg
     
  4. w3bservice

    w3bservice Member

    BESCHEID.

    Blöd es funktioniert nicht.
    Zu hause mit der Standartconf für php und apache ja, so wie es sich gehört.
    und draussen auf dem Server mit ispconfig 3 nicht.
    Der registrierungsprozess für event ist so verschachtelt das ich das captcha abschalten kann aber das formular ist schon eine geschickte sache mit dem Upload im Formular..
    Ich tippe mal auf einen Fehler im PHP von RedHat (CentOS/SL) und auf eine Konfiguration im ISP-Config.

    Frage an TILL Falko:
    Was kann da schief laufen ?
     
    Zuletzt bearbeitet: 7. Nov. 2011
  5. w3bservice

    w3bservice Member

    Nachdem ich die Seite in ISP-Config auf mod_php gestellt habe und die Rechte im
    Webverzeichnis auf 775 und /var/lib/php/session auf 777 geändert habe wurde der
    Captcha erstellt und die Formulare liessen sich verschicken.

    Da ich die Seite gerne unter suPHP laufen lassen möchte.
    Ist die Frage was muss ich ändern um die gleichen Effekte zu erreichen.
    Auf den Seiten ist ein Joomla 1.7 und 1.5 installiert.
     
  6. Till

    Till Administrator

    Für CMS Systeme wie joomla sollte man kein suphp nehmen, ist zu langsam. Sattdessen nimmt man am besten php-fcgi + suexec. Damit hast Du nämlich ausreichende Schreibrechte auf alle notwendigen Verzeichnisse und die notwendige Sicherheit, da alle Scripte unter dem userd es Webs und nicht dem apache user laufen. Und stell unbedingt alle Rechte wieder auf die Ursprungswerte zurück, insbesondere das Web Verzeichnis darf nicht world readable sein und alle Dateien darin müssen dem web User und der Client Gruppe des Webs gehören.

    Ich vermute mal Dein Problem hatte mit Falschen Dateieigentümern zu tun. Alle Dateien im Web Verzeichnis müssen dem web User und der Client Gruppe des Webs gehören. das ist der fall wenn Du sie per FTP hochlädst. Hantierst Du aber in dem Verzeichnis als root User rum, dann must Du unbedingt die Eigentümer aller dateien danach korrigieren.
     
  7. w3bservice

    w3bservice Member

    Ein Rechteproblem kann ich ausschliessen,da ich nur als FTP-User arbeite.
    Das Problem ist die fehlenden Rechte für die Sessioncookies unter /var/lib/php/session

    Ich werde mich mal mit php-fcgi beschäftigen.

    Bei Problemen melde ich mich mal dann.

    Danke Jörg
     
  8. w3bservice

    w3bservice Member

    Habe jetzt auf php-fcgi umgestellt.
    wenn ich in der vhost-datei richtig gelesen habe.

    php_admin_value session.save_path /var/www/clients/client1/web16/tmp

    Der Captcha funktioniert aber erst nach den 9xmal erneuern.

    Der Link kann ausprobiert werden test

    Ich weiss nicht mehr weiter.
    Sollte jetzt einer auf die Idee kommen eine andere Komponente zu nehmen wollen.

    Ich werde nicht zum Kunden hingehen und sagen ich bin zu blöd den webserver zu konfigurieren damit die Komponente läuft.

    Gruss Jörg
     
  9. w3bservice

    w3bservice Member

    php_admin_value session.save_path /var/www/clients/client1/web16/tmp

    wenn ich in das Verzeichniss gehe zeigt mir der FTP-Client folgendes an

    Rechte 0777 UID web16 GID client1
    Die sessioncookies werden aber mit UID 48 GID 48 und Rechte 0600 geschrieben.

    Ist das normal ?

    Gruss Jörg !
     
  10. Till

    Till Administrator

    Du musst in der Webseite suexec aktivieren, damit die php Scripte unter dem User des Webs laufen und außerdem muss der php-mode auf php-fcgi stehen.
     
  11. w3bservice

    w3bservice Member

    Hallo zusammen.

    Web steht auf cgi da fcgi nur Fehlermeldungen schmeisst.
    Problem bei der ganzen Hecktik mit den Captchas war eine Suhosin-konfiguration die 3,5 Jahre ohne Probleme unter CentOS5 und ISP-Config 2 lief und edliche Angriffe sauber abgefangen hat und jetzt Ihren Dienst versagt hat.
    Und in den Logdateien keine Meldung wegen der Fehler, naja.

    Jetzt werde ich mich in einer virtuellen Maschine mit dem Problem auseinandersetzen. Als Sahnehäbchen des ganzen hat ISP-Config-User W3BService keine Geduld mehr gehabt und wahrscheinlich mehrmals die PHP-Konfiguration geändert bevor ISP-Config die Änderungen aktivieren kann. Somit wurde das ganze Schweinetreiben verrückt und ich saß da und wusste nicht mehr weiter.

    Übrigens die Captchas funktionieren jetzt auch unter suPHP.
    Was so ein bisschen Paranoia auslösen kann.

    In dem Sinne Danke ;) und Ihr könnt jetzt eure Hirnwindungen wieder auseinanderknoten und entspannt den Sonntag geniessen. :)

    Wegen FCGI komme ich nochmal auf Euch zurück ;)

    Danke nochmals


    P.S. Kann als gelöst markiert werden !!!
     

Diese Seite empfehlen