[Gelöst] Neu angelegte Kundenwebseiten funktionieren nicht mehr [500 internal]

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von saarworres, 30. Aug. 2015.

  1. saarworres

    saarworres New Member

    Hallo,

    ich betreiebe einen Debian jessie Server mit ISPConfig 3.0.5.4p8
    Momentan sieht es so aus, als würden alle bisher angelegten Webseiten tadellos funktionieren, allerdings bekomme ich einen Fehler 500 für jede neu angelegte Seite.

    Ich dachte zuerst das Problem sei auf php-fpm zurückzuführen (Grund: bugtracker)und abe der Einfachheit halber auf Fast-CGI umgestellt. Mit dem selben Resultat.

    [Sun Aug 30 12:20:42.732821 2015] [fastcgi:error] [pid 2395] (2)No such file or directory: [client IP.IP.IP.IP:42666] FastCGI: failed to connect to server "/var/www/clients/client7/web24/cgi-bin/php5-fcgi-*-80-data.test.de": connect() failed
    [Sun Aug 30 12:20:42.732891 2015] [fastcgi:error] [pid 2395] [client IP.IP.IP.IP:42666] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client7/web24/cgi-bin/php5-fcgi-*-80-data.test.de"

    Angemahnter Ordner ist bei mir immer leer, - egal welcher PHP-Betriebsart ih wähle. Oder ISP3 stellt die Seite nicht mehr auf Fast-CGI zurück?
    Irgend jemand eine Idee?
     
  2. Till

    Till Administrator

    Der Bug aus dem Bugtracker ist schon in 3.0.5.4p5 behoben, kann also hier nicht vorliegen. Starte mal apache und php5-fpm manuell neu.
     
  3. saarworres

    saarworres New Member

    Hab ich schon. Als service und init.d. Ergebnis bleibt gleich. Ich hab mittlerweile schon den ganzen Server rebootet. Nach dem Motto viel hilft viel..
     
  4. saarworres

    saarworres New Member

    Ok zumindest so viel habe ich bisher zurück verfolgt. Alle alten Seiten haben einen Eintrag in pool.d bei php5/fpm bekommen. Die neue Seite, wenn ich Sie auf php-fpm stelle nicht. Es wird keine *.conf angelegt.

    Ich vermute mal es hat etwas mit 'server.sh' die ja jede Minute laufen soll, dennmein cron.log ist voll davon:

    Sun Aug 30 14:10:02 CEST 2015 PHP Warning: mysqli::mysqli(): Headers and client library minor version mismatch. Headers:50543 Library:100021 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 62

    Ich habe jetzt mal 'php-mysql' mit 'php5-mysqlnd' ausgetauscht. Vielleicht hilft es ja.
     
    Zuletzt bearbeitet: 30. Aug. 2015
  5. saarworres

    saarworres New Member

    Hm. Ok. Zur Zit sieht es für mich so aus, als würde nach dem Wechsel auf php-mysqlnd die server.sh ihre Jobwarteschlange ignorieren?

    30.08.2015 17:14 wsx.test.de Update web_domain
    30.08.2015 16:46 wsx.test.de Update web_domain

    Ok. Das abschalten des cronjobs für server.sh und der manuelle Aufruf tut nichts. Keine Fehlermeldung kein Abarbeiten der Jobwarteschlange einfach nichts außer starten und stoppen.

    UPDATE: Ok es hat nur unüblich lange gedauert, aber die Jobwarteschlange ist jetzt abgearbeitet und immerhin habe ich eine *conf in /etc/php/fpm/pool.d für die Kundenseite. Nur geändert hat das nichts an der Fehlermeldung. FastCGI bekommt noch immer keinen Kontakt zum Server und cgi-bin/ ist immer noch komplett leer.
     
    Zuletzt bearbeitet: 30. Aug. 2015
  6. Till

    Till Administrator

    Ich nutze php5-mysqlnd auf meinen Servern auch und da geht es problemlos.

    Das muss ja auch leer sein, denne s ist nur für cgi scripte und wird von keinem PHP Modus verwendet. Die Pfade in der FPM Konfiguration des apache sind "virtuell", es gibt diese Pfade und Dateien daher nicht im Filesystem.
     
  7. saarworres

    saarworres New Member

    Moin Till,

    Ok. Nur warum beschwert sich dann mein Apache dass er dort nichts findet? (siehe error.log oben)
    Immer. Es scheint dem System ja sogar egal wenn ich es auf ModPHP umstelle.
    Die Fehlermeldungen bleiben immer die selben.

    Der Prozess behauptet ja selbst, er bekäme keinen Kontakt zum Server und die header sind ja auch komplett null.
     
  8. Till

    Till Administrator

    Er sagt nicht dass er dort nichts findet sondern dass er sich nicht mit dem socket bzw. port des php-fpm prozess verbinden kann.

    Hast Du die suphp config Datei so geändert wie im perfcet server tutorial beschrieben?
     
  9. saarworres

    saarworres New Member

    Nein weil das Modul gar nicht aktiv war. (Laut Deiner Angabe ist es ja nicht empfohlen.) Ich habe das jetzt versucht kurz nach zu holen und bekome beimrestart des apache gleich eine Fehlermeldung bezüglich der suphp.load Zeile 1 um die Ohren gehauen.

    Ich hab es wieder deaktiviert und der Apache startet wieder. Aber kann es daran wirlich liegen? Es war voher ja nicht als Modul aktiv und die Seiten bisher habe ich ja auch angelegt und die Funktionierne tadellos.

    Ich bekomme jedenfalls eine web42.conf in /etc/php5/fpm/pool.d
    Aber keinen Socket für web42 unter /var/lib/php5-fpm/
    Ich weis nur nicht wo genau das Problem dazwischen liegt. Ich bekomme eine vhost.err für die Seite, die sich in nichts von der vhost-Datei unterscheidet.

    <Directory /var/www/data.test.de>
    AllowOverride None
    Require all denied
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/clients/client42/web42/web

    ServerName data.test.de
    ServerAdmin webmaster@data.test.de

    ErrorLog /var/log/ispconfig/httpd/data.test.de/error.log

    Alias /error/ "/var/www/data.test.de/web/error/"
    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 502 /error/502.html
    ErrorDocument 503 /error/503.html

    <IfModule mod_ssl.c>
    </IfModule>

    <Directory /var/www/data.test.de/web>
    # Clear PHP settings of this website
    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
    SetHandler None
    </FilesMatch>
    Options +FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>
    <Directory /var/www/clients/client42/web42/web>
    # Clear PHP settings of this website
    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
    SetHandler None
    </FilesMatch>
    Options +FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>




    # suexec enabled
    <IfModule mod_suexec.c>
    SuexecUserGroup web42 client42
    </IfModule>
    <IfModule mod_fastcgi.c>
    <Directory /var/www/clients/client42/web42/cgi-bin>
    Require all granted
    </Directory>
    <Directory /var/www/data.test.de/web>
    <FilesMatch "\.php[345]?$">
    SetHandler php5-fcgi
    </FilesMatch>
    </Directory>
    <Directory /var/www/clients/client42/web42/web>
    <FilesMatch "\.php[345]?$">
    SetHandler php5-fcgi
    </FilesMatch>
    </Directory>
    Action php5-fcgi /php5-fcgi
    Alias /php5-fcgi /var/www/clients/client42/web42/cgi-bin/php5-fcgi-*-80-data.test.de
    FastCgiExternalServer /var/www/clients/client42/web42/cgi-bin/php5-fcgi-*-80-data.test.de -idle-timeout 300 -socket /var/lib/php5-fpm/web42.sock -pass-header Authorization
    </IfModule>
    <IfModule mod_proxy_fcgi.c>
    ProxyPassMatch ^/(.*\.php[345]?(/.*)?)$ fcgi://127.0.0.1:9033/var/www/clients/client42/web42/web/$1
    </IfModule>


    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web42 client42
    </IfModule>

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client42/web42/webdav>
    <ifModule mod_security2.c>
    SecRuleRemoveById 960015
    SecRuleRemoveById 960032
    </ifModule>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    DavLockDB /var/www/clients/client42/web42/tmp/DavLock
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>
    </VirtualHost>
     
  10. Till

    Till Administrator

    Wenn Du es nicht installiert hast dann kann s nicht daran liegen.

    Hast Du mal versucht von socket auf port based in den optionend er website umzuschalten?
     
  11. saarworres

    saarworres New Member

    Ja habe ich. Hat die Fehlermeldung nicht verändert.
    Ich habs eben wieder zurück gestellt.
     
  12. saarworres

    saarworres New Member

    Ok nach einiger Recherche und herumprobieren und einem Telefonat hat sich das Problem gelöst. Es lag nicht an ISPC sondern wie so oft lag das Problem vor dem Bildschirm. Ein Kollege hatte vor einiger Zeit an WEBDAV herumexperimentiert und seine Änderungen bissen sich mit dem neuen Host. :mad:

    Es bleiben zwar bei mir Fragen wie 'Warum nur der eine vhost?' und 'Warum kommt dabei nichts konkretes in den Logs an?' offen, aber das darf er mir nach seinem Urlaub dann beantworten.

    Danke nochmals für die Hilfestellung Till.
     

Diese Seite empfehlen