*gelöst* postfix problem - email wird nicht zugestellt

#1
Ein freundliches Hallo in die Runde,

nachdem ich jetzt schon längere Zeit privat und in der Firma auf Linux umgestiegen bin, versuche ich auch die letzte Hürde zu nehmen um Windows abzuschalten. Bis jetzt läuft Win7 mit Jana als Emailzentrale an T-DSL mit fester IP. Neben diversen kleinen Problemen ist der geringe Uploadspeed zunehmend ein Problem.

"Möchte" das ganze jetzt auf einem Linux VServer (Strato) mit Ubuntu 16.04 (postfix/dovecot/fetchmail) umsetzen. Dank Anleitung und Hirneinsatz auch alles ok, aber ich bin an einem Punkt, an dem ich gerade verzweifel. Sämtliche Lösungsansätze brachten keinen Erfolg und ich habe jetzt auch keine Idee mehr, wo es hängt.

Thunderbird soll eine Email an zwei Emailadressen versenden (einzelner oder CC Versand machen keinen Unterschied). Ergebnis siehe Logfile unten aus meiner Sicht sauber. Ergebnis auf der Empfängerseite nur 50:50.

Email an Empfängerdomain1 kommt immer an, bisher keine Ausfälle. Email an Empfängerdomain2 kam noch nie an. Spamordner = negativ
Beide Empfängerdomains sind beim gleichen Provider gehostet (all-inkl) und auf das gleiche Paket geschaltet.

Absenderdomain ist bei (Provider xy) gehostet und der smtp ist korrekt. Das war zu vermuten da es teilweise funktioniert.


Code:
Jul 26 13:34:15 h2490037 postfix/submission/smtpd[2270]: connect from pdxxxxxxx.dip0.t-ipconnect.de[xxx.x.xxx.xx]
Jul 26 13:34:16 h2490037 postfix/submission/smtpd[2270]: 44CC059A1CC7: client=pdxxxxxxx.dip0.t-ipconnect.de[xxx.x.xxx.xx], sasl_method=PLAIN, sasl_username=username123
Jul 26 13:34:16 h2490037 postfix/cleanup[2273]: 44CC059A1CC7: message-id=<b913c996-8706-d649-3eae-d29287239558@absenderdomain.de>
Jul 26 13:34:16 h2490037 postfix/qmgr[2013]: 44CC059A1CC7: from=<office@absenderdomain.de>, size=607, nrcpt=2 (queue active)
Jul 26 13:34:16 h2490037 postfix/submission/smtpd[2270]: disconnect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx] ehlo=2 starttls=1 auth=1 mail=1 rcpt=2 data=1 quit=1 commands=9
Jul 26 13:34:16 h2490037 postfix/smtp[2274]: 44CC059A1CC7: to=<office@empfängerdomain1.de>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25, delay=0.47, delays=0.27/0.02/0.13/0.05, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 23270C047DFA3)
Jul 26 13:34:16 h2490037 postfix/smtp[2274]: 44CC059A1CC7: to=<office@empfängerdomain2.de>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25, delay=0.47, delays=0.27/0.02/0.13/0.05, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 23270C047DFA3)
Jul 26 13:34:16 h2490037 postfix/qmgr[2013]: 44CC059A1CC7: removed
Ich wäre über jeden Lösungsvorschlag dankbar.
vielen Dank Nick
 

nowayback

Well-Known Member
#3
sieht interessant aus... du hast bei beiden nen 250er bekommen. damit ist die sache für dich eigentlich erledigt. das interessante ist, dass beim empfänger beide mails die gleiche queue id haben.
wie dem auch sei... zuständigkeit -> all-inkl.
 
#5
ok, das scheint bei Versand mit CC Adressen Standard zu sein. Anbei mal ein Log mit 3 CC Empfängeradressen. In dem Fall wurden alle 3 zugestellt. Empfängerdomain1.de ist die bei all-inkl, die immer funktioniert und die anderen beiden Empfängerdomains liegen bei zwei anderen Hostern.

Code:
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: connect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx]
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: 5DDD659A1CDF: client=pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx], sasl_method=PLAIN, sasl_username=richtigeruser123
Jul 26 02:29:42 h2490037 postfix/cleanup[24196]: 5DDD659A1CDF: message-id=<27c258ab-5d59-15e2-ce8d-c726548e4a29@absenderdomain.de>
Jul 26 02:29:42 h2490037 postfix/qmgr[24121]: 5DDD659A1CDF: from=<office@absenderdomain.de>, size=643, nrcpt=3 (queue active)
Jul 27 08:02:27 h2490037 postfix/submission/smtpd[4139]: disconnect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx] ehlo=2 starttls=1 auth=1 mail=1 rcpt=3 data=1 quit=1 commands=10
Jul 27 08:02:27 h2490037 postfix/smtp[4143]: 5DDD659A1CDF: to=<office@empfängerdomain2.de>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25 delay=0.59, delays=0.44/0.03/0.08/0.04, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 5EEF1C0421C21)
Jul 27 08:02:27 h2490037 postfix/smtp[4143]: 5DDD659A1CDF: to=<werbung@empfängerdomain3.de>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25, delay=0.59, delays=0.44/0.03/0.08/0.04, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 5EEF1C0421C21)
Jul 27 08:02:27 h2490037 postfix/smtp[4143]: 5DDD659A1CDF: to=<support@empfängerdomain4.com>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25 delay=0.59, delays=0.44/0.03/0.08/0.04, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 5EEF1C0421C21)
Jul 27 08:02:27 h2490037 postfix/qmgr[3329]: 5DDD659A1CDF: removed

Bei Einzelversand gibt es dann auch wie zu erwarten zwei verschiedene Logs, das Ergebnis bleibt aber gleich. Empfängerdomain2 wird nicht zugestellt.

Code:
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: connect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx]
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: 086D959A1CDF: client=pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx], sasl_method=PLAIN, sasl_username=richtigeruser123
Jul 26 02:29:42 h2490037 postfix/cleanup[24196]: 086D959A1CDF: message-id=<27c258ab-5d59-15e2-ce8d-c726548e4a29@absenderdomain.de>
Jul 26 02:29:42 h2490037 postfix/qmgr[24121]: 086D959A1CDF: from=<office@absenderdomain.de>, size=608, nrcpt=1 (queue active)
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: disconnect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx] ehlo=2 starttls=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=8
Jul 27 07:52:22 h2490037 postfix/smtp[4105]: 086D959A1CDF: to=<office@empfängerdomain2.de>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25 delay=0.41, delays=0.2/0.02/0.15/0.04, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as D6082C04B22FC)
Jul 27 07:52:22 h2490037 postfix/qmgr[3329]: 086D959A1CDF: removed

Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: connect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx]
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: 8227159A1CDF: client=pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx], sasl_method=PLAIN, sasl_username=richtigeruser123
Jul 26 02:29:42 h2490037 postfix/cleanup[24196]: 8227159A1CDF: message-id=<27c258ab-5d59-15e2-ce8d-c726548e4a29@absenderdomain.de>
Jul 26 02:29:42 h2490037 postfix/qmgr[24121]: 8227159A1CDF: from=<office@absenderdomain.de>, size=608, nrcpt=1 (queue active)
Jul 26 02:29:42 h2490037 postfix/submission/smtpd[24193]: disconnect from pdxxxxxxx.dip0.t-ipconnect.de[2xx.x.xxx.xx] ehlo=2 starttls=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=8
Jul 27 07:52:36 h2490037 postfix/smtp[4105]: 8227159A1CDF: to=<office@empfängerdomain2.de>, relay=mail.absenderdomain.de[xx.ip.xxx.xx]:25, delay=0.24, delays=0.11/0/0.1/0.04, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 356E6C04B22FD)
Jul 27 07:52:36 h2490037 postfix/qmgr[3329]: 8227159A1CDF: removed

Ich werde mal schauen was ich bei all-inkl in Erfahrung bringen kann.
 
#6
kleine Ursache, große Wirkung.
Die Empfängerdomain lag früher mal auf im Hostingpaket der Absenderdomain und nach dem Umzug der Domain hat der alte Provider die Daten unverändert gelassen, u.a. auch die gleichlautende Empfängeremail. Daher wurde die Email nicht an den neuen Provider weitergereicht, sondern intern in das Postfach abgelegt.

Problem ist hiermit gelöst.
 

Werbung

Top