Geschützter Ordner greift nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von bobbybackblech, 1. Okt. 2014.

  1. Verwendet wird nginx

    Ich habe hier in ISPC einen geschützten Ordner, sowie Benutzer angelegt.
    Allerdings scheint das ganze hier nicht zu greifen. Ich komme hier problemlos auf die URL ohne nach einem Nutzer / PW gefragt zu werden.
    Woran könnte das liegen ?
     
  2. Till

    Till Administrator

    Ist das ein nginx oder apache server?
     
  3. Verwendet wird nginx :)
     
  4. Till

    Till Administrator

    Hast Du irgendwelche Direktiven im nginx Direktiven Feld der Webseite? Es kann sein dass die den Passwortschutz aushebeln indem sie einen anderen Zugriffsweg in nginx anlegen.
     
  5. Ja ich habe folgendes drin stehen:

    Code:
    pagespeed off;
    client_max_body_size 100M;
    
    location /phpmyadmin {
                   root /usr/share/;
                   index index.php index.html index.htm;
                   location ~ ^/phpmyadmin/(.+\.php)$ {
                           try_files $uri =404;
                           root /usr/share/;
                           fastcgi_pass unix:/var/run/php5-fpm.sock;
                           fastcgi_index index.php;
                           fastcgi_param SCRIPT_FILENAME $request_filename;
                           include /etc/nginx/fastcgi_params;
                           fastcgi_param PATH_INFO $fastcgi_script_name;
                           fastcgi_buffer_size 128k;
                           fastcgi_buffers 256 4k;
                           fastcgi_busy_buffers_size 256k;
                           fastcgi_temp_file_write_size 256k;
                           fastcgi_intercept_errors on;
                   }
                   location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
                           root /usr/share/;
                   }
            }
            location /phpMyAdmin {
                   rewrite ^/* /phpmyadmin last;
            }
    
    location ~ /(engine|images/[a-z]+|files|templates)/ {
    }
    
    location / {
             index index.html index.php shopware.php;
             rewrite shopware.dll /shopware.php;
             rewrite files/documents/.* /engine last;
             rewrite images/ayww/(.*) /images/banner/$1 last;
             rewrite backend/media/(.*) /media/$1 last;
             if (!-e $request_filename){
                rewrite . /shopware.php last;
             }
    }
    
    location ~ \.(tpl|yml|ini)$ {
             deny all;
    }
    
    location /install/ {
             location /install/assets {
             }
             if (!-e $request_filename){
                rewrite . /install/index.php last;
             }
    }
    
    location /update/ {
             location /update/assets {
             }
             location /update/templates {
             }
             if (!-e $request_filename){
                 rewrite . /update/index.php last;
             }
    }
    
    location /recovery/install/ {
             location /recovery/install/assets {
             }
             if (!-e $request_filename){
                rewrite . /recovery/install/index.php last;
             }
    }
    
    location /recovery/update/ {
             location /recovery/update/assets {
             }
             if (!-e $request_filename){
                rewrite . /recovery/update/index.php last;
             }
    }
    
    ocation @php { ##merge##
                #fastcgi_buffer_size 128k;
                #fastcgi_buffers 256 16k;
                #fastcgi_busy_buffers_size 256k;
                #fastcgi_temp_file_write_size 256k;
                fastcgi_temp_file_write_size 10m;
                fastcgi_busy_buffers_size    512k;
                fastcgi_buffer_size          512k;
                fastcgi_buffers           16 512k;
                fastcgi_read_timeout 1200;
    }
    
     
  6. Ich habe jetzt gerade mal in /etc/nginx/sites-available geschaut.
    Da wird für jede meiner Domains ebenfalls ein vhost.err angelegt.

    Wie kann ich den Fehler überprüfen, welcher in der vhost.err steht ?

    nginx -t gibt keinen Fehler

    Code:
    nginx -t
    [1001/134805:INFO:google_message_handler.cc(35)] No threading detected. Own threads: 1 Rewrite, 1 Expensive Rewrite.
    nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
    nginx: configuration file /etc/nginx/nginx.conf test is successful
    Meine nginx.conf sieht wie folgt aus:

    Code:
    cat nginx.conf
    user www-data;
    worker_processes 4;
    pid /run/nginx.pid;
    
    events {
        worker_connections 768;
        # multi_accept on;
    }
    
    http {
    
        ##
        # Basic Settings
        ##
    
        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        server_tokens off;
    
        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;
    
        include /etc/nginx/mime.types;
        default_type application/octet-stream;
    
        ##
        # Logging Settings
        ##
    
        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;
    
    fastcgi_buffers 32 32k;
    fastcgi_buffer_size 32k;
    ##
    #ngx_pagespeed module settings
    ##
    
    pagespeed on;
    pagespeed XHeaderValue "";
    pagespeed FileCachePath /var/ngx_pagespeed_cache;
    
        ##
        # Gzip Settings
        ##
    
        gzip on;
        gzip_disable "msie6";
    
         gzip_vary on;
         gzip_proxied any;
         gzip_comp_level 6;
         gzip_buffers 16 8k;
         gzip_http_version 1.1;
         gzip_types       text/plain application/xml text/css text/js text/xml application/javascript application/x-javascript text/javascript application/json application/xml+rss;
    
        ##
        # nginx-naxsi config
        ##
        # Uncomment it if you installed nginx-naxsi
        ##
    
        #include /etc/nginx/naxsi_core.rules;
    
        ##
        # nginx-passenger config
        ##
        # Uncomment it if you installed nginx-passenger
        ##
       
        #passenger_root /usr;
        #passenger_ruby /usr/bin/ruby;
    
        ##
        # Virtual Host Configs
        ##
    
        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
    }
    
    
    #mail {
    #    # See sample authentication script at:
    #    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
    #
    #    # auth_http localhost/auth.php;
    #    # pop3_capabilities "TOP" "USER";
    #    # imap_capabilities "IMAP4rev1" "UIDPLUS";
    #
    #    server {
    #        listen     localhost:110;
    #        protocol   pop3;
    #        proxy      on;
    #    }
    #
    #    server {
    #        listen     localhost:143;
    #        protocol   imap;
    #        proxy      on;
    #    }
    #}
    
     
    Zuletzt bearbeitet: 1. Okt. 2014
  7. Till

    Till Administrator

    hier fehlt ein 'l'.
     
    bobbybackblech gefällt das.
  8. Stimmt - Nun klappt es auch :)
     

Diese Seite empfehlen