Gruppe des FTP-Benutzers dauerhaft ändern

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von celocore, 13. März 2009.

  1. celocore

    celocore Member

    Hallo Leute,

    wie es scheint, habe ich mal wieder die berühmten tomaten auf den Augen und ringe mich daher zu diesem Post durch ;-)

    Um TYPO3 mit ISPconfig und FTP-Benutzern richtig ans Laufen zu bekommen, ist es unter anderem notwendig mittel usermod -g www-data <ftp-benutzer> die gruppe des Benutzer auf die gleiche wie die des Webservers zu stellen. Da klappt auch alles wunderbar, nur wird Gruppe des Nutzers regelmäßig wieder auf die vom ISPconfig festgelegte gruppe zurück gesetzt.
    Gibt es da eine Möglichkeit, daß das zurücksetzen verhidnet wird?
     
  2. Till

    Till Administrator

    Nein.

    Wenn der Webserverprozess unter dem user des webs laufen soll dann sollte man am Besten suphp anstatt mod_php nehmen. damit erledigt sich dann auch gleich das Problem mit dem FTP Zugriff und es sit auch sicherer.

    Hier gibt es eine Anleitung dazu.

    http://www.howtoforge.com/install-s...tions-for-use-with-ispconfig-2.2.20-and-above
     
  3. celocore

    celocore Member

    Danke für die Antwort Till.

    Kann ich das ohne Probleme auch auf laufenden Systemen noch im nachhinein umstellen? Sind da evtl. Hürden oder Stolpersteine bekannt?
     
  4. Till

    Till Administrator

    Die Umstellung sollte problemlos auch auf einem laufenden System gehen.
     
  5. paolom007

    paolom007 Member

    rechte und sFTP

    Hallo Till,

    denke mal bei mir szellt sich das selbe Thema. wir versuchen Joomla zu benutzen, wegen den Schreibrechten haben wir erst mal auf www-data:... umgestellt das passt ja erstmal. aber damit kann per FTP-User nicht mehr in die Verzeichnisse geschieben werden, außer man ändert permanet die Rechte.

    Ich nehme mal an das die umstellung auf suPHP die lösung bringt. Weiterhin habe ich das Problem das ich den FTP Zugang für die einzelnen User nur per FTP durchführen kann. sFTP geht da nicht. ist dieser Weg auch die Hilfe dafür?

    Das HowTo ist ja nun schon par Tage alt und ich nehme ann das es mit der aktuellen suPHP 0.71 Version auch funktioniert.

    Ich wollte gleich die Änderung vornehmen und bin aber schon im ersten anlauf ins rudern gekommen.

    Im HowTo soll ert das php5 Modul deaktiviert werden und dann Apache Restart. Der mislingt mit folgender Meldung.

    .... Syntax error in line 61 ..../Vhosts_ispconfig.conf
    .... Invalied command 'php_admin_flag' ... included in the serverconfig
    failed

    ist das normal oder muß ich mir gedanken machen.

    Grüße Paolo

    -------------------------------------------------------
    ispconfig version 2.2.29
    Debian etch nach Perfekt setup
     
  6. Till

    Till Administrator

    ja.

    Nein. SFTP hat nichts mit FTP zu tun, das verwechseln viele. SFTP ist ein Teil des SSH Protokolls und läuft daher über den SSH Daemon und nicht den FTP Daemon. Ich würde Dir nicht raten, SFTP einzusetzen da Du dann allen Usersn SSH Zugriff geben muust. Wenn Du verschlüsseltes FTP haben möchtest dann deaktivier einfach ftps (also FTP über tls) in Deinem FTP Daemon.

    Du kannst keine php_admin_flag mit suphp einsetzen. Wenn Du das irgendwo manuell im apache directives Feld gemacht hast, musst Du es entfernen. Außerdem musst Du noch ispconfihg umstellen und die hosts aktualisieren wie es im tutorial steht.
     
  7. paolom007

    paolom007 Member

    Hallo Till,

    Danke.

    Ich habe in der Hitze des Gefechts die Fehlermeldung falsch abgeschrieben.

    -->
    Genau ist es folgendes: Invalied Command 'php_admin_flag' perhaps misspelled or defined by a modul not included in the server configuration <--

    Das mit dem FTP habe ich noch nicht ganz verstanden.
    - sFTP und ssl ist klar
    das verstehe ich grad nicht, oder stehe eben auf der Leitung

    Was sollte ich machen oder wo sollte ich es machen? ich habe das perfect Setup etch drauf.

    Vielen Dank und Sorry

    Paolo
     
  8. Till

    Till Administrator

  9. paolom007

    paolom007 Member

    Hallo Till,

    Danke super,

    kannst du nochz was zu der Fehlermeldung wegen suPHP sagen die ja eigentlich so ist:

    vielen dank

    eigentlich habe ich nix per Hand gesetzt.

    Paolo
     
    Zuletzt bearbeitet: 20. März 2009
  10. paolom007

    paolom007 Member

    Hallo Till,

    kann es sein das der Fehler normal ist da ja wenn PHP disabled ist auch isp nicht funktioniert?

    also die angemeckerterte Zeile in der vhosts zeigt auf safe_mod Off??

    Vielen Dank

    Paolo
     
    Zuletzt bearbeitet: 20. März 2009
  11. planet_fox

    planet_fox Super-Moderator

    bei welchem system hast du das joomla? und hast du suphp aktiviert? es kann auch sein das ein php flag in der htaccess ist
     
  12. Till

    Till Administrator

    Du musst einfach das machen, was in der Anleitung für Suphp unter ISPConfig steht. Nämlich ispconfig auf suphp in der config.inc.php umschalten und danache ine Web in ispconfig editieren und speichern, damit die Konfiguration neu geschrieben wird.
     
  13. paolom007

    paolom007 Member

    Hallo Till,

    der Fehler resultier aus der Tatsache das auf dem Server schon paar Webs eingerichtet waren und bei diesen PHP angeschaltet war.

    Fazit ist wenn man die Umstellung auf suPHP machen mochte bei einem schon existierenden Server muss man bei allen das PHP für die Zeit der Installation ausschalten dann kommt der Fehler auch nicht und die Installation funktioniert perfekt. Bin dann aber noch darüber gestolpert das ich natürlich die neuste Version(aktuell 0.71) von suPHP installiert habe und danach ging nichts mehr. Aber ein einfaches drüber installieren hat den Fehler beseitigt.

    Das alles könnte man evtl. als Ergänzung mit in das HowTo aufnehmen, für den Fall das jemand die Umstellung bei einen live Server machen möchte.

    Die Punkte sind zwar banal aber man stolpert darüber.

    vielen Dank und Grüße

    Paolo
     
  14. celocore

    celocore Member

    Auf einem Live-System scheint mir das dann doch eher eine Aufgabe für ein langes Wochenende zu sein. Nur für den Fall, dass doch noch was klemmt ;)
     

Diese Seite empfehlen