habe debian lenny 5.0 und ispconfig installiert problem

#1
Notice: Undefined variable: distver in /tmp/ispconfig3_install/install/lib/install.lib.php on line 120

Notice: Undefined variable: distid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 120

Notice: Undefined variable: distbaseid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 120
Linux Distribution or Version not recognized.accessdenied5k:/tmp/ispconfig3_install/install#
was soll ich nun machen ich bin genau der tut entlang gegangen
http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-3/6/
 

one

New Member
#4
Ich habe heute meinen Server neuinstalliert und dann die ispconfig 3.1.1 runtergeladen.
wenn ich die install. php ausführe sieht das so aus:

Code:
ks357358:/usr/src/ispconfig3_install/install# php -q install.php


--------------------------------------------------------------------------------
 _____ ___________   _____              __ _       
|_   _/  ___| ___ \ /  __ \            / _(_)      
  | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _ 
  | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |
 _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| |
 \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, |
                                              __/ |
                                             |___/ 
--------------------------------------------------------------------------------


>> Initial configuration  


Notice: Undefined variable: distver in /usr/src/ispconfig3_install/install/lib/install.lib.php on line 135

Notice: Undefined variable: distid in /usr/src/ispconfig3_install/install/lib/install.lib.php on line 135

Notice: Undefined variable: distbaseid in /usr/src/ispconfig3_install/install/lib/install.lib.php on line 135
Linux Distribution or Version not recognized.ks357358:/usr/src/ispconfig3_install/install#

Distri ist auch Debian Lenny
 

one

New Member
#5
okay, problem gelöst.
debian hat jetzt die version "5.0.1", ispconfig sucht aber nur nach 5.0.

ispconfig3_install/install/lib/install.lib.php mit deinem lieblingstexteditor öffnen,
folgendes suchen:
Code:
                if(trim(file_get_contents('/etc/debian_version')) == '5.0' || trim(file_get_contents('/etc/debian_version')) == 'lenny/sid') {
                        $distname = 'Debian';
                        $distver = 'Lenny/Sid';
                        $distid = 'debian40';
                        $distbaseid = 'debian';
                        swriteln("Operating System: Debian Lenny/Sid or compatible\n");
                }
und 5.0 mit 5.0.1 ersetzten!


tadaa, geht.
 

Till

Administrator
#10
Ich würde nicht zu einem Update auf SVN raten, Du kannst dann später keine normalen Updates mehr einspielen und es kann sein dass dein System beim nächsten Update komplett unbrauchbar wird.

Stattdessen editierst Du lieber die Datei /etc/debian_version und schreibst da 5.0 rein. das kannst Du nach der Installation von ISPConfig auch wieder zurück ändern.
 

planet_fox

Super-Moderator
#11
ja, hab im bugtracker gesehen das der Fehler noch nicht behoben ist. Ansosten gehts hier nur um einen dev server bei mir daheim nicht so das ding weisst und läuft als kvm guest. werde die tage mal editieren wenn ich installier.
 

Werbung

Top