Hilfe, Apache zeigt nicht die erstellten Wespace an

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von vdHeuvel, 28. Feb. 2008.

  1. vdHeuvel

    vdHeuvel New Member

    Hallo Gemeinde,

    nach mehreren test versuchen brauche ich Eure Unterstützung.

    Wie im Titel schon erwähnt zeigt der Webserver die mit ISPConfig v.2.2.21 erstellten Webspace nicht an. Sowohl aus dem LAN wie aus dem WAN!
    Er spring immer in den 'sharedip' Ordner.:(

    Meine Konfiguration:


    (feste IP xx.xx.xx.xx) WAN --------- IPCop ---------- LAN (192.168.16.1/24)
    (10.168.16.1/24)
    |
    |
    DMZ
    ISPConfig
    (10.168.16.5/24)

    Bei meinem Domain Provider habe ich 'mydomain.tld' ein A-Record auf die feste IP eingestellt.

    Der Webserver läuft unter Ubuntu 7.10, den ich nach der Anleitung

    http://www.howtoforge.de/howto/ubuntu-710-gutsy-gibbon-server-installation-lamp-email-dns-ftp-ispconfig/

    installiert habe.

    In der /etc/hosts steht folgendes:

    Code:
    127.0.0.1       localhost.localdomain   localhost 
    'feste IP'     alpha.mydomain.tld        alpha
    Am ende der Installation von ISPConfig v.2.2.21 bei der abfrage der IP habe ich auch die 'feste IP' sowie natürlich im Admin Backend von ISPConfig eingegeben.

    In der 'Vhosts_ispconfig.conf' sieht auch alles rosig aus.

    Code:
    NameVirtualHost 10.168.16.5:80
    <VirtualHost 10.168.16.5:80>
      ServerName localhost
      ServerAdmin root@localhost
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 'feste IP':80
    <VirtualHost 'feste IP':80>
      ServerName localhost
      ServerAdmin root@localhost
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.mydomain.tld:80
    ######################################
    #
    #
    <VirtualHost 87.79.68.55:80>
    SuexecUserGroup web9_stephan web9
    ServerName www.vdh-net.de:80
    ServerAdmin webmaster@vdh-net.de
    DocumentRoot /var/www/web9/web
    ServerAlias vdh-net.de
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web9/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Directory /var/www/web9/web>
      suPHP_Engine on
      suPHP_UserGroup web9_stephan web9
      AddHandler x-httpd-php .php .php3 .php4 .php5
      suPHP_AddHandler x-httpd-php
      SetEnv php_safe_mode On
    </Directory>
    <IfModule mod_ruby.c>
      <Directory /var/www/web9/web>
        Options +ExecCGI
      </Directory>
       RubyRequire apache/ruby-run
      #RubySafeLevel 0
      <Files *.rb>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
      <Files *.rbx>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
    </IfModule>
    Alias /error/ "/var/www/web9/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web9/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web9/user/$1/web/$3
    </VirtualHost>
    Was kann das sein? :confused: Hat einer von Euch eine Idee was das sein kann?

    Habe ich was falsch gemacht?

     
  2. Till

    Till Administrator

    Stell bitte sicher, dass Du auf die Webseiten mit der Domain zugreofst und nicht mit dr IP Adresse. Für die Domain muss ein DNS A-Record existieren, der auf die IP Deines Routers verweist. Außerdem musst Du für die Wenseiten die interne IP Adresse auswählen und nicht die externe IP.
     
  3. Feanwulf

    Feanwulf Member

    Ich behaupte mal dein ISPConfig Server weiß nicht was er mit der Festen IP-Adresse anfangen muß!

    Was passiert wenn du für das Webhosting die interne IP-Adresse vergibst. Eigentlich müsste durch die DMZ alle Anfragen an Port 80 auf den ISPConfig Server umgeleitet werden, da ist es egal welche feste IP-Adresse du hast!

    Wenn du von deinem Provider weitere IP-Adressen bekommen kannst, würde ich dir eh raten am IPCOP NAT auszuschalten für die feste IP-Adresse des Webservers und dann den Webserver mit der festen IP-Adresse direkt zu konfigurieren!
     
  4. vdHeuvel

    vdHeuvel New Member

    Hallo und guten Abend alle zusammen,

    @Till
    Das hatte ich schon getan.:D

    Das war es! :eek:

    Danke!!!
     

Diese Seite empfehlen