Hilfe bei openssl 1.0.2a installation

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Sigix, 20. März 2015.

  1. Sigix

    Sigix Member

    Hallo,
    ich benötige Hilfe zur Installation der aktuellen Version von Openssl 1.0.2a
    derzeit ist die stable Version (OpenSSL 1.0.1e 11 Feb 2013) installiert
    mein Apache (2.2.29) liegt unter /usr/local/apache
    wenn ich Opennssl 1.0.2a installiere und mit "openssl version" prüfe wird die aktuelle Version angezeigt,
    jedoch im phpinfo steht noch immer die openssl 1.0.1e Version

    Was mache ich falsch? Oder was muss man bei der Installation weiters machen?
    Folgendes wurde ausgeführt:
    apt-get remove openssl
    apt-get install zlib1g
    cd /usr/src/
    tar xfz openssl-*.tar.gz
    ./config--prefix=/usr zlib-dynamic--openssldir=/etc/ssl shared
    make
    make test
    make install

    System: Debian GNU/Linux 7.8 (wheezy)

    Besten Dank im Voraus
     
  2. Till

    Till Administrator

    Falls ich mal fragen darf, warum machst Du das? Dir ist bewußt dass Debian und andere Distributionen software patchen ohne die Versionsnummern zu erhöhen, falls Du das also machen möchtest weil Du denkst dass die Version unsicher ist, dann kannst Du Dir das sparen.
     
    F4RR3LL gefällt das.
  3. Sigix

    Sigix Member

    Hallo Till, danke für deine Antwort.... okay dann hat sich dies erledigt!
    Besten Dank
     

Diese Seite empfehlen