hostname vs FQDN

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Brainfood, 8. Apr. 2013.

  1. Brainfood

    Brainfood Member

    ISPConfig läuft in mehreren OpenVZ (Proxmox) Containern, auf einigen Proxmox Kisten habe ich direkt Root-Zugriff (könnte hier also nach den Skripten suchen und eventuell anpassen) auf anderen nur VE administrative Berechtigung.

    ISPConfig läuft auf Debian 6 ohne FTP/Quota.

    /etc/hostname beinhaltet:

    Code:
    servername
    /etc/hosts beinhaltet:

    Code:
    IPv4 hostname.domain.tld hostname
    IPv6 hostname.domain.tld hostname
    nach der ganzen Dienste-Installation/ISPConfig kommen folgende Einträge im /var/log/syslog

    Code:
    Apr  7 14:06:39 servername amavis[1256]: (01256-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=192.168.148.11;port=3306': Host 'servername.domain.tld' is not allowed to connect to this MySQL server
    Apr  7 14:06:39 servername amavis[1256]: (01256-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 103) line 241, <GEN31> line 4.
    Apr  7 14:06:39 servername amavis[1256]: (01256-01) (!)Requesting process rundown after fatal error
    Apr  7 14:06:39 servername amavis[1259]: (01259-01) (!)connect_to_sql: unable to connect to DSN
    
    Apr  7 14:19:27 servername postfix/proxymap[1339]: warning: connect to mysql server 192.168.148.11: Access denied for user 'ispconfig'@'servername.domain.tld' (using password: YES)
    Apr  7 14:19:27 servername postfix/proxymap[1339]: warning: connect to mysql server 192.168.148.11: Access denied for user 'ispconfig'@'servername.domain.tld' (using password: YES)
    Jetzt habe ich nun alle benötigten DBISPCONFIG/ISPCONFIG MySQL Benutzer für die unterschiedlichen Schnittstellen freigeschaltet:

    Code:
    CREATE USER 'root'@'192.168.148.11' IDENTIFIED BY 'GEHEIM'; GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.148.11' IDENTIFIED BY 'GEHEIM' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'servername.domain.tld' IDENTIFIED BY 'GEHEIM'; GRANT ALL PRIVILEGES ON * . * TO 'root'@'servername.domain.tld' IDENTIFIED BY 'GEHEIM' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    und

    Code:
    CREATE USER 'ispconfig'@'192.168.148.11' IDENTIFIED BY 'GREP_GEHEIM'; GRANT SELECT, INSERT, UPDATE, DELETE ON dbispconfig. * TO 'ispconfig'@'192.168.148.11' IDENTIFIED BY 'GREP_GEHEIM' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'ispconfig'@'servername' IDENTIFIED BY 'GREP_GEHEIM'; GRANT SELECT, INSERT, UPDATE, DELETE ON dbispconfig. * TO 'ispconfig'@'servername' IDENTIFIED BY 'GREP_GEHEIM' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'ispconfig'@'servername.domain.tld' IDENTIFIED BY 'GREP_GEHEIM'; GRANT SELECT, INSERT, UPDATE, DELETE ON dbispconfig. * TO 'ispconfig'@'servername.domain.tld' IDENTIFIED BY 'GREP_GEHEIM' WITH MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    das Passwort hab ich mir aus:
    Code:
    /usr/local/ispconfig/interface/lib/config.inc.php
    gegrept.

    Die Fehlermeldungen sind weg und es scheint alles soweit zu laufen, Till du hattest in dem anderen Beitrag noch erwähnt, dass es zu Problemen im MySQL Multiserver Setup/Cluster kommen würde?
     
  2. Till

    Till Administrator

    Genau. Und Du hast einen der Fehler ja auch oben selbst beschrieben. Der slave löst nämlich bei der Installation den Hostnamen des masters über die entsprechenden Linux api's auf und erhält korrekterweise den fqdn. Dieser wird dann in die mysql DB auch richtig eingetragen, den internen hostnamen des masters kann ein externer Sever auch garnicht in Erfahrung bringen. Leider ist mysql dann aber zu blöd wenn eine Anfrage von extern kommt diesen auch gegen den korrekten externen record abzugleichen sondern mysql nimmt dann den internen hostnamen weshalb anfragen fehlcshlagen wenn Du die hosts Datei nicht wie in der Anleitung beschrieben nur die fqdn enthalten.

    Ein weiteres Problem dass auftauchen kann ist dass amavisd nicht startet weil er auch nur mit fqdn läuft.
     

Diese Seite empfehlen