.htaccess funktioniert nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Anon, 3. Juni 2014.

  1. Anon

    Anon New Member

    Moin!

    Normalerweise finde ich immer eine Lösung aber hier komme ich seit Stunden nicht mehr weiter, was auf der Arbeit irgendwie etwas doof ist. ^^

    Ich habe heute meinen stärkeren VPS erhalten und natürlich sofort die Haupteinrichtung durchgeführt. Danach Roundcube, Munin und Monit und noch Nameserver erstellt.

    Jetzt müsste ich nur das Rootverzeichnis, Munin und PHPmyAdmin mit einer htaccess sichern... denn die Sicherung von Monit (Tutorial oben verlinkt) funktioniert. Der Rest nicht. In erster Linie ist das Root Verzeichnis am wichtigsten.

    Natürlich habe ich die ganze Zeit gegoogelt und zum einen heißt es in die Vhosts "AllowOverride All" einzustellen - hilft nicht. Zum anderen die Berechtigungen 644 und 755 auf die .ht Dateien - funktioniert auch nicht. Sowie "AllowOverride All" global in die apache2.conf - auch nicht. Ausserdem den error-log anschauen - auch nichts zum Thema .htaccess.

    Ich hoffe ihr könnt mir hier helfen. :eek:

    MfG
     
  2. Anon

    Anon New Member

    Problem besteht immernoch.
     
  3. wotan2005

    wotan2005 Member

    Nach den Anpassungen auch den Apache restart gemacht?
     
  4. Anon

    Anon New Member

    Schon mehrfach. ^^
     
  5. Till

    Till Administrator

    Wie und wo hast Du denn "AllowOverride All" eingestellt?
     
  6. Anon

    Anon New Member

    Also, ich habe gerade nochmal nachgeguckt, meinte nicht apache2.conf.

    Ich habe bei
    Code:
    vi /etc/apache2/sites-available/HOMEPAGE.vhost
    :
    Code:
    <Directory /var/www/HOMEPAGE>
                    AllowOverride All
                                    Order Deny,Allow
                    Deny from all
                    </Directory>
    [...]
    <Directory /var/www/HOMEPAGE/web>
                                    Options +FollowSymLinks
                                    AllowOverride All
                                                                    Order allow,deny
                                    Allow from all
                                                    </Directory>
                    <Directory /var/www/clients/client0/web2/web>
                                    Options +FollowSymLinks
                                    AllowOverride All
                                                                    Order allow,deny
                                    Allow from all
                                                    </Directory>
    (Komplette Config HIER.)

    Und in
    Code:
    vi /etc/apache2/sites-available/ispconfig.conf
    :
    Code:
    <Directory /var/www/clients>
        AllowOverride All
                    Order Deny,Allow
            Deny from all
            </Directory>
    [...]
    
    <Directory /usr/share/phpmyadmin>
                            Order allow,deny
            Allow from all
                    </Directory>
    <Directory /usr/share/phpMyAdmin>
                            Order allow,deny
            Allow from all
                    </Directory>
    
    [...]
    
    <Directory /usr/lib/mailman/cgi-bin>
                            Order allow,deny
            Allow from all
                    </Directory>
    
    (Komplette Config HIER.)

    MfG
     
  7. Till

    Till Administrator

    Ok, also hast Du bislang kein "AllowOverride All" für die von Dir genannten Dienste aktiviert, denn diesesind ja nicht in einer ispconfig webseite installiert. Du legst Dir eine neue Datei an:

    /etc/apache2/sites-available/overrides.conf

    und dort fügst Du die Konfiguration für die Verzeichnisse ein. Z.b.:

    <Directory /usr/share/phpmyadmin>
    AllowOverride All
    </Directory>

    und dann aktivierst Du die Config indem Du einen Symlink erstellst:

    ln -s /etc/apache2/sites-available/overrides.conf /etc/apache2/sites-enabled/overrides.conf

    und dann apache neu starten.
     

Diese Seite empfehlen