htaccess Indexes Problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Feanwulf, 23. Nov. 2007.

  1. Feanwulf

    Feanwulf Member

    Hallo,

    ich wollte das ein Kunde eine .htaccess Datei mit

    Code:
    Options +Indexes
    
    in seinem WEB Verzeichnis ablegt, damit die Dateien angezeigt werden. Da erhält er immer einen Internal Server Error

    Dann habe ich im Webinterface
    Code:
    <Directory /var/www/web72/web/>
    Options +Indexes Includes
    </Directory>
    
    eingetragen. Da gibt es keinen Fehler aber auch kein Directorylisting

    error_log schreibt:
    Code:
    [Fri Nov 23 16:38:32 2007] [error] [client 81.92.5.72] Directory index forbidden by Options directive: /var/www/web72/web/Video/
    
    was muß ich machen, daß entweder die Lösung im ISP Config Webinterface klappt, ODER noch besser das mit der .htaccess datei
     
  2. Till

    Till Administrator

    Du musst das Setzen von "Indexes" für .htaccess Dateien in der apache2.conf erlauben. Der relevante Teil ist am Ende, Du musst das AllowOverride für /var/www/*/web/ ändern.
     
  3. ekleist

    ekleist New Member

    Anpassung der httpd.conf

    Die httpd.conf wie folgt anpassen damit man mit .htaccess Dateien das Directory Listing selektiv einschalten kann. (Options muss aktiviert sein);)

    Code:
    <Directory /srv/www/*/web>
        Options +Includes -Indexes
        AllowOverride none
        ## entweder mit all alle Direktivgruppen erlauben oder die Gruppen einzeln angeben
        ##AllowOverride All
        AllowOverride Indexes AuthConfig Limit FileInfo Options
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    weiteres unter: http://httpd.apache.org/docs/1.3/mod/core.html#allowoverride
     
  4. juergen71

    juergen71 Member

    Also ich weis nicht aber irgendwie bekomm ich das nicht auf die Reihe, ich habe auf Ubuntu 8.04 folgenden Eintrag im Apache File (apache2.conf):

    <Directory /var/www/*/web>
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>


    wenn ich aber ein .htaccess mit dem inhalt

    Options +Indexes

    erstelle dann bekomm ich folgende fehlermeldung im logfile:

    /var/www/web273/web/.htaccess: Options not allowed here


    Gruß
    Jürgen
     
  5. Till

    Till Administrator

    Hast Du den Eintrag:

    <Directory /var/www/*/web>
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>


    vielleicht mehrfach in der apache2.conf? Das kann passieren, wenn das Setup bei der ISPConfig Installation mal abgebrochen ist. Dann findest Du am Ender der apache2.conf einen sich wiederholenden Bereich von Einträgen, lösche dann bitte die doppelten Sachen.

    Vergiß bitte bicht, apache nach den Änderungen neu zu starten.
     
  6. juergen71

    juergen71 Member

    Hallo Till,

    also ich habe folgende Einträge gefunden:

    <Directory /var/www/*/web>
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /var/www/*/user/*/web/>
    Options +Includes -Indexes
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /var/www/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>


    davon überlagert meiner Meinung nach keiner den Betreffenden Eintrag oder irre ich mich da?

    Gruß
    Jürgen
     
  7. Till

    Till Administrator

    Ja, das ist richtig.

    Den Apache neu gestartet hattest Du nach Deinen Änderungen?

    Sonst versuch mal testweise Folgendes:

    <Directory /var/www/*/web>
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>


    um das Problem weiter einzugrenzen.
     

Diese Seite empfehlen