htaccess

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von vpns2000, 4. Jan. 2008.

  1. vpns2000

    vpns2000 Member

    Hallo,
    ich habe seit kurzem das Problem das die Authentifzierung für die Bereiche stats und awstats nicht mehr funktionieren.
    Also wenn ich www.domain.tld/stats eingebe werde ich nicht mer nach usernamen und Passwort gefragt. Ich kann aber nicht sagen warum das so ist. Ich habe weder Updates gemacht noch sonstiges. Das einzige das ich gemacht habe das ich für eine Domain ein SSL Zertifikat beantragt und eingespielt habe.

    Kann mir jemand sagen was da falsch gelaufen ist???

    DANKE
     
  2. Till

    Till Administrator

    Scahu mal nach, ob noch eine .htaccess datei in den Stas Verzeichnissen steht. das geht z.B. mit dem Befehl:

    ls -la

    der auch versteckte Dateien anzeigt.
     
  3. vpns2000

    vpns2000 Member

    Hallo Herr Till,
    danke für Ihre Antwort.
    Also es ist bei allen Domains die .htaccess file vorhanden.
    Die Berechtigung steht auf 644.

    Das was mich ein wenig irritiert ist das es bei allen 5 Domains das selbe ist.
    wenn ich eine Domain aufrufe und das stats verzeichnis wechsel werde ich bei keiner nach einem user oder password gefragt obwohl bei allen das file vorhanden ist. Ich habe auch das log durchsucht und kann keinen Fehler finden.

    LG.
     
  4. Till

    Till Administrator

    Dann sind vermutlich .htaccess dateien in det apache Konfigurationsdatei deaktiviert worden, so dass die .haccess dateien jetzt nicht mehr ausgewertet werden.
     
  5. vpns2000

    vpns2000 Member

    hallo,
    also ich kann mich nicht erinnern irgend etwas zu deaktiviert zu haben.
    in der httpd.conf steht:
    Code:
    # 
    # AccessFileName: The name of the file to look for in each directory
    # for additional configuration directives.  See also the AllowOverride
    # directive.
    #     
    AccessFileName .htaccess
    
    #   
    # The following lines prevent .htaccess and .htpasswd files from being
    # viewed by Web clients.
    #
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    
    
    Danke für deine hilfe.
    LG
     
  6. Till

    Till Administrator

    Ok. Aus welcher httpd.conf Datei ist der obige Ausschnitt? Außerdem poste bitte mal den Inhalt einer der .htaccess Dateien.
     
  7. vpns2000

    vpns2000 Member

    Hallo,
    also das ist der Inhalt aus der /etc/httpd/conf/httpd.conf.
    der Inhalt der .hataccess ist:

    Code:
    
    AuthType Basic
    AuthName "Members Only"
    AuthUserFile /home/www/web2/.htpasswd
    <limit GET PUT POST>
    require valid-user
    </limit>
    
    
    Weiters besteht auch die .htpasswd deren inhalt so aus sieht:

    Code:
    
    web2_xxx_xxxxx:12345abcdefgh
    
    
    habe das Posting etwas verändert aber in etwa sieht es so aus.

    Nach dem ich eigentlich sehr selten in die Statistik schaue kann ich eigentlich gar nicht mit Sicherheit sagen seit wann das Problem besteht.
    Ich glaube aber das es seit dem update auf 2.2.18 nicht mehr geht. denn früher hat es funktioniert.


    Danke!

    LG
     
    Zuletzt bearbeitet: 7. Jan. 2008
  8. Till

    Till Administrator

    Die obigen Dateien sind in Ordnung. Da das der einzige Teil ist den ISPConfig daran hat, ist es sehr unwahrscheinlich, dass es am 2.2.18 Update liegt.

    Da der Eintrag in Deiner httpd.conf soweit auch ok ist, fällt mir da im Moment nichts weiter zu ein.
     

Diese Seite empfehlen