HTTPS Standard-VHost

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von win_tho, 16. März 2013.

  1. win_tho

    win_tho Member

    Hallo zusammen,

    nutze ISPC auf einem Standard Debian 6.0 System. Nun tritt folgendes Problem auf: Auf einer Website ist HTTPS aktiviert und arbeitet auch korrekt.

    https://website1.de

    Wenn ich nun jedoch die anderen Webseiten aufrufe (die nicht per HTTPS konfiguriert sind) sehe ich immer den Inhalt von Webseite 1

    https://website2.de --> Inhalt von https://website1.de
    https://website3.de --> Inhalt von https://website1.de

    Bin schon mal alle vhost Dateien unter /etc/apache2/sites-enabled durchgegangen, es gibt nur in der Datei von Website1 einen Eintrag mit 443.

    Aktiviere ich zum Test mal default-ssl bekomme ich aber auch die Meldung, dass der Default HTTPS-Host überlappt.

    Hat jemand eine Idee, was hier falsch läuft. ISPC läuft auf Port 8080
     
  2. Till

    Till Administrator

    Hast Du bie webseite1 * oder die IP ausgewählt?
     
  3. win_tho

    win_tho Member

    Hallo Till,

    es ist * ausgewählt, da noch gar keine IP im System angelegt war. Werde ich mal ausprobieren... Danke für den Tipp
     
  4. win_tho

    win_tho Member

    Hmm, bringt leider keine Besserung: Kann es vielleicht daran liegen, dass ich nur eine IP habe? Habe leider diesbezüglich keinerlei Infos in eurem Handbuch gefunden :(
     
  5. Till

    Till Administrator

    wechsel die einstellung auf die ip und aktiviere dann den ssl default vhost.
     

Diese Seite empfehlen