IMAP Zugriff wird abgewiesen

#1
Habe auf einem Debian 5.0 Server zuerst ISPConfig2 und dann ISPConfig3 eingerichtet, habe dabei hoffentlich nichts durcheinandergewürfelt.
Bzgl. ISBConfig2 bin ich nach diesem Howto vorgegangen:
http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-2/7/
ISBConfig3 nach diesem Howto:
http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3-p5
Habe vor der Installation von ISPConfig3 beide Hoto's verglichen und versucht, die Installataion von Version 2 soweit Rückgängig zu machen, wie ich die entsprechenden Schritte in Version 3 nicht gefunden habe.
Nun habe ich das Problem, dass die Mailuser sich nicht am Postfach anmelden können:
Im ISPConfig Webfrontend habe ich die Maildomain www.sunlife-estates.com angelegt, die einen anderen Namen als die Domain des Webservers www.winnersblog.eu hat. Für die Maildomain habe ich einen User angelegt.
In Kmail habe ich den entsprechenden Account angelegt:
Als Eingangs-Mailserver habe ich angegeben: imap.winnersblog.eu
Da beim Zugriff ein Zertifikat geladen wird gehe ich davon aus, dass der Zugriff auf den Server funktioniert.
Im Autorisierungsdialog bei der Abfrage der Mail werde ich nach dem Passwort gefragt, wenn ich das zur Mailadresse passende Passwort eingebe erscheint die Meldung:
p, li { white-space: pre-wrap; }*Authentifizierung fehlgeschlagen, Anmeldung nicht möglich. Wahrscheinlich ist das Passwort falsch.
Antwort des Servers imap.winnersblog.eu:
Login failed. wird nicht unterstützt
Als Sichheitseinstellungen habe ich "TLS für sicheres Abholen" und "Einfacher Text" gewählt, dies hat Kmail nach einem Test des Servers vorgeschlagen.


Im auth.log steht:
Jan 23 21:29:46 srv1 saslauthd[8161]: pam_unix(imap:auth): check pass; user unknown
Jan 23 21:29:46 srv1 saslauthd[8161]: pam_unix(imap:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
Jan 23 21:29:48 srv1 saslauthd[8161]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module
Jan 23 21:29:48 srv1 saslauthd[8161]: do_auth : auth failure: [service=imap] [realm=] [mech=pam] [reason=PAM auth error]
Jan 23 21:30:01 srv1 CRON[25857]: pam_unix(cron:session): session opened for user getmail by (uid=0)[/quote]Die main.cf
[quote]smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
# Alte EInträge deaktiviert:
#smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
#smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
# Statt dessen eingefügt:
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
# Ab hier wieder Original:
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
myhostname = srv1.winnersblog.eu
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = srv1.winnersblog.eu, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

#Neu eingefügt:
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtu$
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

#War bereits vorhanden:
myorigin = /etc/mailname
inet_protocols = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_m$
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0[/quote]Dann habe ich noch probiert:
[quote]srv1:/media# testsaslauthd -u [EMAIL="m.p@sunlife-estates.com"]m.p@sunlife-estates.com[/EMAIL] -p 4$s2g!
0: NO "authentication failed"[/quote]
Wer hat eine Idee, warum der Zugriff nicht klappt?
Im Voraus vielen Dank für alle Tipps!
 

Till

Administrator
#2
Das ISPConfig 2 Hoato ist mit ispconfig 3 nicht kompatibel, daher läuft Dein Server auch nicht. Wenn der Server einmal für ISPConfig 2 konfiguriert war, kann ispconfig 3 nicht mehr installiert werden bzw. es wird nicht funktionieren. Die schnellste Lösung ist es, den Server neu zu formatieren und exakt nach dem ispconfig 3 tutorial neu zu installieren.
 

Werbung

Top