INFO: ClamAV Zwangsabschaltung 0.94 und frühere

Dieses Thema im Forum "Allgemein" wurde erstellt von Evilchen, 8. Apr. 2010.

  1. Evilchen

    Evilchen New Member

    Nachdem nun die neuste Version von ClamAV erschienen ist (0.96),
    hat das Team um den Virenscanner einen Termin zur Zwangsabschaltung älterer Versionen kommuniziert.
    Ab dem 15.04.2010 werden Signaturen verteilt, welche alle noch in Betrieb befindliche Versionen bis einschließlich 0.94 vom Signaturupdate ausschließen.

    Die veralteten Versionen haben, nach Entwickleraussagen, einen Bug beim inkrementellen Update der Signaturen wodurch nur Updates bis zu einer Größe von 980 Byte empfangen werden können. Zukünftige inkrementelle Updates werden diese Größe jedoch überschreiten.

    Da mit Version ISPConfig 2.2.31 ClamAV Version 0.95 verteilt wurde, sollten alle Anwender älterer Versionen dringend updaten.
    Die aktuelle Version ist ISPConfig 2.2.35 (Stand 08.04.2010)

    Siehe zu ClamAV den Artikel auf golem:
    http://www.golem.de/1004/74332.html

    Grüße,
    Evilchen
     
  2. Falcon37

    Falcon37 New Member

    Danke für die Info. [​IMG]
     
  3. Laubie

    Laubie Member

    und heute morgen wirds dann wirklich interessant.

    Heute (naja, oder irgendwann letzte nacht) lief das erste Update raus, welches ClamAV 0.94 nicht mehr versteht.
    Der clamd - Dienst beendet sich und lässt sich nicht mehr starten :(

    Also, wer sich nicht sicher ist, welche Version läuft, sollte heute mal kurz in die MailQ gucken ;)

    Grüße
    Laubie
     
  4. pee

    pee New Member

    Hi,

    Debian legt ja besonderen Wert auf alte stabile Software. Finde es jedoch krass, wenn die Software in den Lenny Standardrepos (wie bei Clamav) so alt ist, dass Sie "end of life" erreicht.

    Damit konnten heute Morgen bei mir keine E-Mails versendet und abgerufen werden. Dieses Problem hatten offenbar viele andere Serverbetreiber weltweit. Das nenne ich fail. Ich werde darüber nachdenken, ob nicht Ubuntu in Zukunft eine bessere Lösung darstellt.

    Zum Glück bin ich auf die Lösung unter http://www.computerbase.de/forum/showthread.php?p=7696021 gestossen:

    Code:
    $ echo “deb [URL]http://volatile.debian.org/debian-volatile[/URL]   lenny/volatile main contrib non-free” >> /etc/apt/sources.list
     $ apt-get update
    $ apt-get install clamav
    $ apt-get upgrade
    $ /etc/init.d/amavis restart
     - – - – - –> virus-check will work (no guarantee – for me worked  it  fine [IMG]http://openwallet.de/wp-includes/images/smilies/icon_wink.gif[/IMG]  )
    DO NOT FORGET TO ENABLE VIRUSSCAN IF YOU DISABLED IT! 			 		
    Nach dem Clamav Update funktioniert das E-Mail Verteilen wieder problemlos.

    HAND
     
  5. brain-scc

    brain-scc New Member

  6. hahni

    hahni Active Member

    Ich setze die neueste Version von ISPConfig ein (2.2.35) und den clamd von Ubuntu 8.04LTS. So recht verstehe ich jetzt leider aufgrund der oberen Posts nicht, ob ich betroffen bin oder nicht. Und falls ja, was ich tun kann?
     
  7. Till

    Till Administrator

    Du bist nicht betroffen, da ISPConfig 2 ein neueres ClamAV mitbringt. Die obigen Posts zu Debian Lenny beziehen sich auf ISPConfig 3, da es kein eigenes ClamAV mitbringt.
     
  8. hahni

    hahni Active Member

    Hallo Till,

    ich benutze aber clamd von der Ubuntu 8.04LTS-Distribution und nicht das von ISPConfig eingesetzte ClamAV. Von daher war ich mir da nicht so sicher?!?

    Viele Grüße

    Hahni
     
  9. Falcon37

    Falcon37 New Member

  10. pee

    pee New Member

    Probier mal die Lösung von meinem letzten Post. Scheint deinem Post ähnlich zu sein, aber Probieren schadet nicht. Vielleicht hattest du bei deinem Versuch ja einen Tippi.
     
  11. sence123

    sence123 New Member

    same Prob

    Hallo Forum,

    ich hab das selbe Problem mit Ubuntu..... und ispconfig 3

    bevor ich nun irgendwas zerschiesse, wie gehe ich am besten unter ubuntu vor?

    danke :/
     
  12. pee

    pee New Member

    Ohne die genaue Ubuntu-Versionsnummer und die Fehlermeldungen (Hinweise hierzu stehen bereits im Thread), ist eine Hilfestellung schwierig. Hole dies bitte nach.
     
  13. sence123

    sence123 New Member

    ups

    sry ok:

    Ubuntu 8.10 kernel version: 2.6.27-7-server


    .
    Apr 19 11:02:18 ha-mailone amavis[4241]: (04241-04-6) (!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory) at (eval 100) line 309.; ClamAV-clamscan av-scanner FAILED: /usr/bin/clamscan unexpected exit 50, output="LibClamAV Warning: ***********************************************************\nLibClamAV Warning: *** This version of the ClamAV engine is outdated. ***\nLibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***\nLibClamAV Warning: ***********************************************************\nLibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)\nLibClamAV Error: Problem parsin...
    Apr 19 11:02:18 ha-mailone amavis[4241]: (04241-04-6) (!!)...g database at line 742\nLibClamAV Error: Can't load daily.ndb: Malformed database\nLibClamAV Error: cli_tgzload: Can't load daily.ndb\nLibClamAV Error: Can't load /var/lib/clamav//daily.cld: Malformed database\nERROR: Malformed database" at (eval 100) line 527.


    danke ,)
     
  14. Laubie

    Laubie Member

    hast du denn dein ubuntu mit apt-get update / upgrade aktuell gehalten?

    wenn ja, zeig mal deine sources.list
     
  15. Falcon37

    Falcon37 New Member

    Thx @pee scheint wieder zu gehen. Aber mailq | wc -l zeigt nur den Wert "30" und der Befehl freshclam zeigt das ich die alte Version habe.

    Code:
    ClamAV update process started at Mon Apr 19 15:55:56 2010
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.95.3 Recommended version: 0.96
    Ist das normal?
     
  16. Laubie

    Laubie Member

    Japp.
    Selbst in dem "volatile" - oder wie das heisst ist - ist nicht das aktuelle Clam drin.
    Aber die 95er verkraftet schon die großen Updates. Also alles i.o.

    Grüße
    Laubie
     

Diese Seite empfehlen