Installationsproblem mit jailkit-2.15

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Klassenschlechtester, 15. Apr. 2013.

  1. Hallo,
    seit gestern versuche ich den jaikit auf einem debian server 2.6.x zu installieren, aber das will einfach nicht klappen.

    nach "./configure" kommt folgendes:
    Code:
    root@server:/tmp/jailkit-2.15# make
    make[1]: Entering directory `/tmp/jailkit-2.15/src'
    gcc -g -O2 -Wall -pipe -pthread -DINIPREFIX=\"/etc/jailkit\"   -c -o jk_socketd.o jk_socketd.c
    gcc -g -O2 -Wall -pipe -pthread -DINIPREFIX=\"/etc/jailkit\"   -c -o jk_lib.o jk_lib.c
    gcc -g -O2 -Wall -pipe -pthread -DINIPREFIX=\"/etc/jailkit\"   -c -o utils.o utils.c
    gcc -g -O2 -Wall -pipe -pthread -DINIPREFIX=\"/etc/jailkit\"   -c -o iniparser.o iniparser.c
    gcc  -lcap  -o jk_socketd jk_socketd.o jk_lib.o utils.o iniparser.o
    jk_socketd.o: In function `main':
    /tmp/jailkit-2.15/src/jk_socketd.c:474: undefined reference to `pthread_create'
    collect2: ld returned 1 exit status
    make[1]: *** [jk_socketd] Error 1
    make[1]: Leaving directory `/tmp/jailkit-2.15/src'
    make: *** [all] Error 2
    root@server:/tmp/jailkit-2.15# ls -l /usr/bin/gcc*
    lrwxrwxrwx 1 root root   16 Apr 15 08:17 /usr/bin/gcc -> /usr/bin/gcc-4.4
    lrwxrwxrwx 1 root root   19 May  9  2012 /usr/bin/gcc-4.1 -> hardened-cc
    lrwxrwxrwx 1 root root   19 May  9  2012 /usr/bin/gcc-4.2 -> hardened-cc
    lrwxrwxrwx 1 root root   19 May  9  2012 /usr/bin/gcc-4.3 -> hardened-cc
    lrwxrwxrwx 1 root root   19 May  9  2012 /usr/bin/gcc-4.4 -> hardened-cc
    -rwxr-xr-x 1 root root 250K Nov 15  2010 /usr/bin/gcc-4.4.real
    lrwxrwxrwx 1 root root   19 May  9  2012 /usr/bin/gcc-4.5 -> hardened-cc
    
    lt. den hier The Perfect Server - Ubuntu 11.10 [ISPConfig 3] - Page 4 | HowtoForge - Linux Howtos and Tutorials sollte ich mit der Umbenennung des Links weiterkommen. Aber wie oben zu sehen ist das nicht so einfach.

    Ich habe auch den anderen Weg mit dpkg versucht - ebenfalls kommen dann diese Fehlermeldungen. Die Pakete sind installiert:
    Code:
    apt-get install build-essential autoconf automake1.9 libtool flex bison debhelper
    
    Alle in der neuesten Version vorhanden. :confused:
     

Diese Seite empfehlen