integrierte Backup-Funktion sichert Dateien nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von die-andis, 16. Sep. 2015.

  1. die-andis

    die-andis Member

    Hallo Zusammen,

    für einer der Webseiten die ich über ISPCONFIG administriere, wird bei der integrierten Backup-Funktion das Backup für die Dateien nicht angelegt (Einstellung: täglich, 10 Sicherungen, keine auszuschließenden Verzeichnisse). Es werden hier nur die Datenbanken gesichert. Bei anderen Webseites auf dem gleichen Server funktioniert alles einwandfrei.

    Was könnte das sein?

    Gruß
    Andreas
     
  2. Till

    Till Administrator

    ist zip und sudo installiert?
     
  3. die-andis

    die-andis Member

    ja ist beides installiert. Für andere Websites auf der gleichen ISPCONFIG Installation funktioniert es auch, nur für diese eine Seite nicht
     
  4. florian030

    florian030 Member

    Nur mal so auf Verdacht: reicht der temp-space für die Backups? Kannst Du die komplette seite "konventionell" packen?
     
  5. die-andis

    die-andis Member

    ja das klappt. das Archiv ist ca. 21 GB groß
     
  6. florian030

    florian030 Member

    Nutzt Du zip oder tar? zip-Backups werden mit dem jeweiligen web-user angelegt und als temp-dir wird /tmp genutzt. Es kann schon sein, dass entweder /tmp nicht genug Platz hat oder Du in quotas läufst.
     
  7. die-andis

    die-andis Member

    zip und tar funktioniert wenn ich es manuell mache. Im ISPCONFIG Backup werden ja für die Dateien ZIP´s erstellt
     
  8. florian030

    florian030 Member

    Es kann auch sein, dass die Einträge zu der Domain in web_domain nicht passen. Also falsche server_id oder kein type vhost oder vhostsubdomain. Das kannst Du bspw. mit phpmyadmin nachsehen.
    Oder der Platz auf dem Ziellaufwerk reicht nicht. Ruf doch mal zip so auf:
    Code:
    cd $web_path && sudo -u $web_user find . -group $web_group -print 2> /dev/null | zip -b /tmp --symlinks $web_backup_dir/$web_backup_file -@
    Mir sind keine Probleme mit den Web-Backups bekannt.
     
  9. die-andis

    die-andis Member

    Server_id und Type passt beides. In der Datenbank sehen die Einträge der Domains "identisch" aus.
    Der Server selbst hat noch ca. 1,1 TB freien Speicher.

    der Aufruf des Code bringt "error nothing to do".
     
  10. florian030

    florian030 Member

    Du musst schon die Variablen ($IRGENDWAS) mit den richtigen Werten anpassen. Hast Du /tmp auf einer eigenen Partition?
     
  11. Adegrue

    Adegrue New Member

    Hi Leute !:D
     

Diese Seite empfehlen