INTRAnet Hosting, DNS + Domain Fragen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von he-du, 30. Okt. 2009.

  1. he-du

    he-du New Member

    Hi,

    also ich möchte mit ISPConfig 3 für unsere Abteilungen hier in der Firma Webspace fürs intranet bereitstellen.
    Nun ist es so das die DNS Verwaltung natürlich nicht der ISPConfig server macht sondern einer unserer Windows Server.

    Ich möchte auf dem ISPconfig server dann den abteilungen accounts einrichten die dann über abteilung.firma.de erreichbar sind.
    Auf dem DNS ist dafür natürlich der DNS eintrag abteilung.firma.de eingerichtet. Wie muss ich das dann auf dem ISPC Server einrichten, das automatisch die passenden Ordner und die VHOST einstellungen vorgenommen werden?
    Ich kann zwar die domain anlegen, die ist dann aber immer nur für einen account eingerichtet und kann von anderen natürlich nicht mehr verwendet werden.

    Zu dem bekomme ich beim neustart vom apache2 immer folgende fehlermeldung:

    Code:
    /etc/init.d/apache2 restart
    Restarting web server: apache2[Fri Oct 30 07:24:26 2009] [warn] NameVirtualHost XXXXX:443 has no VirtualHosts
     ... waiting ................[Fri Oct 30 07:24:56 2009] [warn] NameVirtualHost XXXXXXX:443 has no VirtualHosts
    .
    
    Kann mir da jemand helfen?

    Gruß
    he-Du
     
  2. Quest

    Quest Member

    In ISP3 hast du ja voneinander unabhängige Module.
    DNS und Website agieren vollständig selbstständig.
    Du kannst die Seiten einfach unter Sites anlegen und die DNS Konfiguration weglassen.
    Sobald eine Site mit einer Domain eingerichtet ist reagiert der Apache auf den Domainnamen. Egal welcher DNS den Namen aufgelöst hat.

    Als Domainnamen für die Sites kannst du statt der normalen Domain firma.de problemlos auch abteilung.firma.de eingeben. So kann jede Abteilung ihr eigenes Konto bekommen.

    Ich hab bei einer Seite auf der ich viel entwickel und voneinander unabhängige Installationen brauche (der Übersicht halber) folgende Sites für eine Domain eingerichtet:
    domain.de (Mit Mailkonten, subdomains wie www, ect. LiveSite halt)
    dev.domain.de
    beta.domain.de

    Funktioniert einwandfrei.
    Diese Sites kannst du dann unterschiedlichen Accounts zuweisen und fertig.

    Zu der Fehlermeldung:
    Unter System->Edit Server IP kannst du eine Option 'HTTP NameVirtualHost' setzen.
    Hast du da bei der IP den haken drin?
    Wenn ja erwartet der Server, dass dieser IP eine Site zugewiesen wird.
    Wird keine zugewiesen, dann kommen fehlermeldungen wie diese.
     
  3. he-du

    he-du New Member

    ah thx ok das hat geholfen. Jez hab ich aber das nächste problem.
    aktuell wird nur die korrekte seite angezeigt wenn ich den FQDN aufrufe. Ich will aber im Browser nicht jedesmal den FQDN eingeben normal reicht es bei uns wenn ich nur abteilung eingebe.
    also "Abteilung" anstat "Abteilung.firma.de" Muss ich das manuell in jeder vhost eintragen oder kann ich ispconfig das irgendwie beibringen das er das für mich übernimmt?
     
  4. Quest

    Quest Member

    Das ist erst mal kein Webseiten- sondern ein DNS problem.

    Wenn du abteilung.firma.de eingibst fragt der Brower ja erst mal beim DNS nach der IP-Adresse des Servers.

    Wenn du nur abteilung eingeben willst müsstest du also im DNS eine Domain mit dem Namen 'abteilung' eintragen.
    Das selbe müsstest du dann als Aliasdomain zu der Site in ISP3 hinzufügen.
    Ich weiß aber nicht, ob der DNS und ISP eine Domain ohne Endung akzeptieren.
    Zur Not könntest du ja auch so was wie abteilung.intra oder so verwenden.
     
  5. he-du

    he-du New Member

    also das problem habe ich erst seit dem ich das system auf ISPconfig am umstellen bin. Vorher habe ich die vhost konfiguration mit webmin gemacht da hatte ich keine probleme. Auch bei anderen servern gibts keine probleme.

    ISP config nimmt leider keine domain die einfach "abteilung" lauten an da sagt er mir ungültige domain.

    edit:
    so müsste ers anlegen... dann gehts auch
    Code:
     ServerName qa-wiki
     ServerAlias qa-wiki.firma.de
    
     
    Zuletzt bearbeitet: 30. Okt. 2009
  6. Quest

    Quest Member

    Wie ich schon geschrieben habe hab ich die Vermutung, dass ISP3 als Hosting Control System nur gültige Domains mit Topleveldomain akzeptiert.
    Das hast du mir ja gerade bestätigt. Ich selbst habs noch nie ausprobiert.
    Ich nehme an eure Firmendomain ist zu lang um sie jedes mal mitzutippen.
    Ist es keine Option, dass die Domains eben in Zukunft so aussehen:
    qa-wiki.intra
    Das müsste ISP ja wieder akzeptieren, besitzt ja wieder eine Topleveldomain.
     
  7. he-du

    he-du New Member

    müsste ich abklähren.
    Zur not muss halt bei jedem account halt die VHOST datei angepasst werden. Blöde nur das er die jedes mal neugeneriert wenn man änderungen am account vornimmt. Bedeutet nach jeder änderung muss diese neu angepasst werden.
    Aber sind ja im prinzip nur 2 einstellungen

    Aber riesen dank für deine hilfe :)
     
  8. Till

    Till Administrator

    Normalerweise nimmt man für interne Domains sowas wie .int oder .intra oder .local wie von Quest vorgeschlagen.

    Dann ändere doch einfach das master template.
     
  9. he-du

    he-du New Member

    naja normalerweise haben wir halt intern adressen mit
    *.kürzel.firmenname.de
    Auch unsere domänen heißen so. Ich hab das ganze auch nicht zu entscheiden ich bin nur Azubi ;)

    Wo kann man denn das master template ändern?? ich bin noch relativ neu bei ISPconfig.
     
  10. Till

    Till Administrator

    Diese Domains sind doch auch OK, da sie korrekte FQDN sind. Du kannst ja durchaus abc..kürzel.firmenname.dein ISPConfig nehmen. Aber eben nicht nur abc da es ein fqdn sein muss.
     
  11. he-du

    he-du New Member

    das ist aber zu lang um das jedesmal einzutippen daher nehmen wir meist einfach nur das was davor steht. auflösen tut der DNS es
     

Diese Seite empfehlen