IP Problem - ISPConfig 2.2.27 und debian lenny

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von sven, 31. Okt. 2008.

  1. sven

    sven New Member

    Hallo,

    ich habe habe ISPConfig 2.2.27 unter debian lenny installiert und habe Probleme die IP - Adressen über ISPConfig einzurichten.

    Die Ips werden im backend angezeigt, aber nicht im System konfiguriert. Macht es Sinn die Ips in der /etc/interfaces händig einzurichten, oder kann
    das dann später zu Problemen führen?

    Vielen Dank und Grüße
    Sven
     
  2. Till

    Till Administrator

    Die Konfiguration der IP Adressen ist in ISPConfig standardmäßig deaktiviert, da ISPConfig nur Setups mit einer Netzwerkkarte (eth0) konfigurieren kann. Wenn Du nur eine Netzwerkkarte hast, kannst Du die automatische IP Konfiguration in der Datei /home/admispconfig/ispconfig/lib/config.inc.php aktivieren. Ansonsten müsstest Du die Konfiguration in /etc/network/interfaces manuell vornehmen.
     
  3. sven

    sven New Member

    Ich habe jetzt die folgende Zeile auf 1 gesetzt

    $go_info["server"]["network_config"] = 1; // 0 = none, 1 = automatic

    Hat auf Anhieb funktioniert. Danke und Grüße.
     
  4. rawe28

    rawe28 New Member

    Hallo Sven,

    ich habe den selben Eintrag vorgenommen wie Du, weiß jetzt aber nicht, mit welchem Befehl ich die Sache starten muß.

    Könntest Du mir bitte weiterhelfen?

    Gruß

    Ralph
     
  5. Till

    Till Administrator

    Du musst eine IP in ISPConfig hinzufügen oder löschen.
     
  6. rawe28

    rawe28 New Member

    Danke, werde es gleich mal versuchen.

    Gruß

    Ralph
     
  7. rawe28

    rawe28 New Member

    Problem - ISPConfig 2.2.27 und debian lenny

    Hallo Till,
    ( ich bin jetzt nicht sicher, ob ich das Thema hier weiterführen soll oder nicht, weil mein Problem ja eigentlich ist, das die IP-Adressen erreichbar sind, der Domainname aber nicht. Unter Debian-etch.)

    Ich hab also alle IP´s aus dem Subnetz in ISPConfig gelöscht, die Dienste alle neu gestrtet und einen Reboot ausgeführt.

    Die IP´s wurden bis auf eine , die letzte; auch richtig erkannt. Nur besteht das Problem nach wie vor unverändert.

    Kannst Du hier anschauen, wenn Du möchtest.

    http://78.46.254.178/
    http://78.46.254.181/
    http://78.46.254.177/
    http://78.46.254.179
    http://78.46.254.180/

    Über´s Wochenende hab ich schon alles mögliche ausprobiert, kriege es aber nicht gebacken.

    Hast Du eine Ahnung, was es sein könnte?

    Gruß

    Ralph
     
  8. rawe28

    rawe28 New Member

    Habe vergessen zu sagen, daß sich Proftpd und manchmal auch Bind, nicht aus ISPConfig heraus starten lassen. Dies muß ich immer über die Kommandozeile machen. Bei diesen beiden Diensten erhalte ich auch keine Warnung, wnn sie nicht laufen. Beim Apache schon
     
  9. Till

    Till Administrator

    Dann überprüfe docj mal mittels dig befehl, ob die Domain auf die neue IP verweist.
     
  10. rawe28

    rawe28 New Member

    Hab jetzt die DNS-Einträge in ISPConfig gemacht und jetzt sind die Domainnamen auch pingbar. Das waren sie vorher nicht.
    Trotzdem lassen sie sich noch nicht aufrufen.
    Inder /apache2/httpd.conf habe ich die virtuellen Hosts indieser Form angelegt
    Hab auch alle Dienste neu gestartet und einen Reboot gemacht. Die Domain ist trotzdem noch nicht erreichbar. Wo mach ich den Fehler?


    Gruß

    Ralph

    Nachtrag:
    @Till
    antworte mal noch nicht auf die Fragen, ich glaube, das Problem löst sich gerade.
    Ich melde mich dann, wenn ich soweit bin.
     
    Zuletzt bearbeitet: 4. Nov. 2008
  11. sven

    sven New Member

    Ich bin gerade dabei ISPconfig3 zu testen. Schaut bisher super aus. Nur leider bekomme ich die automatische IP Konfiguration nicht hin, bzw. finde die passende Config nicht.

    Kannst Du mir bitte den entsprechenden Config-Pfad nennen, bzw. den Parameter den ich ändern muss?

    Viele Dank.

    Sven
     
  12. Till

    Till Administrator

    Du hast Dich hier an einen ISPConfig 2 thread ran gehängt. ISPConfig 2 ist eine komplett andere Software als ISPConfig 3, somit sind alle Antworten dieses Threads für ISPConfig 3 nicht relevant.

    In ISPConfig 3 machst Du einfach unter system > server config auf dem server tab bei Netzwerk Konfiguration einen Haken. Das wird aber nur für debian linux und ubuntu unterstützt.
     
  13. sven

    sven New Member

    Danke hat wunderbar geklappt.
     

Diese Seite empfehlen