IPv6 Verständnisfrage

Dieses Thema im Forum "Server Administration" wurde erstellt von neurex, 22. Feb. 2012.

  1. neurex

    neurex Member

    Hallo zusammen :)

    bisher habe ich IPv4 und IPv6 immer im Dual-Stack-Modus gefahren was auch sehr gut funktionierte.

    Nun richte ich aber gerade einen Server nur auf Basis von IPv6 ein und komme an einer Stelle nicht weiter. Connections zu Servern welche eine IPv6 haben gehen ohne Probleme aber keine welche nur eine IPv4 haben. Warum nicht? Ich dachte IPv6 sei zu IPv4 abwärtskompatibel.

    Ist es überhaupt möglich von einem reinen IPv6 Server auf IPv4 Adressen zuzugreifen? Wenn ja wo müsste dort der ansatzpunkt zum konfigurieren sein?

    Nutze OpenSuse 12.1 als System...

    Vielen Dank für eure Hilfe :)
     
  2. neurex

    neurex Member

    Also so wie ich das jetzt mittlerweile herausgefunden habe benötige ich wohl einen 4to6 Tunnel um auf meinem IPv6 only System auch IPv4 Adressen erreichbar zu machen.

    Hat jemand hier zufällig schonmal soetwas eingerichtet? Wenn ja wie bzw. womit? Hatte zuerst freenet6 als Tunnelbrocker angedacht, bekomme aber absolut keine Verbindung zu denen.
     
  3. neurex

    neurex Member

    So, nachdem ich leider immernoch keine vernünftige Lösung für mein Problem gefunden habe und mir bis auf zwei mittlerweile alle IPv4-Adressen ausgegangen sind und mir auch keine neuen in Aussicht gestellt wurden wird es nun eindeutig Zeit das Problem zu beheben.

    Soweit ich weiß sollte IPv6 ja abwärtskompatibel sein, sprich ich sollte auch IPv4-Adressen weiterhin nutzen können. Aktuell setze ich überwiegend das Dual-Stack Verfahren ein (sprich IPv4 und IPv6 auf einem Rechner) was auch sehr gut funktioniert. Wenn der Rechner gegenüber IPv6 unterstützt wird alles über IPv6 abgewickelt, wenn nicht eben auf IPv4.

    Mein Problem liegt aber an einem Rechner welcher nur eine IPv6-Adresse hat. Theoretisch müsste ich von diesem ohne weiteres auf Inhalte zugreifen können welche nur über IPv4 erreichbar sind. Theoretisch wie gesagt in der Praxis funktioniert das nur nicht.

    Hab ich irgendetwas falsch verstanden oder ist das grundsätzlich nicht so einfach möglich?
     
  4. nowayback

    nowayback Well-Known Member

  5. neurex

    neurex Member

    Nicht ganz. Hab das gestern eingerichtet mit NAT64 und es klappt wie geplant...

    Trotzdem danke :)
     

Diese Seite empfehlen